summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2004-08-19 15:38:53 +0000
committerRenat Lumpau <rl03@gentoo.org>2004-08-19 15:38:53 +0000
commit8681d55f9cefd5e60f4dbc01d6514f71241acf9d (patch)
tree59ce2ad544d65cc53b74a2c8a35ebda3fe1ead41 /www-apps/phpwiki/phpwiki-1.2.4.ebuild
parentStable on x86 for the fix of CGI:Session's insecure permission issue. See bug... (diff)
downloadgentoo-2-8681d55f9cefd5e60f4dbc01d6514f71241acf9d.tar.gz
gentoo-2-8681d55f9cefd5e60f4dbc01d6514f71241acf9d.tar.bz2
gentoo-2-8681d55f9cefd5e60f4dbc01d6514f71241acf9d.zip
Initial ebuild
Diffstat (limited to 'www-apps/phpwiki/phpwiki-1.2.4.ebuild')
-rw-r--r--www-apps/phpwiki/phpwiki-1.2.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/www-apps/phpwiki/phpwiki-1.2.4.ebuild b/www-apps/phpwiki/phpwiki-1.2.4.ebuild
new file mode 100644
index 000000000000..2ed75c211630
--- /dev/null
+++ b/www-apps/phpwiki/phpwiki-1.2.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpwiki/phpwiki-1.2.4.ebuild,v 1.1 2004/08/19 15:38:53 rl03 Exp $
+
+inherit webapp
+
+DESCRIPTION="PhpWiki is a WikiWikiWeb clone in PHP"
+HOMEPAGE="http://phpwiki.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="$DEPEND"
+RDEPEND="virtual/php
+ net-www/apache"
+
+src_install() {
+ webapp_src_preinst
+
+ cp -a *.php admin images lib locale pgsrc templates \
+ "${D}/${MY_HTDOCSDIR}"
+
+ dodoc DBLIB.txt CREDITS ChangeLog LICENSE README INSTALL.*
+ UPGRADING.readme schemas/*
+
+ webapp_serverowned ${MY_HTDOCSDIR}/lib/dbalib.php
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_src_install
+}