summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-08-15 15:47:05 +0000
committerStuart Herbert <stuart@gentoo.org>2004-08-15 15:47:05 +0000
commita220887940e1934c6d074681e70a228a260f32ee (patch)
tree6bb5b2ae8480935018a23667b2a6fc4ed405745d /www-apps/trac/trac-0.6.1.ebuild
parentMoved from net-www/tikiwiki to www-apps/tikiwiki (diff)
downloadgentoo-2-a220887940e1934c6d074681e70a228a260f32ee.tar.gz
gentoo-2-a220887940e1934c6d074681e70a228a260f32ee.tar.bz2
gentoo-2-a220887940e1934c6d074681e70a228a260f32ee.zip
Moved from net-www/trac to www-apps/trac.
Diffstat (limited to 'www-apps/trac/trac-0.6.1.ebuild')
-rw-r--r--www-apps/trac/trac-0.6.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/www-apps/trac/trac-0.6.1.ebuild b/www-apps/trac/trac-0.6.1.ebuild
new file mode 100644
index 000000000000..a77a302c155a
--- /dev/null
+++ b/www-apps/trac/trac-0.6.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/trac/trac-0.6.1.ebuild,v 1.1 2004/08/15 15:47:05 stuart Exp $
+
+inherit webapp
+
+DESCRIPTION="Trac is a minimalistic web-based project management, wiki and bug/issue tracking system."
+HOMEPAGE="http://trac.edgewall.com/"
+SRC_URI="http://ftp.edgewall.com/pub/trac/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+inherit distutils
+
+DEPEND="$DEPEND
+ >=dev-lang/python-2.1
+ >=dev-util/subversion-1.0.0
+ >=dev-python/pysqlite-0.4.3
+ >=dev-libs/clearsilver-0.9.3"
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL PKG-INFO README RELEASE THANKS UPGRADE"
+
+src_install () {
+ webapp_src_preinst
+ distutils_src_install
+ dodoc ${DOCS}
+
+ # now, we have to turn this into something that webapp-config can use
+
+ local my_dir=${D}/usr/share/trac
+ mv ${my_dir}/cgi-bin/trac.cgi ${D}${MY_CGIBINDIR} || die
+ rm -rf ${my_dir}/cgi-bin || die
+ mv ${my_dir}/htdocs/* ${D}${MY_HTDOCSDIR} || die
+ rm -rf ${my_dir}/htdocs || die
+
+ webapp_postinst_txt en ${FILESDIR}/postinst-en.txt
+
+ # the trac dir itself needs to be server-owned
+ # this should do the trick
+
+ webapp_serverowned ${MY_HTDOCSDIR}
+
+ # okay, we're done - let webapp.eclass finish off
+ webapp_src_install
+}