summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-10-05 11:17:04 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-10-05 11:17:04 +0000
commit3b90b472edbc2f6f3ad5b21f00c6d10b895e52a2 (patch)
tree58da263faeb03d10a983e825399050238c160e29 /www-apps
parentUse LyX for lyx files. (diff)
downloadgentoo-2-3b90b472edbc2f6f3ad5b21f00c6d10b895e52a2.tar.gz
gentoo-2-3b90b472edbc2f6f3ad5b21f00c6d10b895e52a2.tar.bz2
gentoo-2-3b90b472edbc2f6f3ad5b21f00c6d10b895e52a2.zip
QA: calculate configuration only once to make sure that the dependency check and the actual configuration are in sync; this should address bug #385595.
(Portage version: 2.2.0_alpha60/cvs/Linux x86_64)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/rt/ChangeLog6
-rw-r--r--www-apps/rt/rt-3.8.10.ebuild47
2 files changed, 29 insertions, 24 deletions
diff --git a/www-apps/rt/ChangeLog b/www-apps/rt/ChangeLog
index 5be650b8620d..a1c8dfdbe299 100644
--- a/www-apps/rt/ChangeLog
+++ b/www-apps/rt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apps/rt
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/ChangeLog,v 1.64 2011/10/04 18:21:29 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/ChangeLog,v 1.65 2011/10/05 11:17:04 flameeyes Exp $
+
+ 05 Oct 2011; Diego E. Pettenò <flameeyes@gentoo.org> rt-3.8.10.ebuild:
+ QA: calculate configuration only once to make sure that the dependency check
+ and the actual configuration are in sync; this should address bug #385595.
04 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> rt-3.6.7.ebuild:
ppc keywords dropped wrt #385591
diff --git a/www-apps/rt/rt-3.8.10.ebuild b/www-apps/rt/rt-3.8.10.ebuild
index 63d14509781c..8c07a09838c7 100644
--- a/www-apps/rt/rt-3.8.10.ebuild
+++ b/www-apps/rt/rt-3.8.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/rt-3.8.10.ebuild,v 1.3 2011/10/04 17:56:21 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/rt-3.8.10.ebuild,v 1.4 2011/10/05 11:17:04 flameeyes Exp $
inherit webapp eutils depend.apache confutils
@@ -150,24 +150,35 @@ src_unpack() {
}
src_compile() {
- local web="apache"
- use lighttpd && web="lighttpd"
-
- local dbtype dba
+ local web myconf depsconf
if use mysql; then
- dbtype="--with-db-type=mysql"
- dba="--with-db-dba=root"
+ myconf+=" --with-db-type=mysql --with-db-dba=root"
+ depsconf+=" --with-mysql"
fi
if use postgres;then
- dbtype="--with-db-type=Pg"
- dba="--with-db-dba=postgres"
+ myconf+=" --with-db-type=Pg --with-db-dba=postgres"
+ depsconf+=" --with-postgresql"
fi
if use postgres && use mysql; then
ewarn "Both mysql and postgres USE flags enabled, default is mysql."
ewarn "You can set the default value in RT_SiteConfig before DB init."
- dbtype="--with-db-type=mysql"
- dba="--with-db-dba=root"
+ myconf+=" --with-db-type=mysql --with-db-dba=root"
+ depsconf+=" --with-mysql"
+ fi
+
+ if use fastcgi ; then
+ myconf+=" --with-web-handler=fastcgi"
+ web="apache"
+ depsconf+=" --with-fastcgi"
+ elif use lighttpd ; then
+ myconf+=" --with-web-handler=fastcgi"
+ web="lighttpd"
+ depsconf+=" --with-fastcgi"
+ else
+ myconf+=" --with-web-handler=modperl2"
+ web="apache"
+ depsconf+=" --with-modperl2"
fi
./configure --enable-layout=Gentoo \
@@ -177,20 +188,10 @@ src_compile() {
--with-rt-group=rt \
--with-web-user=${web} \
--with-web-group=${web} \
- ${dbtype} ${dba}
+ ${myconf}
# check for missing deps and ask to report if something is broken
- local myconf="--verbose \
- $(enable_extension_withonly mysql mysql) \
- $(enable_extension_withonly postgresql postgres) \
- $(enable_extension_withonly fastcgi fastcgi) \
- $(enable_extension_withonly fastcgi lighttpd)" \
-
- if ! use fastcgi && ! use lighttpd; then
- myconf="${myconf} --with-modperl2"
- fi
-
- /usr/bin/perl ./sbin/rt-test-dependencies ${myconf} > "${T}"/t
+ /usr/bin/perl ./sbin/rt-test-dependencies ${depsconf} > "${T}"/t
if grep -q "MISSING" "${T}"/t; then
ewarn "Missing Perl dependency!"
ewarn