summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-11 23:37:15 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-11 23:37:15 +0000
commit56f5f2c56edb8d5329591acea026c25f3d2e00c4 (patch)
treecf78d2c4882d345c21377cbc4fed32bafd590b67 /www-apps
parentStable for HPPA (bug #280514). (diff)
downloadgentoo-2-56f5f2c56edb8d5329591acea026c25f3d2e00c4.tar.gz
gentoo-2-56f5f2c56edb8d5329591acea026c25f3d2e00c4.tar.bz2
gentoo-2-56f5f2c56edb8d5329591acea026c25f3d2e00c4.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
(Portage version: 14000-svn/cvs/Linux x86_64)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/viewvc/ChangeLog8
-rw-r--r--www-apps/viewvc/viewvc-1.1.2.ebuild111
2 files changed, 118 insertions, 1 deletions
diff --git a/www-apps/viewvc/ChangeLog b/www-apps/viewvc/ChangeLog
index 7b2f5fb03926..6859f5f07790 100644
--- a/www-apps/viewvc/ChangeLog
+++ b/www-apps/viewvc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/viewvc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/viewvc/ChangeLog,v 1.30 2009/07/27 22:34:33 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/viewvc/ChangeLog,v 1.31 2009/08/11 23:37:15 arfrever Exp $
+
+*viewvc-1.1.2 (11 Aug 2009)
+
+ 11 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +viewvc-1.1.2.ebuild:
+ Version bump. Set SUPPORT_PYTHON_ABIS.
27 Jul 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
viewvc-1.1.1.ebuild:
diff --git a/www-apps/viewvc/viewvc-1.1.2.ebuild b/www-apps/viewvc/viewvc-1.1.2.ebuild
new file mode 100644
index 000000000000..48ad1742b313
--- /dev/null
+++ b/www-apps/viewvc/viewvc-1.1.2.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/viewvc/viewvc-1.1.2.ebuild,v 1.1 2009/08/11 23:37:15 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit confutils eutils python webapp
+
+WEBAPP_MANUAL_SLOT="yes"
+
+DESCRIPTION="ViewVC, a web interface to CVS and Subversion"
+HOMEPAGE="http://viewvc.org/"
+SRC_URI="http://viewvc.tigris.org/files/documents/3330/46489/${P}.tar.gz"
+
+LICENSE="viewcvs"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="cvs cvsgraph mod_python mysql pygments +subversion"
+SLOT="0"
+
+DEPEND=""
+RDEPEND="
+ cvs? (
+ >=dev-lang/python-1.5.2
+ app-text/rcs
+ )
+
+ subversion? (
+ >=dev-lang/python-2.0
+ >=dev-util/subversion-1.3.1[python]
+ )
+
+ mod_python? ( www-apache/mod_python )
+ !mod_python? ( virtual/httpd-cgi )
+
+ cvsgraph? ( >=dev-util/cvsgraph-1.5.0 )
+ mysql? ( >=dev-python/mysql-python-0.9.0 )
+ pygments? ( dev-python/pygments )
+"
+
+RESTRICT_PYTHON_ABIS="3*"
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ confutils_require_any cvs subversion
+}
+
+src_prepare() {
+ find bin/ -type f -print0 | xargs -0 sed -i \
+ -e "s|\(^LIBRARY_DIR\)\(.*\$\)|\1 = \"$(python_get_sitedir)/${PN}\"|g" \
+ -e "s|\(^CONF_PATHNAME\)\(.*\$\)|\1 = \"../conf/viewvc.conf\"|g"
+
+ sed -i -e "s|\(self\.options\.template_dir\)\(.*\$\)|\1 = \"${MY_APPDIR}/templates\"|" \
+ lib/config.py
+
+ sed -i -e "s|^template_dir.*|#&|" conf/viewvc.conf.dist
+ mv conf/viewvc.conf{.dist,}
+ mv conf/cvsgraph.conf{.dist,}
+ mv conf/mimetypes.conf{.dist,}
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGES COMMITTERS INSTALL README
+ dohtml -r viewvc.org/*
+
+ installation() {
+ insinto "$(python_get_sitedir)/${PN}"
+ doins -r lib/*
+ }
+ python_execute_function installation
+
+ insinto "${MY_APPDIR}"
+ doins -r templates/
+
+ if use mysql; then
+ exeinto "${MY_HOSTROOTDIR}"/bin
+ doexe bin/{*dbadmin,make-database,loginfo-handler}
+ fi
+
+ insinto "${MY_HOSTROOTDIR}"/conf
+ doins conf/{viewvc,cvsgraph,mimetypes}.conf
+
+ if use mod_python; then
+ insinto "${MY_HTDOCSDIR}"
+ doins bin/mod_python/viewvc.py
+ doins bin/mod_python/handler.py
+ doins bin/mod_python/.htaccess
+ use mysql && doins bin/mod_python/query.py
+ else
+ exeinto "${MY_CGIBINDIR}"
+ doexe bin/cgi/viewvc.cgi
+ use mysql && doexe bin/cgi/query.cgi
+ fi
+
+ webapp_configfile "${MY_HOSTROOTDIR}"/conf/{viewvc,cvsgraph}.conf
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+ python_mod_optimize viewvc
+ elog "Now read INSTALL in /usr/share/doc/${PF} to configure ${PN}"
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}