summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2010-02-23 22:54:11 +0000
committerLance Albertson <ramereth@gentoo.org>2010-02-23 22:54:11 +0000
commit6cde065493a8a748dfd71467126caa9f8e917719 (patch)
tree4cb809cb91253a1bbc6d6765ed5fe8a6129af859 /www-apps
parentImprove ebuild to build also reference implementation. (diff)
downloadgentoo-2-6cde065493a8a748dfd71467126caa9f8e917719.tar.gz
gentoo-2-6cde065493a8a748dfd71467126caa9f8e917719.tar.bz2
gentoo-2-6cde065493a8a748dfd71467126caa9f8e917719.zip
New package: cgit (#223339)
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/cgit/ChangeLog12
-rw-r--r--www-apps/cgit/cgit-0.8.3.1.ebuild55
-rw-r--r--www-apps/cgit/files/cgitrc122
-rw-r--r--www-apps/cgit/files/postinstall-en.txt15
-rw-r--r--www-apps/cgit/metadata.xml16
5 files changed, 220 insertions, 0 deletions
diff --git a/www-apps/cgit/ChangeLog b/www-apps/cgit/ChangeLog
new file mode 100644
index 000000000000..f04392f17897
--- /dev/null
+++ b/www-apps/cgit/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for www-apps/cgit
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/cgit/ChangeLog,v 1.1 2010/02/23 22:54:11 ramereth Exp $
+
+*cgit-0.8.3.1 (20 Feb 2010)
+
+ 20 Feb 2010; Lance Albertson <ramereth@gentoo.org> +cgit-0.8.3.1.ebuild,
+ +files/cgitrc, +files/postinstall-en.txt, +metadata.xml:
+ Initial ebuild
+
+ Thanks to everyone who helped in #223339 for contributing to the ebuild.
+
diff --git a/www-apps/cgit/cgit-0.8.3.1.ebuild b/www-apps/cgit/cgit-0.8.3.1.ebuild
new file mode 100644
index 000000000000..135480018f0c
--- /dev/null
+++ b/www-apps/cgit/cgit-0.8.3.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/cgit/cgit-0.8.3.1.ebuild,v 1.1 2010/02/23 22:54:11 ramereth Exp $
+
+EAPI="2"
+
+inherit webapp
+
+GIT_V="1.6.4.3"
+
+DESCRIPTION="a fast web-interface for git repositories"
+HOMEPAGE="http://hjemli.net/git/cgit/about/"
+SRC_URI="mirror://kernel/software/scm/git/git-${GIT_V}.tar.bz2
+ http://hjemli.net/git/cgit/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cgi"
+
+RDEPEND="dev-util/git
+ sys-libs/zlib
+ dev-libs/openssl
+ cgi? ( virtual/httpd-cgi )"
+DEPEND="${RDEPEND}
+ app-text/asciidoc"
+
+src_prepare() {
+ rmdir git
+ mv "${WORKDIR}"/git-"${GIT_V}" git
+}
+
+src_compile() {
+ emake || die "emake died"
+ emake man-doc || die "emake man-doc died"
+}
+
+src_install() {
+ webapp_src_preinst
+
+ mv cgit cgit.cgi
+ if use cgi -o use fastcgi ; then
+ cp cgit.cgi "${D}"/${MY_CGIBINDIR}
+ fi
+ insinto ${MY_HTDOCSDIR}
+ doins cgit.css cgit.png
+ insinto /etc
+ doins "${FILESDIR}"/cgitrc
+ dodir /var/cache/cgit
+ keepdir /var/cache/cgit
+ dodoc README
+ doman cgitrc.5
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}
diff --git a/www-apps/cgit/files/cgitrc b/www-apps/cgit/files/cgitrc
new file mode 100644
index 000000000000..cbf6150a9685
--- /dev/null
+++ b/www-apps/cgit/files/cgitrc
@@ -0,0 +1,122 @@
+# Enable caching of up to 1000 output entriess
+#cache-size=1000
+
+
+# Specify some default clone prefixes
+#clone-prefix=git://foobar.com ssh://foobar.com/pub/git http://foobar.com/git
+
+# Specify the css url
+#css=/css/cgit.css
+
+
+# Show extra links for each repository on the index page
+#enable-index-links=1
+
+
+# Show number of affected files per commit on the log pages
+#enable-log-filecount=1
+
+
+# Show number of added/removed lines per commit on the log pages
+#enable-log-linecount=1
+
+
+# Add a cgit favicon
+#favicon=/favicon.ico
+
+
+# Use a custom logo
+#logo=/img/mylogo.png
+
+
+# Enable statistics per week, month and quarter
+#max-stats=quarter
+
+
+# Set the title and heading of the repository index page
+#root-title=foobar.com git repositories
+
+
+# Set a subheading for the repository index page
+#root-desc=tracking the foobar development
+
+
+# Include some more info about foobar.com on the index page
+#root-readme=/var/www/htdocs/about.html
+
+
+# Allow download of tar.gz, tar.bz2 and zip-files
+#snapshots=tar.gz tar.bz2 zip
+
+
+##
+## List of common mimetypes
+##
+
+#mimetype.git=image/git
+#mimetype.html=text/html
+#mimetype.jpg=image/jpeg
+#mimetype.jpeg=image/jpeg
+#mimetype.pdf=application/pdf
+#mimetype.png=image/png
+#mimetype.svg=image/svg+xml
+
+
+##
+## List of repositories.
+## PS: Any repositories listed when section is unset will not be
+## displayed under a section heading
+## PPS: This list could be kept in a different file (e.g. '/etc/cgitrepos')
+## and included like this:
+## include=/etc/cgitrepos
+##
+
+
+#repo.url=foo
+#repo.path=/pub/git/foo.git
+#repo.desc=the master foo repository
+#repo.owner=fooman@foobar.com
+#repo.readme=info/web/about.html
+
+
+#repo.url=bar
+#repo.path=/pub/git/bar.git
+#repo.desc=the bars for your foo
+#repo.owner=barman@foobar.com
+#repo.readme=info/web/about.html
+
+
+# The next repositories will be displayed under the 'extras' heading
+#section=extras
+
+
+#repo.url=baz
+#repo.path=/pub/git/baz.git
+#repo.desc=a set of extensions for bar users
+
+#repo.url=wiz
+#repo.path=/pub/git/wiz.git
+#repo.desc=the wizard of foo
+
+
+# Add some mirrored repositories
+#section=mirrors
+
+
+#repo.url=git
+#repo.path=/pub/git/git.git
+#repo.desc=the dscm
+
+
+#repo.url=linux
+#repo.path=/pub/git/linux.git
+#repo.desc=the kernel
+
+# Disable adhoc downloads of this repo
+#repo.snapshots=0
+
+# Disable line-counts for this repo
+#repo.enable-log-linecount=0
+
+# Restrict the max statistics period for this repo
+#repo.max-stats=month
diff --git a/www-apps/cgit/files/postinstall-en.txt b/www-apps/cgit/files/postinstall-en.txt
new file mode 100644
index 000000000000..94280c80b66f
--- /dev/null
+++ b/www-apps/cgit/files/postinstall-en.txt
@@ -0,0 +1,15 @@
+There is a few variants of configuration:
+1) Via global config file: /etc/cgitrc
+2) Or via local config file, shipped in ./conf dir into webapp_dir. It has to
+ be explicitly specified with CGIT_CONFIG env variable in your web server
+ configuration.
+
+If you would like to update the list of git repositories in cgit automatically,
+you might consider adding something similar to the following as a cronjob:
+
+"${MY_CGIBINDIR}/cgit.cgi --scan-tree=/git/repo-parent-path > /etc/cgit-repos"
+
+Then add "include=/etc/cgit-repos" in /etc/cgitrc. This way it's simpler and
+more convenient. You won't need to update your cgitrc every time you add a new
+repository.
+
diff --git a/www-apps/cgit/metadata.xml b/www-apps/cgit/metadata.xml
new file mode 100644
index 000000000000..1a0aafdde74b
--- /dev/null
+++ b/www-apps/cgit/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>web-apps</herd>
+ <maintainer>
+ <email>ramereth@gentoo.org</email>
+ <name>Lance Albertson</name>
+ </maintainer>
+ <longdescription lang="en">
+ cgit - cgi for git
+
+ This is an attempt to create a fast web interface for the git scm, using a
+ builtin cache to decrease server io-pressure.
+ </longdescription>
+</pkgmetadata>
+