summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-07-24 21:00:41 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-07-24 21:00:41 +0000
commitb424030027c42b50158663d611a0eb1d43b446fb (patch)
tree7f211c9d1f71c2c08335407a980fd08c3a8e986d /www-apps
parentHousekeeping (diff)
downloadgentoo-2-b424030027c42b50158663d611a0eb1d43b446fb.tar.gz
gentoo-2-b424030027c42b50158663d611a0eb1d43b446fb.tar.bz2
gentoo-2-b424030027c42b50158663d611a0eb1d43b446fb.zip
Version bump
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/mantisbt/ChangeLog7
-rw-r--r--www-apps/mantisbt/files/digest-mantisbt-1.0.43
-rw-r--r--www-apps/mantisbt/mantisbt-1.0.4.ebuild38
3 files changed, 47 insertions, 1 deletions
diff --git a/www-apps/mantisbt/ChangeLog b/www-apps/mantisbt/ChangeLog
index 409f30eacc23..173bfe437ec1 100644
--- a/www-apps/mantisbt/ChangeLog
+++ b/www-apps/mantisbt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/mantisbt
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.32 2006/07/24 20:57:31 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.33 2006/07/24 21:00:41 rl03 Exp $
+
+*mantisbt-1.0.4 (24 Jul 2006)
+
+ 24 Jul 2006; Renat Lumpau <rl03@gentoo.org> +mantisbt-1.0.4.ebuild:
+ Version bump
24 Jul 2006; Renat Lumpau <rl03@gentoo.org> -files/0.19.4-debian.patch,
-files/postinstall-en.txt, -mantisbt-0.19.4.ebuild,
diff --git a/www-apps/mantisbt/files/digest-mantisbt-1.0.4 b/www-apps/mantisbt/files/digest-mantisbt-1.0.4
new file mode 100644
index 000000000000..8c7efc6725aa
--- /dev/null
+++ b/www-apps/mantisbt/files/digest-mantisbt-1.0.4
@@ -0,0 +1,3 @@
+MD5 c7899e6badbd3dafa2d32875d2ea35f0 mantis-1.0.4.tar.gz 1427331
+RMD160 c89836786a151639986eae502edb44bb6489f301 mantis-1.0.4.tar.gz 1427331
+SHA256 d9a07d400c34aa08f5bef68604d61db28ee88102b704fa0e456e6d83e84cee9d mantis-1.0.4.tar.gz 1427331
diff --git a/www-apps/mantisbt/mantisbt-1.0.4.ebuild b/www-apps/mantisbt/mantisbt-1.0.4.ebuild
new file mode 100644
index 000000000000..cd106346db3d
--- /dev/null
+++ b/www-apps/mantisbt/mantisbt-1.0.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/mantisbt-1.0.4.ebuild,v 1.1 2006/07/24 21:00:41 rl03 Exp $
+
+inherit webapp
+
+IUSE="mysql postgres"
+
+DESCRIPTION="PHP/MySQL/Web based bugtracking system"
+HOMEPAGE="http://www.mantisbt.org/"
+SRC_URI="mirror://sourceforge/${PN}/mantis-${PV}.tar.gz"
+
+S=${WORKDIR}/mantis-${PV}
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ mysql? ( >=dev-db/mysql-3.23.32 )
+ postgres? ( >=dev-db/postgresql-7 )
+ net-www/apache
+ virtual/httpd-php
+"
+
+LICENSE="GPL-2"
+
+src_install() {
+ webapp_src_preinst
+ dodoc doc/*
+
+ cp -R . ${D}/${MY_HTDOCSDIR}
+ rm -rf ${D}/${MY_HTDOCSDIR}/doc
+
+ mv ${D}/${MY_HTDOCSDIR}/config_inc.php.sample ${D}/${MY_HTDOCSDIR}/config_inc.php
+
+ webapp_configfile ${MY_HTDOCSDIR}/config_inc.php
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en-1.0.0.txt
+ webapp_src_install
+}