summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2011-12-24 02:48:42 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2011-12-24 02:48:42 +0000
commitcb689fc9ca8bc11b8c9db590db80901b34dd042b (patch)
tree1f821afc640676b590ec899e8e9f6348db432c1d /www-apps
parentInitial import of system_timer gem, which also covers SystemTimer. (diff)
downloadgentoo-2-cb689fc9ca8bc11b8c9db590db80901b34dd042b.tar.gz
gentoo-2-cb689fc9ca8bc11b8c9db590db80901b34dd042b.tar.bz2
gentoo-2-cb689fc9ca8bc11b8c9db590db80901b34dd042b.zip
Version bump.
(Portage version: 2.2.0_alpha59_p57/cvs/Linux x86_64)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/blohg/ChangeLog7
-rw-r--r--www-apps/blohg/blohg-0.9.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/www-apps/blohg/ChangeLog b/www-apps/blohg/ChangeLog
index 9a5ee3314797..9b5e14748f68 100644
--- a/www-apps/blohg/ChangeLog
+++ b/www-apps/blohg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/blohg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/blohg/ChangeLog,v 1.12 2011/12/17 03:46:20 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/blohg/ChangeLog,v 1.13 2011/12/24 02:48:42 rafaelmartins Exp $
+
+*blohg-0.9 (24 Dec 2011)
+
+ 24 Dec 2011; Rafael G. Martins <rafaelmartins@gentoo.org> +blohg-0.9.ebuild:
+ Version bump.
17 Dec 2011; Rafael G. Martins <rafaelmartins@gentoo.org> blohg-9999.ebuild:
live ebuild now supports tests. restrict python dependency to >=2.6.
diff --git a/www-apps/blohg/blohg-0.9.ebuild b/www-apps/blohg/blohg-0.9.ebuild
new file mode 100644
index 000000000000..7a7451fec007
--- /dev/null
+++ b/www-apps/blohg/blohg-0.9.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/blohg/blohg-0.9.ebuild,v 1.1 2011/12/24 02:48:42 rafaelmartins Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+DESCRIPTION="A Mercurial-based blogging engine."
+HOMEPAGE="http://blohg.org/ http://pypi.python.org/pypi/blohg"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc test"
+
+DEPEND=">=dev-python/docutils-0.7
+ >=dev-python/flask-0.7
+ >=dev-python/flask-babel-0.6
+ >=dev-python/flask-script-0.3
+ >=dev-python/frozen-flask-0.7
+ >=dev-python/jinja-2.5.2
+ >=dev-vcs/mercurial-1.6
+ dev-python/pyyaml
+ dev-python/setuptools
+ dev-python/pygments
+ doc? ( dev-python/sphinx )"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo 'building documentation'
+ emake -C docs html
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ einfo 'installing documentation'
+ dohtml -r docs/_build/html/*
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ einfo "If you're upgrading from <=blohg-0.5.1, please read the upgrade notes:"
+ einfo "http://docs.blohg.org/upgrade/#from-0-5-1-to-0-6"
+}