summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2012-12-27 20:20:00 +0000
committerTorsten Veller <tove@gentoo.org>2012-12-27 20:20:00 +0000
commitd96384432a3a9a5ab7b638a127d9c3f2e83f174b (patch)
tree491ce7de479d4cb4c2ac1562e383ad9a22222988 /www-apps
parent[bump] virtual/perl-Scalar-List-Utils-1.270.0 (diff)
downloadgentoo-2-d96384432a3a9a5ab7b638a127d9c3f2e83f174b.tar.gz
gentoo-2-d96384432a3a9a5ab7b638a127d9c3f2e83f174b.tar.bz2
gentoo-2-d96384432a3a9a5ab7b638a127d9c3f2e83f174b.zip
Version bump (#399007)
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 0x5772769F4E046AEC)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/ikiwiki/ChangeLog7
-rw-r--r--www-apps/ikiwiki/ikiwiki-3.20121212.ebuild96
2 files changed, 102 insertions, 1 deletions
diff --git a/www-apps/ikiwiki/ChangeLog b/www-apps/ikiwiki/ChangeLog
index 4253470a70a0..9343e5d1c7db 100644
--- a/www-apps/ikiwiki/ChangeLog
+++ b/www-apps/ikiwiki/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/ikiwiki
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/ikiwiki/ChangeLog,v 1.12 2012/08/31 14:05:46 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/ikiwiki/ChangeLog,v 1.13 2012/12/27 20:20:00 tove Exp $
+
+*ikiwiki-3.20121212 (27 Dec 2012)
+
+ 27 Dec 2012; Torsten Veller <tove@gentoo.org> +ikiwiki-3.20121212.ebuild:
+ Version bump (#399007)
*ikiwiki-3.20120725 (31 Aug 2012)
diff --git a/www-apps/ikiwiki/ikiwiki-3.20121212.ebuild b/www-apps/ikiwiki/ikiwiki-3.20121212.ebuild
new file mode 100644
index 000000000000..22e002114530
--- /dev/null
+++ b/www-apps/ikiwiki/ikiwiki-3.20121212.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/ikiwiki/ikiwiki-3.20121212.ebuild,v 1.1 2012/12/27 20:20:00 tove Exp $
+
+EAPI=4
+
+inherit perl-module
+
+DESCRIPTION="A wiki compiler"
+HOMEPAGE="http://ikiwiki.info/"
+SRC_URI="mirror://debian/pool/main/i/ikiwiki/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="extras minimal test"
+KEYWORDS="~amd64 ~x86"
+
+S=${WORKDIR}/${PN}
+
+#Authen::Passphrase
+#Search::Xapian
+#Locale::gettext
+#Crypt::SSLeay
+#Text::CSV
+#Text::Typography
+#Text::Textile
+#Text::WikiFormat
+#Net::Amazon::S3
+
+EXTRA_RDEPEND="
+ dev-python/docutils
+ dev-perl/Digest-SHA1
+ dev-perl/File-MimeInfo
+ dev-perl/RPC-XML
+ dev-perl/XML-Feed
+ dev-perl/LWPx-ParanoidAgent
+ dev-perl/Net-OpenID-Consumer
+"
+
+SUGGESTED_RDEPEND="
+ virtual/perl-CGI
+ >=dev-perl/CGI-FormBuilder-3.0202
+ >=dev-perl/CGI-Session-4.14
+ dev-perl/Mail-Sendmail
+ dev-perl/Term-ReadLine-Gnu
+ dev-perl/XML-Simple
+"
+
+TEST_DEPEND="dev-perl/File-chdir"
+
+DEPEND="
+ >=dev-lang/perl-5.10
+ app-text/po4a
+ dev-perl/HTML-Parser
+ dev-perl/HTML-Scrubber
+ dev-perl/HTML-Template
+ dev-perl/URI
+ dev-perl/Text-Markdown
+ dev-perl/TimeDate
+ dev-perl/YAML-LibYAML
+"
+
+RDEPEND="${DEPEND}
+ !minimal? (
+ ${SUGGESTED_RDEPEND}
+ extras? (
+ ${EXTRA_RDEPEND}
+ )
+ )
+"
+
+DEPEND="${DEPEND}
+ test? ( ${TEST_DEPEND} )"
+
+SRC_TEST=do
+
+src_prepare() {
+ sed -i 's,lib/ikiwiki,libexec/ikiwiki,' \
+ "${S}"/{IkiWiki.pm,Makefile.PL,doc/plugins/install.mdwn} || die
+# if use w3m ; then
+ sed -i 's,lib/w3m,libexec/w3m,' "${S}"/Makefile.PL || die
+# else
+# sed -i '/w3m/d' "${S}"/Makefile.PL || die
+# fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" pure_install
+ insinto /etc/ikiwiki
+ doins wikilist
+
+ #insinto /usr/share/doc/${PF}/examples
+ #doins -r doc/examples/*
+ dohtml -r -A setup html/*
+ dodoc debian/{NEWS,changelog}
+}