summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-12-04 10:53:47 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-12-04 10:53:47 +0000
commiteeea6163d2340d219da95006378fb503d25f358e (patch)
treed0884f9eaf57bd9f93fda98e636fb2b5c35a433b /www-apps
parentAdd missing src_install function. Thanks to Jeroen Roovers <jer@gentoo.org>.... (diff)
downloadgentoo-2-eeea6163d2340d219da95006378fb503d25f358e.tar.gz
gentoo-2-eeea6163d2340d219da95006378fb503d25f358e.tar.bz2
gentoo-2-eeea6163d2340d219da95006378fb503d25f358e.zip
version bump. Bug #390395. Thanks to Patrick <mail@patrick-nagel.net>
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/tt-rss/ChangeLog9
-rw-r--r--www-apps/tt-rss/files/postinstall-en-with-daemon.txt4
-rw-r--r--www-apps/tt-rss/files/postinstall-en.txt4
-rw-r--r--www-apps/tt-rss/files/ttrssd.initd2
-rw-r--r--www-apps/tt-rss/tt-rss-1.5.4.ebuild52
-rw-r--r--www-apps/tt-rss/tt-rss-1.5.7.ebuild (renamed from www-apps/tt-rss/tt-rss-1.5.5.ebuild)13
6 files changed, 26 insertions, 58 deletions
diff --git a/www-apps/tt-rss/ChangeLog b/www-apps/tt-rss/ChangeLog
index 23b238cee56f..294dae312811 100644
--- a/www-apps/tt-rss/ChangeLog
+++ b/www-apps/tt-rss/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/tt-rss
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/tt-rss/ChangeLog,v 1.4 2011/11/02 21:43:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tt-rss/ChangeLog,v 1.5 2011/12/04 10:53:46 hwoarang Exp $
+
+*tt-rss-1.5.7 (04 Dec 2011)
+
+ 04 Dec 2011; Markos Chandras <hwoarang@gentoo.org> +tt-rss-1.5.7.ebuild,
+ -tt-rss-1.5.5.ebuild, -tt-rss-1.5.4.ebuild, files/postinstall-en.txt,
+ files/ttrssd.initd, files/postinstall-en-with-daemon.txt:
+ version bump. Bug #390395. Thanks to Patrick <mail@patrick-nagel.net>
02 Nov 2011; Mike Frysinger <vapier@gentoo.org> tt-rss-1.5.5.ebuild:
Drop "die" from enew{user,group} since these have always taken care of
diff --git a/www-apps/tt-rss/files/postinstall-en-with-daemon.txt b/www-apps/tt-rss/files/postinstall-en-with-daemon.txt
index ff5544c042c5..34476f671f4e 100644
--- a/www-apps/tt-rss/files/postinstall-en-with-daemon.txt
+++ b/www-apps/tt-rss/files/postinstall-en-with-daemon.txt
@@ -12,3 +12,7 @@ so that it gets launched after a system restart:
rc-update add ttrssd default
+
+Note on update from 1.5.6 or earlier: The directory containing the
+feed icons has been renamed from 'icons' to 'feed-icons'. Please
+move your *.ico files over, and then remove the old 'icons' dir.
diff --git a/www-apps/tt-rss/files/postinstall-en.txt b/www-apps/tt-rss/files/postinstall-en.txt
index 369d5e03dc27..77423cae900d 100644
--- a/www-apps/tt-rss/files/postinstall-en.txt
+++ b/www-apps/tt-rss/files/postinstall-en.txt
@@ -1 +1,5 @@
Please read http://tt-rss.org/trac/wiki/InstallationNotes
+
+Note on update from 1.5.6 or earlier: The directory containing the
+feed icons has been renamed from 'icons' to 'feed-icons'. Please
+move your *.ico files over, and then remove the old 'icons' dir.
diff --git a/www-apps/tt-rss/files/ttrssd.initd b/www-apps/tt-rss/files/ttrssd.initd
index f3496389c42d..5a1a18942290 100644
--- a/www-apps/tt-rss/files/ttrssd.initd
+++ b/www-apps/tt-rss/files/ttrssd.initd
@@ -19,7 +19,7 @@ start () {
# Since I have no idea how I could do this during the webapp-config installation,
# lets do it during start up...
- for DIR in cache cache/htmlpurifier cache/magpie cache/simplepie lock icons; do
+ for DIR in cache cache/htmlpurifier cache/magpie cache/simplepie lock feed-icons; do
chgrp ttrssd "${INSTANCE_DIR}/${DIR}"
chmod g+w "${INSTANCE_DIR}/${DIR}"
done
diff --git a/www-apps/tt-rss/tt-rss-1.5.4.ebuild b/www-apps/tt-rss/tt-rss-1.5.4.ebuild
deleted file mode 100644
index 40994b2fb35d..000000000000
--- a/www-apps/tt-rss/tt-rss-1.5.4.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/tt-rss/tt-rss-1.5.4.ebuild,v 1.1 2011/07/03 12:37:42 hwoarang Exp $
-
-EAPI="2"
-
-inherit webapp depend.php depend.apache
-
-DESCRIPTION="Tiny Tiny RSS - A web-based news feed (RSS/Atom) aggregator using AJAX"
-HOMEPAGE="http://tt-rss.org/"
-SRC_URI="http://tt-rss.org/download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64"
-IUSE="mysql postgres"
-
-DEPEND="dev-lang/php[mysql?,postgres?]"
-RDEPEND="${DEPEND}"
-
-need_httpd_cgi
-need_php_httpd
-
-pkg_setup() {
- webapp_pkg_setup
- use mysql && require_php_with_use mysql
- use postgres && require_php_with_use postgres
-}
-
-src_prepare() {
- # Customize config.php so that the right 'DB_TYPE' is already set (according to the USE flag)
- einfo "Customizing config.php..."
- mv config.php{-dist,} || die "Could not rename config.php-dist to config.php."
- if use mysql && ! use postgres; then
- sed -e "/define('DB_TYPE',/{s:pgsql:mysql:}" -i config.php || die "sed failed"
- fi
- sed -e "/define('DB_TYPE',/{s:// \(or mysql\):// pgsql \1:}" -i config.php \
- || die "sed failed"
-}
-
-src_install() {
- webapp_src_preinst
-
- insinto "/${MY_HTDOCSDIR}"
- doins -r * || die "Could not copy the files to ${MY_HTDOCSDIR}."
- keepdir "/${MY_HTDOCSDIR}"/icons
-
- webapp_serverowned "${MY_HTDOCSDIR}"/icons
- webapp_configfile "${MY_HTDOCSDIR}"/config.php
-
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- webapp_src_install
-}
diff --git a/www-apps/tt-rss/tt-rss-1.5.5.ebuild b/www-apps/tt-rss/tt-rss-1.5.7.ebuild
index 2dda0126edfa..4e74473e2343 100644
--- a/www-apps/tt-rss/tt-rss-1.5.5.ebuild
+++ b/www-apps/tt-rss/tt-rss-1.5.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/tt-rss/tt-rss-1.5.5.ebuild,v 1.2 2011/11/02 21:43:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tt-rss/tt-rss-1.5.7.ebuild,v 1.1 2011/12/04 10:53:46 hwoarang Exp $
EAPI="2"
@@ -23,8 +23,10 @@ use daemon && need_php_cli
pkg_setup() {
webapp_pkg_setup
+
use mysql && require_php_with_use mysql
use postgres && require_php_with_use postgres
+
if use daemon; then
require_php_with_use pcntl
enewgroup ttrssd
@@ -36,9 +38,11 @@ src_prepare() {
# Customize config.php so that the right 'DB_TYPE' is already set (according to the USE flag)
einfo "Customizing config.php..."
mv config.php{-dist,} || die "Could not rename config.php-dist to config.php."
+
if use mysql && ! use postgres; then
sed -e "/define('DB_TYPE',/{s:pgsql:mysql:}" -i config.php || die "sed failed"
fi
+
sed -e "/define('DB_TYPE',/{s:// \(or mysql\):// pgsql \1:}" -i config.php \
|| die "sed failed"
}
@@ -48,14 +52,15 @@ src_install() {
insinto "/${MY_HTDOCSDIR}"
doins -r * || die "Could not copy the files to ${MY_HTDOCSDIR}."
- keepdir "/${MY_HTDOCSDIR}"/icons
-
+ keepdir "/${MY_HTDOCSDIR}"/feed-icons
+
insinto /etc/logrotate.d/
newins "${FILESDIR}"/ttrssd.logrotated ttrssd || die "Installing ttrssd logrotate config failed."
- for DIR in cache cache/htmlpurifier cache/magpie cache/simplepie lock icons; do
+ for DIR in cache cache/htmlpurifier cache/magpie cache/simplepie lock feed-icons; do
webapp_serverowned "${MY_HTDOCSDIR}/${DIR}"
done
+
webapp_configfile "${MY_HTDOCSDIR}"/config.php
if use daemon; then
webapp_postinst_txt en "${FILESDIR}"/postinstall-en-with-daemon.txt