summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2012-04-18 23:33:56 +0000
committerChristian Ruppert <idl0r@gentoo.org>2012-04-18 23:33:56 +0000
commitf1e87f0d56f7951be071c982e229913a505d8501 (patch)
treeb2d9d97b03d6f535b4cae59b5b1f1663251b459b /www-apps
parentVersion bump. Big autotools patch seems to have been applied upstream (diff)
downloadgentoo-2-f1e87f0d56f7951be071c982e229913a505d8501.tar.gz
gentoo-2-f1e87f0d56f7951be071c982e229913a505d8501.tar.bz2
gentoo-2-f1e87f0d56f7951be071c982e229913a505d8501.zip
Version bumps re CVE-2012-0465 and CVE-2012-0466
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/bugzilla/ChangeLog11
-rw-r--r--www-apps/bugzilla/bugzilla-3.6.9.ebuild106
-rw-r--r--www-apps/bugzilla/bugzilla-4.0.6.ebuild (renamed from www-apps/bugzilla/bugzilla-4.0.5.ebuild)2
-rw-r--r--www-apps/bugzilla/bugzilla-4.2.1.ebuild (renamed from www-apps/bugzilla/bugzilla-4.2.ebuild)2
4 files changed, 118 insertions, 3 deletions
diff --git a/www-apps/bugzilla/ChangeLog b/www-apps/bugzilla/ChangeLog
index a4b0a711e91c..aee510115ad4 100644
--- a/www-apps/bugzilla/ChangeLog
+++ b/www-apps/bugzilla/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for www-apps/bugzilla
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/ChangeLog,v 1.210 2012/02/28 14:57:36 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/ChangeLog,v 1.211 2012/04/18 23:33:56 idl0r Exp $
+
+*bugzilla-4.2.1 (18 Apr 2012)
+*bugzilla-4.0.6 (18 Apr 2012)
+*bugzilla-3.6.9 (18 Apr 2012)
+
+ 18 Apr 2012; Christian Ruppert <idl0r@gentoo.org> +bugzilla-3.6.9.ebuild,
+ -bugzilla-4.0.5.ebuild, +bugzilla-4.0.6.ebuild, -bugzilla-4.2.ebuild,
+ +bugzilla-4.2.1.ebuild:
+ Version bumps re CVE-2012-0465 and CVE-2012-0466
28 Feb 2012; Christian Ruppert <idl0r@gentoo.org> bugzilla-4.0.5.ebuild,
bugzilla-4.2.ebuild:
diff --git a/www-apps/bugzilla/bugzilla-3.6.9.ebuild b/www-apps/bugzilla/bugzilla-3.6.9.ebuild
new file mode 100644
index 000000000000..dfe29dafbb8d
--- /dev/null
+++ b/www-apps/bugzilla/bugzilla-3.6.9.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/bugzilla-3.6.9.ebuild,v 1.1 2012/04/18 23:33:56 idl0r Exp $
+
+EAPI="3"
+
+inherit webapp depend.apache versionator eutils
+
+MY_PB=$(get_version_component_range 1-2)
+
+DESCRIPTION="Bugzilla is the Bug-Tracking System from the Mozilla project"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/webtools/${P}.tar.gz"
+HOMEPAGE="http://www.bugzilla.org"
+
+LICENSE="MPL-1.1"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="modperl extras graphviz mysql postgres"
+
+RDEPEND="
+ virtual/httpd-cgi
+ >=dev-lang/perl-5.8.8
+
+ >=dev-perl/DBI-1.601
+ >=dev-perl/DateTime-0.50
+ >=dev-perl/DateTime-Locale-0.43
+ >=dev-perl/DateTime-TimeZone-0.71
+ >=dev-perl/URI-1.38
+ >=dev-perl/Email-MIME-1.900
+ >=dev-perl/Email-MIME-Encodings-1.313
+ >=dev-perl/Email-Send-2.190
+ >=dev-perl/MIME-tools-5.427
+ >=dev-perl/Template-Toolkit-2.22
+ >=dev-perl/TimeDate-1.16
+ >=virtual/perl-CGI-3.510
+ >=virtual/perl-Digest-SHA-5.46
+ >=virtual/perl-File-Spec-3.27.01
+ >=virtual/perl-MIME-Base64-3.07
+
+ mysql? ( >=dev-perl/DBD-mysql-4.00.5 )
+ postgres? ( >=dev-perl/DBD-Pg-1.49 )
+ graphviz? ( media-gfx/graphviz )
+
+ modperl? (
+ >=dev-perl/Apache-DBI-1.06
+ www-apache/mod_perl:1
+ )
+
+ extras? (
+ dev-perl/Authen-SASL
+ >=dev-perl/Chart-2.4.1
+ dev-perl/Email-MIME-Attachment-Stripper
+ dev-perl/Email-Reply
+ >=dev-perl/GD-2.35
+ dev-perl/GDGraph
+ dev-perl/GDTextUtil
+ >=dev-perl/HTML-Parser-3.60
+ dev-perl/HTML-Scrubber
+ dev-perl/JSON-RPC
+ dev-perl/libwww-perl
+ >=dev-perl/PatchReader-0.9.5
+ dev-perl/perl-ldap
+ dev-perl/SOAP-Lite
+ dev-perl/Template-GD
+ dev-perl/Test-Taint
+ dev-perl/XML-Twig
+ || ( media-gfx/imagemagick[perl] media-gfx/graphicsmagick[imagemagick,perl] )
+ dev-perl/TheSchwartz
+ dev-perl/Daemon-Generic
+ dev-perl/Math-Random-Secure
+ )
+"
+# from extras we miss:
+# (nothing)
+
+want_apache modperl
+
+pkg_setup() {
+ depend.apache_pkg_setup modperl
+ webapp_pkg_setup
+}
+
+src_prepare() {
+ ecvs_clean
+ # Remove bundled perl modules
+ rm -rf "${S}"/lib || die
+}
+
+src_install () {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r . || die
+ for f in bugzilla.cron.daily bugzilla.cron.tab; do
+ doins "${FILESDIR}"/${MY_PB}/${f} || die
+ done
+
+ webapp_hook_script "${FILESDIR}"/${MY_PB}/reconfig
+ webapp_postinst_txt en "${FILESDIR}"/${MY_PB}/postinstall-en.txt
+ webapp_src_install
+
+ # bug #124282
+ chmod +x "${D}${MY_HTDOCSDIR}"/*.cgi
+ # configuration must be executable
+ chmod u+x "${D}${MY_HTDOCSDIR}"/checksetup.pl
+}
diff --git a/www-apps/bugzilla/bugzilla-4.0.5.ebuild b/www-apps/bugzilla/bugzilla-4.0.6.ebuild
index 0d7dc8717dd3..9ad25efa9b21 100644
--- a/www-apps/bugzilla/bugzilla-4.0.5.ebuild
+++ b/www-apps/bugzilla/bugzilla-4.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/bugzilla-4.0.5.ebuild,v 1.2 2012/02/28 14:57:36 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/bugzilla-4.0.6.ebuild,v 1.1 2012/04/18 23:33:56 idl0r Exp $
EAPI="3"
diff --git a/www-apps/bugzilla/bugzilla-4.2.ebuild b/www-apps/bugzilla/bugzilla-4.2.1.ebuild
index 68964aafcda1..667cbd5c3406 100644
--- a/www-apps/bugzilla/bugzilla-4.2.ebuild
+++ b/www-apps/bugzilla/bugzilla-4.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/bugzilla-4.2.ebuild,v 1.2 2012/02/28 14:57:36 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/bugzilla/bugzilla-4.2.1.ebuild,v 1.1 2012/04/18 23:33:56 idl0r Exp $
EAPI="4"