summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-12-05 23:49:23 +0000
committerBen de Groot <yngwin@gentoo.org>2009-12-05 23:49:23 +0000
commit04685e912c0985704b88883e4c021b2c11246517 (patch)
tree52e6401cce82f249ac186fc2906ca1ad4b8b93fa /www-client/arora
parentold (diff)
downloadgentoo-2-04685e912c0985704b88883e4c021b2c11246517.tar.gz
gentoo-2-04685e912c0985704b88883e4c021b2c11246517.tar.bz2
gentoo-2-04685e912c0985704b88883e4c021b2c11246517.zip
Version bump. Fixes bug 295808.
(Portage version: 2.2_rc55/cvs/Linux x86_64)
Diffstat (limited to 'www-client/arora')
-rw-r--r--www-client/arora/ChangeLog7
-rw-r--r--www-client/arora/arora-0.10.2.ebuild78
2 files changed, 84 insertions, 1 deletions
diff --git a/www-client/arora/ChangeLog b/www-client/arora/ChangeLog
index 850ab3aeb866..20417830d615 100644
--- a/www-client/arora/ChangeLog
+++ b/www-client/arora/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/arora
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/arora/ChangeLog,v 1.28 2009/12/05 21:16:37 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/arora/ChangeLog,v 1.29 2009/12/05 23:49:23 yngwin Exp $
+
+*arora-0.10.2 (05 Dec 2009)
+
+ 05 Dec 2009; Ben de Groot <yngwin@gentoo.org> +arora-0.10.2.ebuild:
+ Version bump. Fixes bug 295808.
05 Dec 2009; Ben de Groot <yngwin@gentoo.org> -arora-0.8.0.ebuild,
-arora-0.9.0.ebuild, -arora-0.10.0.ebuild, arora-0.10.1.ebuild:
diff --git a/www-client/arora/arora-0.10.2.ebuild b/www-client/arora/arora-0.10.2.ebuild
new file mode 100644
index 000000000000..69f1181b92c7
--- /dev/null
+++ b/www-client/arora/arora-0.10.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/arora/arora-0.10.2.ebuild,v 1.1 2009/12/05 23:49:23 yngwin Exp $
+
+EAPI=2
+inherit eutils qt4
+
+DESCRIPTION="A cross-platform Qt4 WebKit browser"
+HOMEPAGE="http://arora.googlecode.com/"
+SRC_URI="http://arora.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+RDEPEND=">=x11-libs/qt-gui-4.6.0_rc1
+ >=x11-libs/qt-sql-4.6.0_rc1
+ >=x11-libs/qt-webkit-4.6.0_rc1
+ >=x11-libs/qt-xmlpatterns-4.6.0_rc1"
+DEPEND="${RDEPEND}"
+
+ARORA_LANGS="ast ca es es_CR et_EE fr_CA gl ms nb_NO pt_BR pt_PT sr@latin sr_CS uk
+zh_CN zh_TW"
+ARORA_NOLONGLANGS="cs_CZ da_DK de_DE el_GR fi_FI fr_FR he_IL hu_HU it_IT ja_JP
+nl_NL pl_PL ru_RU sk_SK tr_TR"
+
+for L in $ARORA_LANGS; do
+ IUSE="$IUSE linguas_$L"
+done
+for L in $ARORA_NOLONGLANGS; do
+ IUSE="$IUSE linguas_${L%_*}"
+done
+
+src_prepare() {
+ # use Gentoo lingua designations
+ mv src/locale/sr_RS@latin.ts src/locale/sr@latin.ts
+ mv src/locale/sr_RS.ts src/locale/sr_CS.ts
+
+ # process linguas
+ local langs=
+ for lingua in $LINGUAS; do
+ if has $lingua $ARORA_LANGS; then
+ langs="$langs ${lingua}.ts"
+ else
+ for a in $ARORA_NOLONGLANGS; do
+ if [[ $lingua == ${a%_*} ]]; then
+ langs="$langs ${a}.ts"
+ fi
+ done
+ fi
+ done
+
+ # remove all translations, then add only the ones we want
+ sed -i '/ts/d' src/locale/locale.pri || die 'sed failed'
+ sed -i "/^TRANSLATIONS/s:\\\:${langs}:" src/locale/locale.pri \
+ || die 'sed failed'
+
+ if ! use doc ; then
+ sed -i 's|QMAKE_EXTRA|#QMAKE_EXTRA|' arora.pro || die 'sed failed'
+ fi
+}
+
+src_configure() {
+ eqmake4 arora.pro PREFIX=/usr
+}
+
+src_compile() {
+ emake || die "make failed"
+
+ # don't pre-strip
+ sed -i "/strip/d" src/Makefile || die 'sed failed'
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die 'make install failed'
+ dodoc AUTHORS ChangeLog README
+}