summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-10-13 12:00:01 +0000
committerAlex Alexander <wired@gentoo.org>2010-10-13 12:00:01 +0000
commit9989ff58c8f484e27476916b575b1888d0c555da (patch)
tree8a05a463594b98eb4dfb925f4b4a5f808fc00d4d /www-client/arora
parentStable on amd64 wrt bug #340749 (diff)
downloadgentoo-2-9989ff58c8f484e27476916b575b1888d0c555da.tar.gz
gentoo-2-9989ff58c8f484e27476916b575b1888d0c555da.tar.bz2
gentoo-2-9989ff58c8f484e27476916b575b1888d0c555da.zip
version bump, bug #338942
(Portage version: 2.2_rc89/cvs/Linux x86_64)
Diffstat (limited to 'www-client/arora')
-rw-r--r--www-client/arora/ChangeLog7
-rw-r--r--www-client/arora/arora-0.11.0.ebuild79
2 files changed, 85 insertions, 1 deletions
diff --git a/www-client/arora/ChangeLog b/www-client/arora/ChangeLog
index 8b9abbc5411c..0191b3ecdde8 100644
--- a/www-client/arora/ChangeLog
+++ b/www-client/arora/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/arora
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/arora/ChangeLog,v 1.39 2010/08/28 13:43:24 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/arora/ChangeLog,v 1.40 2010/10/13 12:00:01 wired Exp $
+
+*arora-0.11.0 (13 Oct 2010)
+
+ 13 Oct 2010; Alex Alexander <wired@gentoo.org> +arora-0.11.0.ebuild:
+ version bump, bug #338942
28 Aug 2010; Alex Alexander <wired@gentoo.org> arora-0.10.2-r1.ebuild,
+files/arora-0.10.2_qt_4.7_build_fix.patch:
diff --git a/www-client/arora/arora-0.11.0.ebuild b/www-client/arora/arora-0.11.0.ebuild
new file mode 100644
index 000000000000..052fcb8dbee0
--- /dev/null
+++ b/www-client/arora/arora-0.11.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/arora/arora-0.11.0.ebuild,v 1.1 2010/10/13 12:00:01 wired Exp $
+
+EAPI=2
+inherit eutils qt4-r2
+
+DESCRIPTION="A cross-platform Qt4 WebKit browser"
+HOMEPAGE="http://arora.googlecode.com/"
+SRC_URI="http://arora.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="debug doc"
+
+RDEPEND="x11-libs/qt-gui:4
+ x11-libs/qt-sql:4
+ x11-libs/qt-webkit:4
+ x11-libs/qt-xmlpatterns:4"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+ARORA_LANGS="ast ca es es_CR et_EE fr_CA gl ms nb_NO nl pt_BR pt_PT sr@latin sr_CS uk
+zh_CN zh_TW"
+ARORA_NOLONGLANGS="cs_CZ da_DK de_DE el_GR fi_FI fr_FR he_IL hu_HU it_IT ja_JP
+pl_PL ru_RU sk_SK tr_TR"
+
+for L in $ARORA_LANGS; do
+ IUSE="$IUSE linguas_$L"
+done
+for L in $ARORA_NOLONGLANGS; do
+ IUSE="$IUSE linguas_${L%_*}"
+done
+
+src_prepare() {
+ # use Gentoo lingua designations
+ mv src/locale/sr_RS@latin.ts src/locale/sr@latin.ts
+ mv src/locale/sr_RS.ts src/locale/sr_CS.ts
+
+ # process linguas
+ local langs=
+ for lingua in $LINGUAS; do
+ if has $lingua $ARORA_LANGS; then
+ langs="$langs ${lingua}.ts"
+ else
+ for a in $ARORA_NOLONGLANGS; do
+ if [[ $lingua == ${a%_*} ]]; then
+ langs="$langs ${a}.ts"
+ fi
+ done
+ fi
+ done
+
+ # remove all translations, then add only the ones we want
+ sed -i '/ts/d' src/locale/locale.pri || die 'sed failed'
+ sed -i "/^TRANSLATIONS/s:\\\:${langs}:" src/locale/locale.pri \
+ || die 'sed failed'
+
+ if ! use doc ; then
+ sed -i 's|QMAKE_EXTRA|#QMAKE_EXTRA|' arora.pro || die 'sed failed'
+ fi
+}
+
+src_configure() {
+ eqmake4 PREFIX=/usr
+}
+
+src_compile() {
+ emake || die "make failed"
+
+ # don't pre-strip
+ sed -i "/strip/d" src/Makefile || die 'sed failed'
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die 'make install failed'
+ dodoc AUTHORS ChangeLog README
+}