summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-02-04 20:30:56 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-02-04 20:30:56 +0000
commit8286bd4a4438b3e64f6fab73565f4048d3e26ccc (patch)
tree832032fab70c012c447ff390efc38bb501cc4919 /www-client/dillo
parentAdd libpng patch to live version. (diff)
downloadgentoo-2-8286bd4a4438b3e64f6fab73565f4048d3e26ccc.tar.gz
gentoo-2-8286bd4a4438b3e64f6fab73565f4048d3e26ccc.tar.bz2
gentoo-2-8286bd4a4438b3e64f6fab73565f4048d3e26ccc.zip
old
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'www-client/dillo')
-rw-r--r--www-client/dillo/ChangeLog6
-rw-r--r--www-client/dillo/dillo-2.2.ebuild67
-rw-r--r--www-client/dillo/files/dillo-2.2-libpng14.patch13
3 files changed, 5 insertions, 81 deletions
diff --git a/www-client/dillo/ChangeLog b/www-client/dillo/ChangeLog
index bf5ba948607b..1314af07284d 100644
--- a/www-client/dillo/ChangeLog
+++ b/www-client/dillo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-client/dillo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/ChangeLog,v 1.106 2012/02/04 18:55:01 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/ChangeLog,v 1.107 2012/02/04 20:30:56 ssuominen Exp $
+
+ 04 Feb 2012; Samuli Suominen <ssuominen@gentoo.org> -dillo-2.2.ebuild,
+ -files/dillo-2.2-libpng14.patch:
+ old
04 Feb 2012; Raúl Porcel <armin76@gentoo.org> dillo-3.0.1.ebuild:
alpha/sparc stable wrt #395917
diff --git a/www-client/dillo/dillo-2.2.ebuild b/www-client/dillo/dillo-2.2.ebuild
deleted file mode 100644
index e60262c96703..000000000000
--- a/www-client/dillo/dillo-2.2.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/dillo-2.2.ebuild,v 1.11 2012/01/05 18:12:31 ssuominen Exp $
-
-EAPI=2
-inherit eutils flag-o-matic multilib
-
-DESCRIPTION="Lean FLTK2-based web browser"
-HOMEPAGE="http://www.dillo.org/"
-SRC_URI="http://www.dillo.org/download/${P}.tar.bz2
- mirror://gentoo/${PN}.png"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ppc ~ppc64 sparc x86"
-IUSE="doc +gif ipv6 +jpeg +png ssl"
-
-RDEPEND="x11-libs/fltk:2[-cairo,jpeg=,png=]
- sys-libs/zlib
- jpeg? ( virtual/jpeg )
- png? ( media-libs/libpng:0 )
- ssl? ( dev-libs/openssl:0 )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/dillo2-inbuf.patch \
- "${FILESDIR}"/${P}-libpng14.patch
-}
-
-src_configure() {
- append-ldflags "-L/usr/$(get_libdir)/fltk"
- econf \
- $(use_enable gif) \
- $(use_enable ipv6) \
- $(use_enable jpeg) \
- $(use_enable png) \
- $(use_enable ssl)
-}
-
-src_compile() {
- emake || die
- if use doc; then
- doxygen Doxyfile || die
- fi
-}
-
-src_install() {
- dodir /etc
- emake DESTDIR="${D}" install || die
-
- if use doc; then
- dohtml html/* || die
- fi
- dodoc AUTHORS ChangeLog README NEWS
- docinto doc
- dodoc doc/*.txt doc/README
-
- doicon "${DISTDIR}"/dillo.png
- make_desktop_entry dillo Dillo
-}
-
-pkg_postinst() {
- elog "Dillo has installed a default configuration into /etc/dillo/dillorc"
- elog "You can copy this to ~/.dillo/ and customize it"
-}
diff --git a/www-client/dillo/files/dillo-2.2-libpng14.patch b/www-client/dillo/files/dillo-2.2-libpng14.patch
deleted file mode 100644
index f4af67e4b196..000000000000
--- a/www-client/dillo/files/dillo-2.2-libpng14.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-http://repos.archlinux.org/wsvn/community/dillo/trunk/libpng14.patch
-
---- src/png.c
-+++ src/png.c
-@@ -345,7 +345,7 @@ static void Png_write(DilloPng *png, voi
- return; /* need MORE data */
- }
- /* check the image signature - DON'T update ipbufstart! */
-- if (!png_check_sig(png->ipbuf, DATASIZE)) {
-+ if (png_sig_cmp(png->ipbuf, 0, DATASIZE)) {
- /* you lied to me about it being a PNG image */
- MSG_WARN("\"%s\" is not a PNG file.\n", URL_STR(png->url));
- png->state = IS_finished;