summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-04-10 22:36:50 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-04-10 22:36:50 +0000
commitd8fd97f7abf285dc8f4ea788f635c68a26bfc75e (patch)
treeeafd93d52116e49c3473cfd5092de89ee16eec2a /www-client/epiphany
parentRevision bump to fix bug #216702 and workaround autoconf bug in #217154. (diff)
downloadgentoo-2-d8fd97f7abf285dc8f4ea788f635c68a26bfc75e.tar.gz
gentoo-2-d8fd97f7abf285dc8f4ea788f635c68a26bfc75e.tar.bz2
gentoo-2-d8fd97f7abf285dc8f4ea788f635c68a26bfc75e.zip
bump to 2.22.1.1. Changes to documentation afaict.
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'www-client/epiphany')
-rw-r--r--www-client/epiphany/ChangeLog8
-rw-r--r--www-client/epiphany/epiphany-2.22.1.1.ebuild83
2 files changed, 90 insertions, 1 deletions
diff --git a/www-client/epiphany/ChangeLog b/www-client/epiphany/ChangeLog
index b0957605912d..5c4cd4c4ac45 100644
--- a/www-client/epiphany/ChangeLog
+++ b/www-client/epiphany/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/epiphany
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.155 2008/04/10 22:09:42 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.156 2008/04/10 22:36:50 eva Exp $
+
+*epiphany-2.22.1.1 (10 Apr 2008)
+
+ 10 Apr 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +epiphany-2.22.1.1.ebuild:
+ bump to 2.22.1.1. Changes to documentation afaict.
*epiphany-2.22.1 (10 Apr 2008)
diff --git a/www-client/epiphany/epiphany-2.22.1.1.ebuild b/www-client/epiphany/epiphany-2.22.1.1.ebuild
new file mode 100644
index 000000000000..155aff982478
--- /dev/null
+++ b/www-client/epiphany/epiphany-2.22.1.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-2.22.1.1.ebuild,v 1.1 2008/04/10 22:36:50 eva Exp $
+
+inherit gnome2 eutils multilib
+
+DESCRIPTION="GNOME webbrowser based on the mozilla rendering engine"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="avahi doc networkmanager python spell xulrunner"
+
+# FIXME: add webkit/gecko switch possibility
+# dang: *after* webkit actually works.
+# this release should work with xulrunner 1.9 so not slotting right now
+
+RDEPEND=">=dev-libs/glib-2.16.0
+ >=x11-libs/gtk+-2.12.0
+ >=dev-libs/libxml2-2.6.12
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/libglade-2.3.1
+ >=gnome-base/libgnome-2.14
+ >=gnome-base/libgnomeui-2.14
+ >=gnome-base/gnome-desktop-2.9.91
+ >=x11-libs/startup-notification-0.5
+ >=x11-libs/libnotify-0.4
+ >=dev-libs/dbus-glib-0.71
+ >=gnome-base/gconf-2
+ >=app-text/iso-codes-0.35
+ avahi? ( >=net-dns/avahi-0.6.22 )
+ networkmanager? ( net-misc/networkmanager )
+ !xulrunner? ( >=www-client/mozilla-firefox-1.5 )
+ xulrunner? ( net-libs/xulrunner )
+ python? (
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.7.1
+ >=dev-python/gnome-python-2.6
+ )
+ spell? ( app-text/enchant )
+ x11-themes/gnome-icon-theme"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ >=app-text/gnome-doc-utils-0.3.2
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-scrollkeeper
+ --with-engine=mozilla
+ --enable-certificate-manager
+ --with-distributor-name=Gentoo
+ $(use_enable avahi zeroconf)
+ $(use_enable networkmanager network-manager)
+ $(use_enable spell spell-checker)
+ $(use_enable python)"
+
+ if use xulrunner; then
+ G2CONF="${G2CONF} --with-gecko=xulrunner"
+ else
+ G2CONF="${G2CONF} --with-gecko=firefox"
+ fi
+}
+
+src_compile() {
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/xpti.dat
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/xpti.dat.tmp
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/compreg.dat.tmp
+
+ addpredict /usr/$(get_libdir)/xulrunner/components/xpti.dat
+ addpredict /usr/$(get_libdir)/xulrunner/components/xpti.dat.tmp
+ addpredict /usr/$(get_libdir)/xulrunner/components/compreg.dat.tmp
+
+ addpredict /usr/$(get_libdir)/mozilla/components/xpti.dat
+ addpredict /usr/$(get_libdir)/mozilla/components/xpti.dat.tmp
+
+ gnome2_src_compile
+}