summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephanie J. Lockwood-Childs <wormo@gentoo.org>2009-08-13 06:40:44 +0000
committerStephanie J. Lockwood-Childs <wormo@gentoo.org>2009-08-13 06:40:44 +0000
commit0957304f2308c39f7f12d8045266fea57493841a (patch)
tree251c03c966eee4bd8af94bd303dca23511be2ae9 /www-client/lynx
parentResize the patch. (diff)
downloadgentoo-2-0957304f2308c39f7f12d8045266fea57493841a.tar.gz
gentoo-2-0957304f2308c39f7f12d8045266fea57493841a.tar.bz2
gentoo-2-0957304f2308c39f7f12d8045266fea57493841a.zip
Patch lynx configure script to prevent build failure when openssl
is compiled with USE=kerberos (bug #267749, thanks to Guy for testing) (Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'www-client/lynx')
-rw-r--r--www-client/lynx/ChangeLog8
-rw-r--r--www-client/lynx/files/lynx-2.8.7-configure-openssl.patch33
-rw-r--r--www-client/lynx/lynx-2.8.7_p1.ebuild5
-rw-r--r--www-client/lynx/lynx-2.8.7_rc6.ebuild115
4 files changed, 44 insertions, 117 deletions
diff --git a/www-client/lynx/ChangeLog b/www-client/lynx/ChangeLog
index ecfb784d0655..8837f35be7b2 100644
--- a/www-client/lynx/ChangeLog
+++ b/www-client/lynx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/lynx
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/ChangeLog,v 1.89 2009/08/02 15:13:15 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/ChangeLog,v 1.90 2009/08/13 06:40:44 wormo Exp $
+
+ 13 Aug 2009; Stephanie Lockwood-Childs <wormo@gentoo.org>
+ +files/lynx-2.8.7-configure-openssl.patch, -lynx-2.8.7_rc6.ebuild,
+ lynx-2.8.7_p1.ebuild:
+ Patch lynx configure script to prevent build failure when openssl
+ is compiled with USE=kerberos (bug #267749, thanks to Guy for testing)
02 Aug 2009; Brent Baude <ranger@gentoo.org> lynx-2.8.6-r4.ebuild:
Marking lynx-2.8.6-r4 ppc64 for bug 243058
diff --git a/www-client/lynx/files/lynx-2.8.7-configure-openssl.patch b/www-client/lynx/files/lynx-2.8.7-configure-openssl.patch
new file mode 100644
index 000000000000..55bbb695bfd6
--- /dev/null
+++ b/www-client/lynx/files/lynx-2.8.7-configure-openssl.patch
@@ -0,0 +1,33 @@
+--- configure.old 2009-07-31 00:12:26.000000000 -0700
++++ configure 2009-07-31 00:10:05.000000000 -0700
+@@ -11763,16 +11763,23 @@
+ if test -n "$cf_cflags_ssl" ; then
+ case "$cf_cflags_ssl" in #(vi
+ *-I*) #(vi
+- cf_cv_header_path_ssl=`echo "$cf_cflags_ssl" | sed -e 's/^.*-I//' -e 's/ .*//'`
+- ;;
+- *)
+- cf_cv_header_path_ssl=/usr/include
++ # if openssl pkg-config lists more than one includedir,
++ # primary one will be first
++ # (e.g. kerberos includedir may follow)
++ # so, pick out path following first '-I'
++ cf_cv_header_path_ssl=`echo "$cf_cflags_ssl" | sed -e 's/\(-I[^ ]*\).*/\1/' -e 's/.*-I//'`
++ cf_cv_header_path_ssl=$cf_cv_header_path_ssl/openssl
+ ;;
+ esac
+- if test -d $cf_cv_header_path_ssl/openssl ; then
+- cf_cv_header_path_ssl=$cf_cv_header_path_ssl/openssl
++ # try standard location if couldn't
++ # figure out path using pkg-config
++ if ! test -d "$cf_cv_header_path_ssl" ; then
++ if test -d "/usr/include/openssl" ; then
++ cf_cv_header_path_ssl=/usr/include/openssl
++ else
++ cf_cv_header_path_ssl=/usr/include
++ fi
+ fi
+-
+ cf_fix_cppflags=no
+ cf_new_cflags=
+ cf_new_cppflags=
diff --git a/www-client/lynx/lynx-2.8.7_p1.ebuild b/www-client/lynx/lynx-2.8.7_p1.ebuild
index 3b154df1831d..cb75610fbb50 100644
--- a/www-client/lynx/lynx-2.8.7_p1.ebuild
+++ b/www-client/lynx/lynx-2.8.7_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/lynx-2.8.7_p1.ebuild,v 1.1 2009/07/26 23:07:42 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/lynx-2.8.7_p1.ebuild,v 1.2 2009/08/13 06:40:44 wormo Exp $
EAPI=2
@@ -72,6 +72,9 @@ src_prepare() {
# making sure '+' comes after leading whitespace
sed -i -e '/$(MAKE_RECUR)/ s/\([[:blank:]]\)/\1+/' makefile.in || \
die "failed to update makefile.in"
+
+ # fix configure for openssl compiled with kerberos (bug #267749)
+ epatch "${FILESDIR}/lynx-2.8.7-configure-openssl.patch"
}
src_configure() {
diff --git a/www-client/lynx/lynx-2.8.7_rc6.ebuild b/www-client/lynx/lynx-2.8.7_rc6.ebuild
deleted file mode 100644
index 690d79550122..000000000000
--- a/www-client/lynx/lynx-2.8.7_rc6.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/lynx-2.8.7_rc6.ebuild,v 1.3 2009/07/26 23:07:42 wormo Exp $
-
-EAPI=2
-
-inherit eutils versionator
-
-# VERSIONING SCHEME TRANSLATION
-# Upstream : Gentoo
-# rel. : _p
-# pre. : _rc
-# dev. : _pre
-
-if [[ "${PV/_p[0-9]}" != "${PV}" ]]
-then
- MY_P="${PN}${PV/_p/rel.}"
-
-elif [[ "${PV/_rc[0-9]}" != "${PV}" ]]
-then
- MY_P="${PN}${PV/_rc/pre.}"
-
-elif [[ "${PV/_pre[0-9]}" != "${PV}" ]]
-then
- MY_P="${PN}${PV/_pre/dev.}"
-
-fi
-
-DESCRIPTION="An excellent console-based web browser with ssl support"
-HOMEPAGE="http://lynx.isc.org/"
-SRC_URI="http://lynx.isc.org/current/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="bzip2 cjk gnutls ipv6 nls openssl unicode"
-
-RDEPEND="sys-libs/ncurses[unicode?]
- sys-libs/zlib
- nls? ( virtual/libintl )
- openssl? ( >=dev-libs/openssl-0.9.8 )
- !openssl? (
- gnutls? ( >=net-libs/gnutls-2.6.4 )
- )
- bzip2? ( app-arch/bzip2 )"
-
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- >=dev-util/pkgconfig-0.23"
-
-S="${WORKDIR}/${PN}$(replace_all_version_separators - $(get_version_component_range 1-3))"
-
-pkg_setup() {
- if use openssl
- then
- if use gnutls
- then
- elog "Both openssl and gnutls use-flags specified. Openssl will be used."
- fi
- else
- if ! use gnutls
- then
- elog "No SSL library selected, you will not be able to access secure websites."
- fi
- fi
-}
-
-src_prepare() {
- # fix up toplevel makefile to enable parallel make (bug #262972)
- #
- # add '+' prefix to lines using $(MAKE_RECUR),
- # making sure '+' comes after leading whitespace
- sed -i -e '/$(MAKE_RECUR)/ s/\([[:blank:]]\)/\1+/' makefile.in || \
- die "failed to update makefile.in"
-}
-
-src_configure() {
- econf \
- --enable-cgi-links \
- --enable-persistent-cookies \
- --enable-prettysrc \
- --enable-nsl-fork \
- --enable-file-upload \
- --enable-read-eta \
- --enable-color-style \
- --enable-scrollbar \
- --enable-included-msgs \
- --with-zlib \
- $(use_enable nls) \
- $(use_enable ipv6) \
- $(use_enable cjk) \
- $(use_enable unicode japanese-utf8) \
- $(use_with openssl ssl) \
- $(use_with gnutls) \
- $(use_with bzip2 bzlib) \
- $(use unicode && printf '%s' '--with-screen=ncursesw')
-}
-
-src_install() {
- make install DESTDIR="${D}" || die
-
- sed -i -e "s|^HELPFILE.*$|HELPFILE:file://localhost/usr/share/doc/${PF}/lynx_help/lynx_help_main.html|" \
- "${D}"/etc/lynx.cfg || die "lynx.cfg not found"
- if use unicode
- then
- sed -i -e '/^#CHARACTER_SET:/ c\CHARACTER_SET:utf-8' \
- "${D}"/etc/lynx.cfg || die "lynx.cfg not found"
- fi
- dodoc CHANGES COPYHEADER PROBLEMS README
- docinto docs
- dodoc docs/*
- docinto lynx_help
- dodoc lynx_help/*.txt
- dohtml -r lynx_help/*
-}