summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-04-28 13:18:39 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-04-28 13:18:39 +0000
commit9a6cdc155bff83288eb4f2ba3d97a4beac1edf3f (patch)
tree9053609e11cd5830b4e17e0bcdd2d99c428f6c3c /www-client/midori
parentbumps to 6.3.2.2 and 6.3.3, remove 6.3.2 (diff)
downloadgentoo-2-9a6cdc155bff83288eb4f2ba3d97a4beac1edf3f.tar.gz
gentoo-2-9a6cdc155bff83288eb4f2ba3d97a4beac1edf3f.tar.bz2
gentoo-2-9a6cdc155bff83288eb4f2ba3d97a4beac1edf3f.zip
old
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'www-client/midori')
-rw-r--r--www-client/midori/files/midori-0.2.9-libnotify-0.7.patch27
-rw-r--r--www-client/midori/midori-0.2.9-r1.ebuild80
2 files changed, 0 insertions, 107 deletions
diff --git a/www-client/midori/files/midori-0.2.9-libnotify-0.7.patch b/www-client/midori/files/midori-0.2.9-libnotify-0.7.patch
deleted file mode 100644
index c1c58408c59f..000000000000
--- a/www-client/midori/files/midori-0.2.9-libnotify-0.7.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-http://bugs.launchpad.net/midori/+bug/710352
-
---- midori/midori-app.c
-+++ midori/midori-app.c
-@@ -42,6 +42,9 @@
-
- #if HAVE_LIBNOTIFY
- #include <libnotify/notify.h>
-+ #ifndef NOTIFY_CHECK_VERSION
-+ #define NOTIFY_CHECK_VERSION(x,y,z) 0
-+ #endif
- #endif
-
- struct _MidoriApp
-@@ -1203,8 +1206,11 @@
- if (notify_is_initted ())
- {
- NotifyNotification* note;
--
-+ #if NOTIFY_CHECK_VERSION(0, 7, 0)
-+ note = notify_notification_new (title, message, "midori");
-+ #else
- note = notify_notification_new (title, message, "midori", NULL);
-+ #endif
- notify_notification_show (note, NULL);
- g_object_unref (note);
- }
diff --git a/www-client/midori/midori-0.2.9-r1.ebuild b/www-client/midori/midori-0.2.9-r1.ebuild
deleted file mode 100644
index fe080ccb1d3c..000000000000
--- a/www-client/midori/midori-0.2.9-r1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/midori/midori-0.2.9-r1.ebuild,v 1.6 2011/03/21 22:22:44 nirbheek Exp $
-
-EAPI=3
-inherit eutils multilib python xfconf
-
-DESCRIPTION="A lightweight web browser based on WebKitGTK+"
-HOMEPAGE="http://www.twotoasts.de/index.php?/pages/midori_summary.html"
-SRC_URI="mirror://xfce/src/apps/${PN}/0.2/${P}.tar.bz2"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc x86 ~x86-fbsd"
-IUSE="doc gnome +html idn libnotify nls +unique"
-
-RDEPEND="libnotify? ( x11-libs/libnotify )
- >=net-libs/libsoup-2.25.2:2.4
- >=net-libs/webkit-gtk-1.1.1:2
- >=dev-db/sqlite-3.0
- dev-libs/libxml2:2
- >=x11-libs/gtk+-2.10:2
- gnome? ( net-libs/libsoup-gnome:2.4 )
- idn? ( net-dns/libidn )
- unique? ( dev-libs/libunique:1 )"
-DEPEND="${RDEPEND}
- || ( dev-lang/python:2.7 dev-lang/python:2.6 )
- dev-util/intltool
- dev-util/pkgconfig
- doc? ( dev-util/gtk-doc )
- html? ( dev-python/docutils )
- nls? ( sys-devel/gettext )"
-
-pkg_setup() {
- python_set_active_version 2
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
-
- # moving docs to version-specific directory
- sed -i -e "s:/${PN}/user/midori.html:/user/midori.html:g" midori/midori-browser.c || die
-}
-
-src_configure() {
- strip-linguas -i po
-
- CCFLAGS="${CFLAGS}" LINKFLAGS="${LDFLAGS}" ./waf \
- --prefix="/usr/" \
- --libdir="/usr/$(get_libdir)" \
- --docdir="/usr/share/doc/${PF}/html" \
- --disable-docs \
- --enable-addons \
- $(use_enable doc apidocs) \
- $(use_enable html userdocs) \
- $(use_enable idn libidn) \
- $(use_enable libnotify) \
- $(use_enable nls) \
- $(use_enable unique) \
- --disable-vala \
- configure || die
-}
-
-src_compile() {
- # This is from dev-libs/boost, keep it synced
- jobs=$( echo " ${MAKEOPTS} " | \
- sed -e 's/ --jobs[= ]/ -j /g' \
- -e 's/ -j \([1-9][0-9]*\)/ -j\1/g' \
- -e 's/ -j\>/ -j1/g' | \
- ( while read -d ' ' j ; do if [[ "${j#-j}" = "$j" ]]; then continue; fi;
- jobs="${j#-j}"; done; echo ${jobs} ) )
- if [[ "${jobs}" != "" ]]; then NUMJOBS="-j"${jobs}; fi;
-
- ./waf build ${NUMJOBS} || die
-}
-
-src_install() {
- DESTDIR=${D} ./waf install || die
- dodoc AUTHORS ChangeLog INSTALL TODO || die
-}