summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-11-28 18:34:00 +0000
committerJeroen Roovers <jer@gentoo.org>2012-11-28 18:34:00 +0000
commit997fcc653ce6627d7fe8f5eb7b1437561c3a5057 (patch)
treecef7dbd05064381821a69afcd1e7ed96e6520fa1 /www-client/opera-next
parentApply O_B mangling more. (diff)
downloadgentoo-2-997fcc653ce6627d7fe8f5eb7b1437561c3a5057.tar.gz
gentoo-2-997fcc653ce6627d7fe8f5eb7b1437561c3a5057.tar.bz2
gentoo-2-997fcc653ce6627d7fe8f5eb7b1437561c3a5057.zip
Merge O_B mangling into O_D/O_P concatenation.
(Portage version: 2.2.0_alpha142/cvs/Linux i686, signed Manifest commit with key A792A613)
Diffstat (limited to 'www-client/opera-next')
-rw-r--r--www-client/opera-next/ChangeLog6
-rw-r--r--www-client/opera-next/opera-next-12.11_pre1661.ebuild12
-rw-r--r--www-client/opera-next/opera-next-12.12_pre1662.ebuild10
3 files changed, 14 insertions, 14 deletions
diff --git a/www-client/opera-next/ChangeLog b/www-client/opera-next/ChangeLog
index 0f52bf534523..eb7532030426 100644
--- a/www-client/opera-next/ChangeLog
+++ b/www-client/opera-next/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-client/opera-next
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/opera-next/ChangeLog,v 1.157 2012/11/28 17:40:20 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/opera-next/ChangeLog,v 1.158 2012/11/28 18:34:00 jer Exp $
+
+ 28 Nov 2012; Jeroen Roovers <jer@gentoo.org> opera-next-12.11_pre1661.ebuild,
+ opera-next-12.12_pre1662.ebuild:
+ Merge O_B mangling into O_D/O_P concatenation.
*opera-next-12.12_pre1662 (28 Nov 2012)
*opera-next-12.11_pre1661 (28 Nov 2012)
diff --git a/www-client/opera-next/opera-next-12.11_pre1661.ebuild b/www-client/opera-next/opera-next-12.11_pre1661.ebuild
index e70e8d07831d..83b3fc219d84 100644
--- a/www-client/opera-next/opera-next-12.11_pre1661.ebuild
+++ b/www-client/opera-next/opera-next-12.11_pre1661.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/opera-next/opera-next-12.11_pre1661.ebuild,v 1.1 2012/11/28 17:40:20 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/opera-next/opera-next-12.11_pre1661.ebuild,v 1.2 2012/11/28 18:34:00 jer Exp $
EAPI=4
inherit eutils fdo-mime gnome2-utils multilib pax-utils versionator
@@ -19,7 +19,7 @@ O_B="$(get_version_component_range 3)" # Build number, i.e. 1156
# == Variables that often change ==
# All other variables should be accounted for by _pre/_p
-O_K="" # The key to the snapshot URL
+O_K="rev" # The key to the snapshot URL
O_LINGUAS="
af ar az be bg bn cs da de el en-GB es-ES es-LA et fa fi fr fr-CA fy gd he
@@ -30,9 +30,8 @@ O_LINGUAS="
# == End of variables that often change ==
if [[ "pre${O_B/pre/}" = "${O_B}" ]]; then # snapshot: _pre
- O_B="${O_B/pre}" # remove _pre
- O_D="${O_K}_${O_V}-${O_B}" # directory string
- O_P="${PN}-${O_V}-${O_B}" # package string
+ O_D="${O_K}_${O_V}-${O_B/pre}" # directory string
+ O_P="${PN}-${O_V}-${O_B/pre}" # package string
O_U="http://snapshot.opera.com/unix/" # base URI
SRC_URI="
@@ -41,9 +40,8 @@ if [[ "pre${O_B/pre/}" = "${O_B}" ]]; then # snapshot: _pre
x86-fbsd? ( ${O_U}${O_D}/${O_P}.i386.freebsd.tar.xz )
"
else # release: _p
- O_B="${O_B/p}" # remove _p
O_D="${O_V/./}" # directory string
- O_P="${PN}-${O_V}-${O_B}" # package string
+ O_P="${PN}-${O_V}-${O_B/p}" # package string
O_U="mirror://opera/" # base URI
SRC_URI="
diff --git a/www-client/opera-next/opera-next-12.12_pre1662.ebuild b/www-client/opera-next/opera-next-12.12_pre1662.ebuild
index 0587c09a0185..d457f62e9f10 100644
--- a/www-client/opera-next/opera-next-12.12_pre1662.ebuild
+++ b/www-client/opera-next/opera-next-12.12_pre1662.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/opera-next/opera-next-12.12_pre1662.ebuild,v 1.1 2012/11/28 17:40:20 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/opera-next/opera-next-12.12_pre1662.ebuild,v 1.2 2012/11/28 18:34:00 jer Exp $
EAPI=4
inherit eutils fdo-mime gnome2-utils multilib pax-utils versionator
@@ -30,9 +30,8 @@ O_LINGUAS="
# == End of variables that often change ==
if [[ "pre${O_B/pre/}" = "${O_B}" ]]; then # snapshot: _pre
- O_B="${O_B/pre}" # remove _pre
- O_D="${O_K}_${O_V}-${O_B}" # directory string
- O_P="${PN}-${O_V}-${O_B}" # package string
+ O_D="${O_K}_${O_V}-${O_B/pre}" # directory string
+ O_P="${PN}-${O_V}-${O_B/pre}" # package string
O_U="http://snapshot.opera.com/unix/" # base URI
SRC_URI="
@@ -41,9 +40,8 @@ if [[ "pre${O_B/pre/}" = "${O_B}" ]]; then # snapshot: _pre
x86-fbsd? ( ${O_U}${O_D}/${O_P}.i386.freebsd.tar.xz )
"
else # release: _p
- O_B="${O_B/p}" # remove _p
O_D="${O_V/./}" # directory string
- O_P="${PN}-${O_V}-${O_B}" # package string
+ O_P="${PN}-${O_V}-${O_B/p}" # package string
O_U="mirror://opera/" # base URI
SRC_URI="