summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-03-19 14:00:23 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-03-19 14:00:23 +0000
commitd1aee22888090f68c00f9bf72be5b01c958a4411 (patch)
tree7865db831a0f6dcfed571e27071f69df06c55fb9 /www-client/seamonkey-bin
parentMarking ispell-de-alt-2 ppc for bug 262361 (diff)
downloadgentoo-2-d1aee22888090f68c00f9bf72be5b01c958a4411.tar.gz
gentoo-2-d1aee22888090f68c00f9bf72be5b01c958a4411.tar.bz2
gentoo-2-d1aee22888090f68c00f9bf72be5b01c958a4411.zip
Version bump
(Portage version: 2.1.6.7/cvs/Linux ia64)
Diffstat (limited to 'www-client/seamonkey-bin')
-rw-r--r--www-client/seamonkey-bin/ChangeLog8
-rw-r--r--www-client/seamonkey-bin/seamonkey-bin-1.1.15.ebuild72
2 files changed, 79 insertions, 1 deletions
diff --git a/www-client/seamonkey-bin/ChangeLog b/www-client/seamonkey-bin/ChangeLog
index 304348433219..9a3e94c76b02 100644
--- a/www-client/seamonkey-bin/ChangeLog
+++ b/www-client/seamonkey-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/seamonkey-bin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/ChangeLog,v 1.60 2009/03/06 16:55:36 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/ChangeLog,v 1.61 2009/03/19 14:00:23 armin76 Exp $
+
+*seamonkey-bin-1.1.15 (19 Mar 2009)
+
+ 19 Mar 2009; Raúl Porcel <armin76@gentoo.org>
+ +seamonkey-bin-1.1.15.ebuild:
+ Version bump
*seamonkey-bin-2.0_alpha3 (06 Mar 2009)
diff --git a/www-client/seamonkey-bin/seamonkey-bin-1.1.15.ebuild b/www-client/seamonkey-bin/seamonkey-bin-1.1.15.ebuild
new file mode 100644
index 000000000000..644091d50595
--- /dev/null
+++ b/www-client/seamonkey-bin/seamonkey-bin-1.1.15.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/seamonkey-bin-1.1.15.ebuild,v 1.1 2009/03/19 14:00:23 armin76 Exp $
+
+inherit eutils mozilla-launcher multilib
+
+DESCRIPTION="Mozilla Application Suite - web browser, email, HTML editor, IRC"
+SRC_URI="http://releases.mozilla.org/pub/mozilla.org/seamonkey/releases/${PV}/seamonkey-${PV}.en-US.linux-i686.tar.gz"
+HOMEPAGE="http://www.seamonkey-project.org/"
+RESTRICT="strip"
+QA_EXECSTACK="opt/seamonkey/*"
+
+KEYWORDS="-* ~amd64 ~x86"
+SLOT="0"
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+ x86? (
+ >=x11-libs/gtk+-2.2
+ =virtual/libstdc++-3.3
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-1.0
+ >=app-emulation/emul-linux-x86-gtklibs-1.0
+ app-emulation/emul-linux-x86-compat
+ )
+ >=www-client/mozilla-launcher-1.56"
+
+S="${WORKDIR}/seamonkey"
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/opt/seamonkey
+
+ # Install seamonkey in /opt
+ dodir ${MOZILLA_FIVE_HOME%/*}
+ mv "${S}" "${D}${MOZILLA_FIVE_HOME}"
+
+ # Install /usr/bin/seamonkey-bin
+ install_mozilla_launcher_stub seamonkey-bin ${MOZILLA_FIVE_HOME}
+
+ # Install icon and .desktop for menu entry
+ doicon "${FILESDIR}/icon/${PN}.png"
+ domenu "${FILESDIR}/icon/${PN}.desktop"
+}
+
+pkg_preinst() {
+ declare MOZILLA_FIVE_HOME=/opt/seamonkey
+
+ # Remove entire installed instance to prevent all kinds of
+ # problems... see bug 44772 for example
+ rm -rf "${ROOT}${MOZILLA_FIVE_HOME}"
+}
+
+pkg_postinst() {
+ use amd64 && einfo "NB: You just installed a 32-bit seamonkey"
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}