summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-09-12 15:33:09 +0000
committerJeroen Roovers <jer@gentoo.org>2013-09-12 15:33:09 +0000
commit2504633949ce1d6532515ac3d9eec42379457ee8 (patch)
tree9ed96b27d339b6aa881b22d240977c3a0cb1cf58 /www-client/surf
parentVersion bump. Cleanup old. (diff)
downloadgentoo-2-2504633949ce1d6532515ac3d9eec42379457ee8.tar.gz
gentoo-2-2504633949ce1d6532515ac3d9eec42379457ee8.tar.bz2
gentoo-2-2504633949ce1d6532515ac3d9eec42379457ee8.zip
Add live ebuild. Fix elog messages about runtime dependencies (bug #481700 by Ari Malinen).
(Portage version: 2.2.3/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'www-client/surf')
-rw-r--r--www-client/surf/ChangeLog9
-rw-r--r--www-client/surf/surf-0.6-r1.ebuild18
-rw-r--r--www-client/surf/surf-9999.ebuild60
3 files changed, 79 insertions, 8 deletions
diff --git a/www-client/surf/ChangeLog b/www-client/surf/ChangeLog
index b71c1a90c1e7..4e620d7385c6 100644
--- a/www-client/surf/ChangeLog
+++ b/www-client/surf/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-client/surf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/surf/ChangeLog,v 1.28 2013/09/12 15:01:44 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/surf/ChangeLog,v 1.29 2013/09/12 15:33:09 jer Exp $
+
+*surf-9999 (12 Sep 2013)
+
+ 12 Sep 2013; Jeroen Roovers <jer@gentoo.org> surf-0.6-r1.ebuild,
+ +surf-9999.ebuild:
+ Add live ebuild. Fix elog messages about runtime dependencies (bug #481700 by
+ Ari Malinen).
*surf-0.6-r1 (12 Sep 2013)
diff --git a/www-client/surf/surf-0.6-r1.ebuild b/www-client/surf/surf-0.6-r1.ebuild
index 4149f450904e..d71c8fd01753 100644
--- a/www-client/surf/surf-0.6-r1.ebuild
+++ b/www-client/surf/surf-0.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/surf/surf-0.6-r1.ebuild,v 1.1 2013/09/12 15:01:44 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/surf/surf-0.6-r1.ebuild,v 1.2 2013/09/12 15:33:09 jer Exp $
EAPI=5
inherit eutils savedconfig toolchain-funcs
@@ -23,18 +23,22 @@ DEPEND="
"
RDEPEND="
!sci-chemistry/surf
- !savedconfig? ( net-misc/wget )
x11-apps/xprop
x11-misc/dmenu
${DEPEND}
"
pkg_setup() {
- elog "net-misc/wget will be installed by default to"
- elog "support the default download command, which can be changed through"
- elog "the savedconfig mechanism. If you enable USE=savedconfig, you will"
- elog "need to satisfy requirements for the alternative download command"
- elog "yourself."
+ if ! use savedconfig; then
+ elog "The default config.h assumes you have"
+ elog " net-misc/curl"
+ elog " x11-terms/st"
+ elog "installed to support the download function."
+ elog "Without those, downloads will fail (gracefully)."
+ elog "You can fix this by:"
+ elog " 1) Installing these packages, or"
+ elog " 2) Setting USE=savedconfig and changing config.h accordingly."
+ fi
}
src_prepare() {
diff --git a/www-client/surf/surf-9999.ebuild b/www-client/surf/surf-9999.ebuild
new file mode 100644
index 000000000000..3dbb5b83269e
--- /dev/null
+++ b/www-client/surf/surf-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/surf/surf-9999.ebuild,v 1.1 2013/09/12 15:33:09 jer Exp $
+
+EAPI=5
+inherit eutils git-2 savedconfig toolchain-funcs
+
+DESCRIPTION="a simple web browser based on WebKit/GTK+"
+HOMEPAGE="http://surf.suckless.org/"
+EGIT_REPO_URI="git://git.suckless.org/surf"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND="
+ dev-libs/glib
+ net-libs/libsoup
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+"
+RDEPEND="
+ !sci-chemistry/surf
+ x11-apps/xprop
+ x11-misc/dmenu
+ ${DEPEND}
+"
+
+pkg_setup() {
+ if ! use savedconfig; then
+ elog "The default config.h assumes you have"
+ elog " net-misc/curl"
+ elog " x11-terms/st"
+ elog "installed to support the download function."
+ elog "Without those, downloads will fail (gracefully)."
+ elog "You can fix this by:"
+ elog "1) Installing these packages, or"
+ elog "2) Setting USE=savedconfig and changing config.h accordingly."
+ fi
+}
+
+src_prepare() {
+ epatch_user
+ sed -i \
+ -e 's|{|(|g;s|}|)|g' \
+ -e 's|\t@|\t|g;s|echo|@&|g' \
+ -e 's|^LIBS.*|LIBS = $(GTKLIB) -lgthread-2.0|g' \
+ -e 's|^LDFLAGS.*|LDFLAGS += $(LIBS)|g' \
+ -e 's|^CC.*|CC ?= gcc|g' \
+ -e 's|^CFLAGS.*|CFLAGS += -std=c99 -pedantic -Wall $(INCS) $(CPPFLAGS)|g' \
+ config.mk Makefile || die
+ restore_config config.h
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+ save_config config.h
+}