summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-02-04 11:00:59 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-02-04 11:00:59 +0000
commit181d77d176da9db366f8ef64b71ab108e2e8128d (patch)
treeeae6e9acf974ea5a16d24439071bdc78de172a8b /www-client
parentAdd >=seamonkey-bin-2.0_alpha1 mask (diff)
downloadgentoo-2-181d77d176da9db366f8ef64b71ab108e2e8128d.tar.gz
gentoo-2-181d77d176da9db366f8ef64b71ab108e2e8128d.tar.bz2
gentoo-2-181d77d176da9db366f8ef64b71ab108e2e8128d.zip
Version bump
(Portage version: 2.1.6.4/cvs/Linux 2.6.27-gentoo-r8 i686)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/seamonkey-bin/ChangeLog10
-rw-r--r--www-client/seamonkey-bin/seamonkey-bin-2.0_alpha2.ebuild82
2 files changed, 90 insertions, 2 deletions
diff --git a/www-client/seamonkey-bin/ChangeLog b/www-client/seamonkey-bin/ChangeLog
index e116cb2d0672..3f8a415eeb44 100644
--- a/www-client/seamonkey-bin/ChangeLog
+++ b/www-client/seamonkey-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/seamonkey-bin
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/ChangeLog,v 1.58 2008/12/20 21:15:22 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/ChangeLog,v 1.59 2009/02/04 11:00:59 armin76 Exp $
+
+*seamonkey-bin-2.0_alpha2 (04 Feb 2009)
+
+ 04 Feb 2009; Raúl Porcel <armin76@gentoo.org>
+ +seamonkey-bin-2.0_alpha2.ebuild:
+ Version bump
20 Dec 2008; Markus Meier <maekke@gentoo.org> seamonkey-bin-1.1.14.ebuild:
amd64/x86 stable, bug #251322
diff --git a/www-client/seamonkey-bin/seamonkey-bin-2.0_alpha2.ebuild b/www-client/seamonkey-bin/seamonkey-bin-2.0_alpha2.ebuild
new file mode 100644
index 000000000000..87eda01e77a0
--- /dev/null
+++ b/www-client/seamonkey-bin/seamonkey-bin-2.0_alpha2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/seamonkey-bin-2.0_alpha2.ebuild,v 1.1 2009/02/04 11:00:59 armin76 Exp $
+
+inherit eutils mozilla-launcher multilib
+
+MY_PV="${PV/_alpha/a}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Mozilla Application Suite - web browser, email, HTML editor, IRC"
+SRC_URI="http://releases.mozilla.org/pub/mozilla.org/seamonkey/releases/${MY_PV}/seamonkey-${MY_PV}.en-US.linux-i686.tar.bz2"
+HOMEPAGE="http://www.seamonkey-project.org/"
+RESTRICT="strip"
+QA_EXECSTACK="opt/seamonkey/*"
+
+KEYWORDS="-* ~amd64 ~x86"
+SLOT="0"
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-libs/dbus-glib
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+ x86? (
+ >=x11-libs/gtk+-2.2
+ >=media-libs/alsa-lib-1.0.16
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-1.0
+ >=app-emulation/emul-linux-x86-gtklibs-1.0
+ >=app-emulation/emul-linux-x86-soundlibs-20080418
+ app-emulation/emul-linux-x86-compat
+ )"
+
+S="${WORKDIR}/seamonkey"
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/opt/seamonkey
+
+ # Install seamonkey in /opt
+ dodir ${MOZILLA_FIVE_HOME%/*}
+ mv "${S}" "${D}${MOZILLA_FIVE_HOME}"
+
+ # Create /usr/bin/seamonkey-bin
+ dodir /usr/bin/
+ cat <<EOF >"${D}"/usr/bin/seamonkey-bin
+#!/bin/sh
+unset LD_PRELOAD
+exec /opt/seamonkey/seamonkey "\$@"
+EOF
+ fperms 0755 /usr/bin/seamonkey-bin
+
+ # Install icon and .desktop for menu entry
+ doicon "${FILESDIR}/icon/${PN}.png"
+ domenu "${FILESDIR}/icon/${PN}.desktop"
+}
+
+pkg_preinst() {
+ declare MOZILLA_FIVE_HOME=/opt/seamonkey
+
+ # Remove entire installed instance to prevent all kinds of
+ # problems... see bug 44772 for example
+ rm -rf "${ROOT}${MOZILLA_FIVE_HOME}"
+}
+
+pkg_postinst() {
+ use amd64 && einfo "NB: You just installed a 32-bit seamonkey"
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}