summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2011-09-15 21:33:59 +0000
committerMike Gilbert <floppym@gentoo.org>2011-09-15 21:33:59 +0000
commit2841110850f98ff09c3ed2bcc612bd79cfdf357d (patch)
tree5a1e921253b30858b7ca613891cc5bc8d20efd7e /www-client
parentRevision bump and remove old. Fixes bug #382927 with help from Martin von Gag... (diff)
downloadgentoo-2-2841110850f98ff09c3ed2bcc612bd79cfdf357d.tar.gz
gentoo-2-2841110850f98ff09c3ed2bcc612bd79cfdf357d.tar.bz2
gentoo-2-2841110850f98ff09c3ed2bcc612bd79cfdf357d.zip
Enable H.264 support in bundled ffmpeg; bug 382029 by Sylvain Bertrand. Add bindist use flag.
(Portage version: 2.2.0_alpha57_p7/cvs/Linux x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog7
-rw-r--r--www-client/chromium/chromium-14.0.835.163.ebuild15
-rw-r--r--www-client/chromium/chromium-15.0.874.12.ebuild15
-rw-r--r--www-client/chromium/chromium-9999-r1.ebuild15
4 files changed, 45 insertions, 7 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index c4bdbaae6edb..5be393fe3bc1 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.443 2011/09/15 06:19:48 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.444 2011/09/15 21:33:59 floppym Exp $
+
+ 15 Sep 2011; Mike Gilbert <floppym@gentoo.org> chromium-14.0.835.163.ebuild,
+ chromium-15.0.874.12.ebuild, chromium-9999-r1.ebuild:
+ Enable H.264 support in bundled ffmpeg; bug 382029 by Sylvain Bertrand. Add
+ bindist use flag.
15 Sep 2011; Mike Gilbert <floppym@gentoo.org> chromium-9999-r1.ebuild:
Keep third_party/smhasher, bug 382941 by Julien Sanchez.
diff --git a/www-client/chromium/chromium-14.0.835.163.ebuild b/www-client/chromium/chromium-14.0.835.163.ebuild
index 2972e952feca..1880636344ac 100644
--- a/www-client/chromium/chromium-14.0.835.163.ebuild
+++ b/www-client/chromium/chromium-14.0.835.163.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-14.0.835.163.ebuild,v 1.2 2011/09/15 00:27:18 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-14.0.835.163.ebuild,v 1.3 2011/09/15 21:33:59 floppym Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
@@ -15,7 +15,7 @@ SRC_URI="http://build.chromium.org/official/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="cups gnome gnome-keyring kerberos"
+IUSE="bindist cups gnome gnome-keyring kerberos"
# en_US is ommitted on purpose from the list below. It must always be available.
LANGS="am ar bg bn ca cs da de el en_GB es es_LA et fa fi fil fr gu he hi hr
@@ -113,6 +113,12 @@ pkg_setup() {
# bug #363907.
CONFIG_CHECK="~PID_NS ~NET_NS"
check_extra_config
+
+ if use bindist; then
+ elog "bindist enabled: H.264 video support will be disabled."
+ else
+ elog "bindist disabled: Resulting binaries may not be legal to re-distribute."
+ fi
}
src_prepare() {
@@ -221,6 +227,11 @@ src_configure() {
# for Chromium.
# myconf+=" -Dproprietary_codecs=1"
+ if ! use bindist; then
+ # Enable H.624 support in bundled ffmpeg.
+ myconf+=" -Dproprietary_codecs=1 -Dffmpeg_branding=Chrome"
+ fi
+
local myarch="$(tc-arch)"
if [[ $myarch = amd64 ]] ; then
myconf+=" -Dtarget_arch=x64"
diff --git a/www-client/chromium/chromium-15.0.874.12.ebuild b/www-client/chromium/chromium-15.0.874.12.ebuild
index 3a5091ab40be..41a1874d7982 100644
--- a/www-client/chromium/chromium-15.0.874.12.ebuild
+++ b/www-client/chromium/chromium-15.0.874.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-15.0.874.12.ebuild,v 1.2 2011/09/15 00:27:18 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-15.0.874.12.ebuild,v 1.3 2011/09/15 21:33:59 floppym Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
@@ -15,7 +15,7 @@ SRC_URI="http://build.chromium.org/official/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="chromedriver cups gnome gnome-keyring kerberos pulseaudio"
+IUSE="bindist chromedriver cups gnome gnome-keyring kerberos pulseaudio"
# en_US is ommitted on purpose from the list below. It must always be available.
LANGS="am ar bg bn ca cs da de el en_GB es es_LA et fa fi fil fr gu he hi hr
@@ -113,6 +113,12 @@ pkg_setup() {
# bug #363907.
CONFIG_CHECK="~PID_NS ~NET_NS"
check_extra_config
+
+ if use bindist; then
+ elog "bindist enabled: H.264 video support will be disabled."
+ else
+ elog "bindist disabled: Resulting binaries may not be legal to re-distribute."
+ fi
}
src_prepare() {
@@ -224,6 +230,11 @@ src_configure() {
# for Chromium.
# myconf+=" -Dproprietary_codecs=1"
+ if ! use bindist; then
+ # Enable H.624 support in bundled ffmpeg.
+ myconf+=" -Dproprietary_codecs=1 -Dffmpeg_branding=Chrome"
+ fi
+
local myarch="$(tc-arch)"
if [[ $myarch = amd64 ]] ; then
myconf+=" -Dtarget_arch=x64"
diff --git a/www-client/chromium/chromium-9999-r1.ebuild b/www-client/chromium/chromium-9999-r1.ebuild
index 20e2d7d6be60..eba29060a8f3 100644
--- a/www-client/chromium/chromium-9999-r1.ebuild
+++ b/www-client/chromium/chromium-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999-r1.ebuild,v 1.52 2011/09/15 06:19:48 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999-r1.ebuild,v 1.53 2011/09/15 21:33:59 floppym Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
@@ -15,7 +15,7 @@ ESVN_REPO_URI="http://src.chromium.org/svn/trunk/src"
LICENSE="BSD"
SLOT="live"
KEYWORDS=""
-IUSE="chromedriver cups gnome gnome-keyring kerberos pulseaudio"
+IUSE="bindist chromedriver cups gnome gnome-keyring kerberos pulseaudio"
# en_US is ommitted on purpose from the list below. It must always be available.
LANGS="am ar bg bn ca cs da de el en_GB es es_LA et fa fi fil fr gu he hi hr
@@ -165,6 +165,12 @@ pkg_setup() {
# bug #363907.
CONFIG_CHECK="~PID_NS ~NET_NS"
check_extra_config
+
+ if use bindist; then
+ elog "bindist enabled: H.264 video support will be disabled."
+ else
+ elog "bindist disabled: Resulting binaries may not be legal to re-distribute."
+ fi
}
src_prepare() {
@@ -275,6 +281,11 @@ src_configure() {
# for Chromium.
# myconf+=" -Dproprietary_codecs=1"
+ if ! use bindist; then
+ # Enable H.624 support in bundled ffmpeg.
+ myconf+=" -Dproprietary_codecs=1 -Dffmpeg_branding=Chrome"
+ fi
+
local myarch="$(tc-arch)"
if [[ $myarch = amd64 ]] ; then
myconf+=" -Dtarget_arch=x64"