summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-08-28 13:43:25 +0000
committerAlex Alexander <wired@gentoo.org>2010-08-28 13:43:25 +0000
commit4d35282636b68dfb28f9c15c29c55d7d11b0907e (patch)
treea53141cb72b3d2e10befbbf37e4ef3b639a4fb6d /www-client
parentRespect ruby's LDFLAGS and explicitly link against the right shared library. ... (diff)
downloadgentoo-2-4d35282636b68dfb28f9c15c29c55d7d11b0907e.tar.gz
gentoo-2-4d35282636b68dfb28f9c15c29c55d7d11b0907e.tar.bz2
gentoo-2-4d35282636b68dfb28f9c15c29c55d7d11b0907e.zip
fixed compilation with qt 4.7, bug #335011
(Portage version: 2.2_rc71/cvs/Linux x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/arora/ChangeLog6
-rw-r--r--www-client/arora/arora-0.10.2-r1.ebuild6
-rw-r--r--www-client/arora/files/arora-0.10.2_qt_4.7_build_fix.patch29
3 files changed, 39 insertions, 2 deletions
diff --git a/www-client/arora/ChangeLog b/www-client/arora/ChangeLog
index fbd1bfed103f..8b9abbc5411c 100644
--- a/www-client/arora/ChangeLog
+++ b/www-client/arora/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-client/arora
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/arora/ChangeLog,v 1.38 2010/05/11 16:35:25 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/arora/ChangeLog,v 1.39 2010/08/28 13:43:24 wired Exp $
+
+ 28 Aug 2010; Alex Alexander <wired@gentoo.org> arora-0.10.2-r1.ebuild,
+ +files/arora-0.10.2_qt_4.7_build_fix.patch:
+ fixed compilation with qt 4.7, bug #335011
11 May 2010; Joseph Jezak <josejx@gentoo.org> arora-0.10.2-r1.ebuild:
Marked ~ppc for bug #285889.
diff --git a/www-client/arora/arora-0.10.2-r1.ebuild b/www-client/arora/arora-0.10.2-r1.ebuild
index d375eb48a31d..f2447603f559 100644
--- a/www-client/arora/arora-0.10.2-r1.ebuild
+++ b/www-client/arora/arora-0.10.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/arora/arora-0.10.2-r1.ebuild,v 1.7 2010/05/11 16:35:25 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/arora/arora-0.10.2-r1.ebuild,v 1.8 2010/08/28 13:43:24 wired Exp $
EAPI=2
inherit eutils qt4-r2
@@ -34,6 +34,10 @@ for L in $ARORA_NOLONGLANGS; do
done
src_prepare() {
+ # fix compilation with qt 4.7, bug #335011
+ # patch: http://github.com/Arora/arora/commit/5ca8d4b93a284d2e96ba9c2413c4060814258a95
+ epatch "${FILESDIR}"/"${P}"_qt_4.7_build_fix.patch
+
# use Gentoo lingua designations
mv src/locale/sr_RS@latin.ts src/locale/sr@latin.ts
mv src/locale/sr_RS.ts src/locale/sr_CS.ts
diff --git a/www-client/arora/files/arora-0.10.2_qt_4.7_build_fix.patch b/www-client/arora/files/arora-0.10.2_qt_4.7_build_fix.patch
new file mode 100644
index 000000000000..120cdc9f2e0f
--- /dev/null
+++ b/www-client/arora/files/arora-0.10.2_qt_4.7_build_fix.patch
@@ -0,0 +1,29 @@
+From 5ca8d4b93a284d2e96ba9c2413c4060814258a95 Mon Sep 17 00:00:00 2001
+From: Benjamin Poulain <benjamin.poulain@nokia.com>
+Date: Fri, 7 May 2010 12:28:32 +0200
+Subject: [PATCH 02/16] QtWebKit 2.0 declare a meta type for QWebElement
+
+Fix the compilation of Arora with QtWebKit 2.0. QtWebKit 2 already
+declare the meta type, declaring it in Arora results in a clash of
+symbols.
+---
+ src/webview.cpp | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/src/webview.cpp b/src/webview.cpp
+index 30df9a6..43eeeb9 100644
+--- a/src/webview.cpp
++++ b/src/webview.cpp
+@@ -87,7 +87,9 @@
+ #include <qwebframe.h>
+
+ #if QT_VERSION >= 0x040600 || defined(WEBKIT_TRUNK)
++#if !defined(QTWEBKIT_VERSION) || QTWEBKIT_VERSION < 0x020000
+ Q_DECLARE_METATYPE(QWebElement)
++#endif
+ #include <qinputdialog.h>
+ #include <qlabel.h>
+ #include <qmessagebox.h>
+--
+1.7.2.2
+