summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-01-09 00:49:49 +0000
committerMike Gilbert <floppym@gentoo.org>2014-01-09 00:49:49 +0000
commit5116c56e78a537f30b7139c977656af250547e82 (patch)
tree4d7907fb96f4abc68e93bdbf918d87c47d87253d /www-client
parentUpstream is now using rst2pdf instead of LaTeX, updated 9999 ebuild; proxied ... (diff)
downloadgentoo-2-5116c56e78a537f30b7139c977656af250547e82.tar.gz
gentoo-2-5116c56e78a537f30b7139c977656af250547e82.tar.bz2
gentoo-2-5116c56e78a537f30b7139c977656af250547e82.zip
Beta channel bump.
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog8
-rw-r--r--www-client/chromium/chromium-32.0.1700.72.ebuild (renamed from www-client/chromium/chromium-32.0.1700.55.ebuild)36
2 files changed, 25 insertions, 19 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index 0d188861281e..179380310eee 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.1007 2014/01/08 14:07:06 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.1008 2014/01/09 00:49:49 floppym Exp $
+
+*chromium-32.0.1700.72 (09 Jan 2014)
+
+ 09 Jan 2014; Mike Gilbert <floppym@gentoo.org> +chromium-32.0.1700.72.ebuild,
+ -chromium-32.0.1700.55.ebuild:
+ Beta channel bump.
*chromium-33.0.1750.18 (08 Jan 2014)
diff --git a/www-client/chromium/chromium-32.0.1700.55.ebuild b/www-client/chromium/chromium-32.0.1700.72.ebuild
index 56be29309a13..11944cfafac0 100644
--- a/www-client/chromium/chromium-32.0.1700.55.ebuild
+++ b/www-client/chromium/chromium-32.0.1700.72.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-32.0.1700.55.ebuild,v 1.1 2013/12/13 02:00:55 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-32.0.1700.72.ebuild,v 1.1 2014/01/09 00:49:49 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -20,7 +20,7 @@ SRC_URI="https://commondatastorage.googleapis.com/chromium-browser-official/${P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="bindist cups gnome gnome-keyring kerberos neon pulseaudio selinux system-sqlite +tcmalloc"
+IUSE="bindist cups gnome gnome-keyring kerberos neon pulseaudio selinux +tcmalloc"
# Native Client binaries are compiled with different set of flags, bug #452066.
QA_FLAGS_IGNORED=".*\.nexe"
@@ -32,7 +32,6 @@ QA_PRESTRIPPED=".*\.nexe"
RDEPEND=">=app-accessibility/speech-dispatcher-0.8:=
app-arch/bzip2:=
app-arch/snappy:=
- system-sqlite? ( dev-db/sqlite:3 )
cups? (
dev-libs/libgcrypt:=
>=net-print/cups-1.3.11:=
@@ -71,15 +70,11 @@ RDEPEND=">=app-accessibility/speech-dispatcher-0.8:=
kerberos? ( virtual/krb5 )
selinux? ( sec-policy/selinux-chromium )"
DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
!arm? (
dev-lang/yasm
)
dev-lang/perl
dev-perl/JSON
- >=dev-python/jinja-2.7
- dev-python/ply
- dev-python/simplejson
>=dev-util/gperf-3.0.3
dev-util/ninja
sys-apps/hwids
@@ -88,7 +83,6 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
test? (
dev-libs/openssl:0
- dev-python/pyftpdlib
)"
# For nvidia-drivers blocker, see bug #413637 .
RDEPEND+="
@@ -97,6 +91,21 @@ RDEPEND+="
virtual/ttf-fonts
tcmalloc? ( !<x11-drivers/nvidia-drivers-331.20 )"
+# Python dependencies. The DEPEND part needs to be kept in sync
+# with python_check_deps.
+DEPEND+=" $(python_gen_any_dep '
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ test? ( dev-python/pyftpdlib[${PYTHON_USEDEP}] )
+')"
+python_check_deps() {
+ has_version ">=dev-python/jinja-2.7[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/ply[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/simplejson[${PYTHON_USEDEP}]" && \
+ { ! use test || has_version "dev-python/pyftpdlib[${PYTHON_USEDEP}]"; }
+}
+
if ! has chromium_pkg_die ${EBUILD_DEATH_HOOKS}; then
EBUILD_DEATH_HOOKS+=" chromium_pkg_die";
fi
@@ -294,15 +303,6 @@ src_configure() {
$(gyp_use pulseaudio)
$(gyp_use tcmalloc linux_use_tcmalloc)"
- if use system-sqlite; then
- elog "Enabling system sqlite. WebSQL - http://www.w3.org/TR/webdatabase/"
- elog "will not work. Please report sites broken by this"
- elog "to https://bugs.gentoo.org"
- myconf+="
- -Duse_system_sqlite=1
- -Denable_sql_database=0"
- fi
-
# Use explicit library dependencies instead of dlopen.
# This makes breakages easier to detect by revdep-rebuild.
myconf+="