summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-11-09 14:55:13 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-11-09 14:55:13 +0000
commit7b22f5b16ea14416d571dfb1acea578f14739d32 (patch)
tree707ca093bf0385e31597f738afd287bb40512c2a /www-client
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-7b22f5b16ea14416d571dfb1acea578f14739d32.tar.gz
gentoo-2-7b22f5b16ea14416d571dfb1acea578f14739d32.tar.bz2
gentoo-2-7b22f5b16ea14416d571dfb1acea578f14739d32.zip
Re-enable system zlib, thanks to Elias Pipping. Also add gnome-icon-theme to RDEPEND, thanks to Oleksandr Kovalenko <alx.kovalenko@gmail.com> in bug #292201
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog8
-rw-r--r--www-client/chromium/chromium-4.0.240.0.ebuild15
2 files changed, 17 insertions, 6 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index a6c5e13ef485..e87350bce033 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.19 2009/11/08 23:15:39 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.20 2009/11/09 14:55:13 voyageur Exp $
+
+ 09 Nov 2009; Bernard Cafarelli <voyageur@gentoo.org>
+ chromium-4.0.240.0.ebuild:
+ Re-enable system zlib, thanks to Elias Pipping. Also add gnome-icon-theme
+ to RDEPEND, thanks to Oleksandr Kovalenko <alx.kovalenko@gmail.com> in bug
+ #292201
*chromium-4.0.240.0 (08 Nov 2009)
diff --git a/www-client/chromium/chromium-4.0.240.0.ebuild b/www-client/chromium/chromium-4.0.240.0.ebuild
index 7eff858761d9..75114fdda231 100644
--- a/www-client/chromium/chromium-4.0.240.0.ebuild
+++ b/www-client/chromium/chromium-4.0.240.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-4.0.240.0.ebuild,v 1.1 2009/11/08 23:15:39 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-4.0.240.0.ebuild,v 1.2 2009/11/09 14:55:13 voyageur Exp $
EAPI="2"
inherit eutils multilib toolchain-funcs
@@ -25,8 +25,9 @@ RDEPEND="app-arch/bzip2
media-libs/jpeg
media-libs/libpng
>=media-video/ffmpeg-0.5_p19787
- >=x11-libs/gtk+-2.14.7"
-# sys-libs/zlib
+ sys-libs/zlib
+ >=x11-libs/gtk+-2.14.7
+ x11-themes/gnome-icon-theme"
# >=dev-libs/libevent-1.4.13
# dev-db/sqlite:3
DEPEND="${RDEPEND}
@@ -43,6 +44,11 @@ src_prepare() {
# Add configuration flag to use system libevent
epatch "${FILESDIR}"/${PN}-use_system_libevent.patch
+ # Disable prefixing to allow linking against system zlib
+ sed -e '/^#include "mozzconf.h"$/d' \
+ -i third_party/{,WebKit/WebCore/platform/image-decoders}/zlib/zconf.h \
+ || die "zlib sed failed"
+
# Display correct svn revision in about box (if not a release)
if [[ "${PV}" =~ "_p" ]]; then
echo "${PV/[0-9.]*\_p}" > build/LASTCHANGE.in || die "setting revision failed"
@@ -63,8 +69,7 @@ EOF
export HOME="${S}"
# Configuration options (system libraries)
- local myconf="-Duse_system_bzip2=1 -Duse_system_libjpeg=1 -Duse_system_libpng=1 -Duse_system_libxml=1 -Duse_system_libxslt=1 -Duse_system_ffmpeg=1"
- # -Duse_system_zlib=1: needs mozzconf.h and some MOZ_Z_* functions
+ local myconf="-Duse_system_zlib=1 -Duse_system_bzip2=1 -Duse_system_libjpeg=1 -Duse_system_libpng=1 -Duse_system_libxml=1 -Duse_system_libxslt=1 -Duse_system_ffmpeg=1"
# -Duse_system_libevent=1: http://crbug.com/22140
# -Duse_system_sqlite=1 : http://crbug.com/22208
# Others still bundled: icu (not possible?), hunspell (changes required for sandbox support)