summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-04-17 15:11:03 +0000
committerBen de Groot <yngwin@gentoo.org>2009-04-17 15:11:03 +0000
commit7e8e4713b05f87a8e08852e0c25e7e515584940f (patch)
tree59d752ee5d7cde7d62b3a9eec958fec168086eb0 /www-client
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-7e8e4713b05f87a8e08852e0c25e7e515584940f.tar.gz
gentoo-2-7e8e4713b05f87a8e08852e0c25e7e515584940f.tar.bz2
gentoo-2-7e8e4713b05f87a8e08852e0c25e7e515584940f.zip
Fix bug 266497
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/dillo/ChangeLog8
-rw-r--r--www-client/dillo/dillo-2.0-r1.ebuild63
-rw-r--r--www-client/dillo/dillo-9999.ebuild6
-rw-r--r--www-client/dillo/files/dillo-2.0-enable-ssl.patch10
4 files changed, 83 insertions, 4 deletions
diff --git a/www-client/dillo/ChangeLog b/www-client/dillo/ChangeLog
index ff3c7c4a5f4b..a3f66c4692f0 100644
--- a/www-client/dillo/ChangeLog
+++ b/www-client/dillo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/dillo
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/ChangeLog,v 1.70 2009/04/10 15:57:12 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/ChangeLog,v 1.71 2009/04/17 15:11:02 yngwin Exp $
+
+*dillo-2.0-r1 (17 Apr 2009)
+
+ 17 Apr 2009; Ben de Groot <yngwin@gentoo.org>
+ +files/dillo-2.0-enable-ssl.patch, +dillo-2.0-r1.ebuild, dillo-9999:
+ Add patch from bug 266497. Use append-ldflags function.
*dillo-9999 (10 Apr 2009)
diff --git a/www-client/dillo/dillo-2.0-r1.ebuild b/www-client/dillo/dillo-2.0-r1.ebuild
new file mode 100644
index 000000000000..142dcb937a4a
--- /dev/null
+++ b/www-client/dillo/dillo-2.0-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/dillo-2.0-r1.ebuild,v 1.1 2009/04/17 15:11:02 yngwin Exp $
+
+EAPI="2"
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="Lean FLTK2-based web browser"
+HOMEPAGE="http://www.dillo.org/"
+SRC_URI="http://www.dillo.org/download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+IUSE="doc +gif ipv6 +jpeg +png ssl"
+
+RDEPEND="x11-libs/fltk:2[-cairo,jpeg=,png=]
+ sys-libs/zlib
+ jpeg? ( media-libs/jpeg )
+ png? ( media-libs/libpng )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/dillo2-inbuf.patch
+ use ssl && epatch "${FILESDIR}"/${P}-enable-ssl.patch
+}
+
+src_configure() {
+ append-ldflags "-L/usr/$(get_libdir)/fltk"
+ econf \
+ $(use_enable gif) \
+ $(use_enable ipv6) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable ssl)
+}
+
+src_compile() {
+ emake || die "make failed"
+ if use doc ; then
+ doxygen Doxyfile || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ dodir /etc
+ emake DESTDIR="${D}" install || die "install failed"
+
+ if use doc; then
+ dohtml html/* || die "install documentation failed"
+ fi
+ dodoc AUTHORS ChangeLog README NEWS
+ docinto doc
+ dodoc doc/*.txt doc/README
+
+ doicon "${FILESDIR}"/dillo.png
+ make_desktop_entry dillo Dillo dillo
+
+ elog "Dillo has installed a default configuration into /etc/dillorc"
+ elog "You can copy this to ~/.dillo/ and customize it"
+}
diff --git a/www-client/dillo/dillo-9999.ebuild b/www-client/dillo/dillo-9999.ebuild
index 9e39f31e049c..bf04c9131063 100644
--- a/www-client/dillo/dillo-9999.ebuild
+++ b/www-client/dillo/dillo-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/dillo-9999.ebuild,v 1.1 2009/04/10 15:57:12 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/dillo-9999.ebuild,v 1.2 2009/04/17 15:11:02 yngwin Exp $
EAPI="2"
-inherit eutils multilib mercurial
+inherit eutils flag-o-matic multilib mercurial
DESCRIPTION="Lean FLTK2-based web browser"
HOMEPAGE="http://www.dillo.org/"
@@ -30,7 +30,7 @@ src_prepare() {
}
src_configure() {
- LDFLAGS="${LDFLAGS} -L/usr/$(get_libdir)/fltk" \
+ append-ldflags "-L/usr/$(get_libdir)/fltk"
econf \
$(use_enable gif) \
$(use_enable ipv6) \
diff --git a/www-client/dillo/files/dillo-2.0-enable-ssl.patch b/www-client/dillo/files/dillo-2.0-enable-ssl.patch
new file mode 100644
index 000000000000..fb61f52de830
--- /dev/null
+++ b/www-client/dillo/files/dillo-2.0-enable-ssl.patch
@@ -0,0 +1,10 @@
+--- ./dpi/https.c.orig 2009-04-17 17:56:15.000000000 +0900
++++ ./dpi/https.c 2009-04-17 17:56:28.000000000 +0900
+@@ -69,7 +69,6 @@
+
+
+ #define ENABLE_SSL
+-#undef ENABLE_SSL
+ #ifdef ENABLE_SSL
+
+ #include <openssl/ssl.h>