summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-06-26 03:08:02 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-06-26 03:08:02 +0000
commit8c999e7ad703c5a073b5ce8ef41759dd99714e6a (patch)
tree5964a2d8d0cf21e71863d190b847ee34e565c908 /www-client
parentVersion bump. (diff)
downloadgentoo-2-8c999e7ad703c5a073b5ce8ef41759dd99714e6a.tar.gz
gentoo-2-8c999e7ad703c5a073b5ce8ef41759dd99714e6a.tar.bz2
gentoo-2-8c999e7ad703c5a073b5ce8ef41759dd99714e6a.zip
Bump to 5.0, we now install the 64-bit build for amd64 instead of the 32-bit build with emul x86 libs
(Portage version: 2.2.0_alpha39_p14/cvs/Linux x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox-bin/ChangeLog9
-rw-r--r--www-client/firefox-bin/files/firefox-bin-prefs.js6
-rw-r--r--www-client/firefox-bin/firefox-bin-5.0.ebuild167
3 files changed, 181 insertions, 1 deletions
diff --git a/www-client/firefox-bin/ChangeLog b/www-client/firefox-bin/ChangeLog
index 6654309434f5..f4b12bbe8ffe 100644
--- a/www-client/firefox-bin/ChangeLog
+++ b/www-client/firefox-bin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-client/firefox-bin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/firefox-bin/ChangeLog,v 1.59 2011/06/23 14:12:11 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/firefox-bin/ChangeLog,v 1.60 2011/06/26 03:08:02 nirbheek Exp $
+
+*firefox-bin-5.0 (26 Jun 2011)
+
+ 26 Jun 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +firefox-bin-5.0.ebuild,
+ +files/firefox-bin-prefs.js:
+ Bump to 5.0, we now install the 64-bit build for amd64 instead of the 32-bit
+ build with emul x86 libs
*firefox-bin-3.6.18 (23 Jun 2011)
diff --git a/www-client/firefox-bin/files/firefox-bin-prefs.js b/www-client/firefox-bin/files/firefox-bin-prefs.js
new file mode 100644
index 000000000000..c40cec506636
--- /dev/null
+++ b/www-client/firefox-bin/files/firefox-bin-prefs.js
@@ -0,0 +1,6 @@
+pref("app.update.enabled", false);
+pref("app.update.autoInstallEnabled", false);
+pref("browser.display.use_system_colors", true);
+pref("browser.shell.checkDefaultBrowser", false);
+pref("browser.EULA.override", true);
+pref("intl.locale.matchOS", true);
diff --git a/www-client/firefox-bin/firefox-bin-5.0.ebuild b/www-client/firefox-bin/firefox-bin-5.0.ebuild
new file mode 100644
index 000000000000..86346e8fc2be
--- /dev/null
+++ b/www-client/firefox-bin/firefox-bin-5.0.ebuild
@@ -0,0 +1,167 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/firefox-bin/firefox-bin-5.0.ebuild,v 1.1 2011/06/26 03:08:02 nirbheek Exp $
+
+EAPI="3"
+
+inherit eutils mozilla-launcher multilib mozextension
+
+# Can be updated using scripts/get_langs.sh from mozilla overlay
+# '\' at EOL is needed for ${LANG} matching in linguas() below
+LANGS="af ak ar ast be bg bn-BD bn-IN br bs ca cs cy da de \
+el en eo es-ES et eu fa fi fr fy-NL ga-IE gd gl gu-IN \
+he hi-IN hr hu hy-AM id is it ja kk kn ko ku lg lt lv mai mk \
+ml mr nb-NO nl nn-NO nso or pa-IN pl pt-PT rm ro ru si sk sl \
+son sq sr sv-SE ta ta-LK te th tr uk vi zu"
+NOSHORTLANGS="en-GB en-ZA es-AR es-CL es-MX pt-BR zh-CN zh-TW"
+
+MY_PV="${PV/_rc/rc}"
+MY_PN="${PN/-bin}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Firefox Web Browser"
+REL_URI="http://releases.mozilla.org/pub/mozilla.org/${MY_PN}/releases/"
+SRC_URI="
+ amd64? ( ${REL_URI}/${MY_PV}/linux-x86_64/en-US/${MY_P}.tar.bz2 -> ${PN}_x86_64-${PV}.tar.bz2 )
+ x86? ( ${REL_URI}/${MY_PV}/linux-i686/en-US/${MY_P}.tar.bz2 -> ${PN}_i686-${PV}.tar.bz2 )"
+HOMEPAGE="http://www.mozilla.com/firefox"
+RESTRICT="strip mirror"
+
+KEYWORDS="-* ~amd64 ~x86"
+SLOT="0"
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+IUSE="startup-notification"
+
+for X in ${LANGS} ; do
+ if [ "${X}" != "en" ] && [ "${X}" != "en-US" ]; then
+ SRC_URI="${SRC_URI}
+ linguas_${X/-/_}? ( ${REL_URI}/${MY_PV}/linux-i686/xpi/${X}.xpi -> ${P/-bin/}-${X}.xpi )"
+ fi
+ IUSE="${IUSE} linguas_${X/-/_}"
+ # english is handled internally
+ if [ "${#X}" == 5 ] && ! has ${X} ${NOSHORTLANGS}; then
+ if [ "${X}" != "en-US" ]; then
+ SRC_URI="${SRC_URI}
+ linguas_${X%%-*}? ( ${REL_URI}/${MY_PV}/linux-i686/xpi/${X}.xpi -> ${P/-bin/}-${X}.xpi )"
+ fi
+ IUSE="${IUSE} linguas_${X%%-*}"
+ fi
+done
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-libs/dbus-glib
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+
+ >=x11-libs/gtk+-2.2:2
+ >=media-libs/alsa-lib-1.0.16
+"
+
+S="${WORKDIR}/${MY_PN}"
+
+linguas() {
+ local LANG SLANG
+ for LANG in ${LINGUAS}; do
+ if has ${LANG} en en_US; then
+ has en ${linguas} || linguas="${linguas:+"${linguas} "}en"
+ continue
+ elif has ${LANG} ${LANGS//-/_}; then
+ has ${LANG//_/-} ${linguas} || linguas="${linguas:+"${linguas} "}${LANG//_/-}"
+ continue
+ elif [[ " ${LANGS} " == *" ${LANG}-"* ]]; then
+ for X in ${LANGS}; do
+ if [[ "${X}" == "${LANG}-"* ]] && \
+ [[ " ${NOSHORTLANGS} " != *" ${X} "* ]]; then
+ has ${X} ${linguas} || linguas="${linguas:+"${linguas} "}${X}"
+ continue 2
+ fi
+ done
+ fi
+ ewarn "Sorry, but ${PN} does not support the ${LANG} LINGUA"
+ done
+}
+
+src_unpack() {
+ unpack ${A}
+
+ linguas
+ for X in ${linguas}; do
+ [[ ${X} != "en" ]] && xpi_unpack "${P/-bin/}-${X}.xpi"
+ done
+ if [[ ${linguas} != "" && ${linguas} != "en" ]]; then
+ einfo "Selected language packs (first will be default): ${linguas}"
+ fi
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/opt/${MY_PN}
+
+ # Install icon and .desktop for menu entry
+ newicon "${S}"/chrome/icons/default/default48.png ${PN}-icon.png
+ domenu "${FILESDIR}"/${PN}.desktop
+
+ # Add StartupNotify=true bug 237317
+ if use startup-notification; then
+ echo "StartupNotify=true" >> "${D}"/usr/share/applications/${PN}.desktop
+ fi
+
+ # Install firefox in /opt
+ dodir ${MOZILLA_FIVE_HOME%/*}
+ mv "${S}" "${D}"${MOZILLA_FIVE_HOME} || die
+
+ # Fix prefs that make no sense for a system-wide install
+ insinto ${MOZILLA_FIVE_HOME}/defaults/pref/
+ doins "${FILESDIR}"/${PN}-prefs.js || die
+
+ linguas
+ for X in ${linguas}; do
+ [[ ${X} != "en" ]] && xpi_install "${WORKDIR}"/"${P/-bin/}-${X}"
+ done
+
+ local LANG=${linguas%% *}
+ if [[ -n ${LANG} && ${LANG} != "en" ]]; then
+ elog "Setting default locale to ${LANG}"
+ echo "pref(\"general.useragent.locale\", \"${LANG}\");" \
+ >> "${D}${MOZILLA_FIVE_HOME}"/defaults/pref/${PN}-prefs.js || \
+ die "sed failed to change locale"
+ fi
+
+ # Create /usr/bin/firefox-bin
+ dodir /usr/bin/
+ cat <<-EOF >"${D}"/usr/bin/${PN}
+ #!/bin/sh
+ unset LD_PRELOAD
+ LD_LIBRARY_PATH="/opt/firefox/"
+ GTK_PATH=/usr/lib/gtk-2.0/
+ exec /opt/${MY_PN}/${MY_PN} "\$@"
+ EOF
+ fperms 0755 /usr/bin/${PN}
+
+ # revdep-rebuild entry
+ insinto /etc/revdep-rebuild
+ doins "${FILESDIR}"/10${PN} || die
+
+ ln -sfn "/usr/$(get_libdir)/nsbrowser/plugins" \
+ "${D}${MOZILLA_FIVE_HOME}/plugins" || die
+}
+
+pkg_postinst() {
+ if ! has_version 'gnome-base/gconf' || ! has_version 'gnome-base/orbit' \
+ || ! has_version 'net-misc/curl'; then
+ einfo
+ einfo "For using the crashreporter, you need gnome-base/gconf,"
+ einfo "gnome-base/orbit and net-misc/curl emerged."
+ einfo
+ fi
+ if has_version 'net-misc/curl[nss]'; then
+ einfo
+ einfo "Crashreporter won't be able to send reports"
+ einfo "if you have curl emerged with the nss USE-flag"
+ einfo
+ fi
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}