summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuele Giaquinta <exg@gentoo.org>2006-08-31 21:20:03 +0000
committerEmanuele Giaquinta <exg@gentoo.org>2006-08-31 21:20:03 +0000
commita0f93f54d422f24a7b60d674c017d81f5e94b17d (patch)
treeb06afbf4c392ae632f2dba36f913943e2b156b02 /www-client
parent~amd64 (diff)
downloadgentoo-2-a0f93f54d422f24a7b60d674c017d81f5e94b17d.tar.gz
gentoo-2-a0f93f54d422f24a7b60d674c017d81f5e94b17d.tar.bz2
gentoo-2-a0f93f54d422f24a7b60d674c017d81f5e94b17d.zip
Add patch to fix bug #145739.
(Portage version: 2.1.1_rc1-r2)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/lynx/ChangeLog8
-rw-r--r--www-client/lynx/files/digest-lynx-2.8.5-r46
-rw-r--r--www-client/lynx/files/lynx-2.8.5-embedded-url.patch51
-rw-r--r--www-client/lynx/lynx-2.8.5-r4.ebuild77
4 files changed, 141 insertions, 1 deletions
diff --git a/www-client/lynx/ChangeLog b/www-client/lynx/ChangeLog
index ff3ad91b0990..d3f0b7b093e7 100644
--- a/www-client/lynx/ChangeLog
+++ b/www-client/lynx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/lynx
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/ChangeLog,v 1.36 2006/08/10 08:31:54 exg Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/ChangeLog,v 1.37 2006/08/31 21:20:03 exg Exp $
+
+*lynx-2.8.5-r4 (31 Aug 2006)
+
+ 31 Aug 2006; Emanuele Giaquinta <exg@gentoo.org>
+ +files/lynx-2.8.5-embedded-url.patch, +lynx-2.8.5-r4.ebuild:
+ Add patch to fix bug #145739.
10 Aug 2006; Emanuele Giaquinta <exg@gentoo.org> lynx-2.8.5-r3.ebuild,
lynx-2.8.6_pre18.ebuild:
diff --git a/www-client/lynx/files/digest-lynx-2.8.5-r4 b/www-client/lynx/files/digest-lynx-2.8.5-r4
new file mode 100644
index 000000000000..f7f732972368
--- /dev/null
+++ b/www-client/lynx/files/digest-lynx-2.8.5-r4
@@ -0,0 +1,6 @@
+MD5 070b1da6098ca1bb8b084713766dfb3a lynx-2.8.5-rel5.patch.bz2 6907
+RMD160 9e843f4c235c1de17a4ebe62ad1511dd9ed1f620 lynx-2.8.5-rel5.patch.bz2 6907
+SHA256 a6997212e7a36c109f57856d1ce185c074b598f2fb1b1d3d9c57fe38df5d6ccb lynx-2.8.5-rel5.patch.bz2 6907
+MD5 d1e5134e5d175f913c16cb6768bc30eb lynx2.8.5.tar.bz2 2177287
+RMD160 80d20261ac6eaebe1d940fb5de485daaad7bb3b7 lynx2.8.5.tar.bz2 2177287
+SHA256 37607008086933c869be26b4db687f61a768c51ddefa741e77225069b880bc63 lynx2.8.5.tar.bz2 2177287
diff --git a/www-client/lynx/files/lynx-2.8.5-embedded-url.patch b/www-client/lynx/files/lynx-2.8.5-embedded-url.patch
new file mode 100644
index 000000000000..8bf23803997b
--- /dev/null
+++ b/www-client/lynx/files/lynx-2.8.5-embedded-url.patch
@@ -0,0 +1,51 @@
+--- WWW/Library/Implementation/HTParse.c.old 2006-08-31 22:55:10.031020854 +0200
++++ WWW/Library/Implementation/HTParse.c 2006-08-31 22:56:58.964604699 +0200
+@@ -166,6 +166,16 @@
+ #define LYalloca_free(x) free(x)
+ #endif
+
++static char *strchr_or_end(char *string, int ch)
++{
++ char *result = strchr(string, ch);
++
++ if (result == 0) {
++ result = string + strlen(string);
++ }
++ return result;
++}
++
+ /* Parse a Name relative to another name. HTParse()
+ ** --------------------------------------
+ **
+@@ -455,13 +465,24 @@
+ *tail++ = '/';
+ strcpy(tail, related.absolute);
+ if (given.relative) {
+- p = strchr(tail, '?'); /* Search part? */
+- if (p == NULL)
+- p = (tail + strlen(tail) - 1);
+- for (; *p != '/'; p--)
+- ; /* last / */
+- p[1] = '\0'; /* Remove filename */
+- strcat(p, given.relative); /* Add given one */
++ /* RFC 1808 part 4 step 5 (if URL path is empty) */
++ /* a) if given has params, add/replace that */
++ if (given.relative[0] == ';') {
++ strcpy(strchr_or_end(tail, ';'), given.relative);
++ }
++ /* b) if given has query, add/replace that */
++ else if (given.relative[0] == '?') {
++ strcpy(strchr_or_end(tail, '?'), given.relative);
++ }
++ /* otherwise fall through to RFC 1808 part 4 step 6 */
++ else {
++ p = strchr(tail, '?'); /* Search part? */
++ if (p == NULL)
++ p = (tail + strlen(tail) - 1);
++ for (; *p != '/'; p--) ; /* last / */
++ p[1] = '\0'; /* Remove filename */
++ strcat(p, given.relative); /* Add given one */
++ }
+ HTSimplify (result);
+ }
+ CTRACE((tfp, "HTParse: (Related-ABS)\n"));
diff --git a/www-client/lynx/lynx-2.8.5-r4.ebuild b/www-client/lynx/lynx-2.8.5-r4.ebuild
new file mode 100644
index 000000000000..8c93d6cfadc3
--- /dev/null
+++ b/www-client/lynx/lynx-2.8.5-r4.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/lynx-2.8.5-r4.ebuild,v 1.1 2006/08/31 21:20:03 exg Exp $
+
+inherit eutils flag-o-matic
+
+MY_P="${P/-/}"
+DESCRIPTION="An excellent console-based web browser with ssl support"
+HOMEPAGE="http://lynx.browser.org/"
+SRC_URI="ftp://lynx.isc.org/${MY_P}/${MY_P}.tar.bz2
+ mirror://gentoo/${P}-rel5.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
+IUSE="bzip2 cjk ipv6 nls ssl"
+
+DEPEND="sys-libs/ncurses
+ sys-libs/zlib
+ nls? ( sys-devel/gettext )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ bzip2? ( app-arch/bzip2 )"
+
+S="${WORKDIR}/${PN}${PV//./-}"
+
+src_unpack() {
+ unpack ${A}; cd "${S}"
+ epatch "${DISTDIR}/${P}"-rel5.patch.bz2
+ epatch "${FILESDIR}/${P}"-darwin.patch
+ epatch "${FILESDIR}/${P}"-tab_to.patch
+ epatch "${FILESDIR}/${P}"-embedded-url.patch
+}
+
+src_compile() {
+ local myconf
+ use ssl && myconf="${myconf} --with-ssl=yes"
+ use bzip2 && myconf="${myconf} --with-bzlib"
+
+ append-flags -DANSI_VARARGS
+
+ econf \
+ --libdir=/etc/lynx \
+ --enable-cgi-links \
+ --enable-EXP_PERSISTENT_COOKIES \
+ --enable-prettysrc \
+ --enable-nsl-fork \
+ --enable-file-upload \
+ --enable-read-eta \
+ --enable-libjs \
+ --enable-color-style \
+ --enable-scrollbar \
+ --enable-included-msgs \
+ --with-zlib \
+ $(use_enable nls) \
+ $(use_enable ipv6) \
+ $(use_enable cjk) \
+ ${myconf} || die
+
+ emake -j1 || die "compile problem"
+}
+
+src_install() {
+ einstall libdir="${D}"/etc/lynx || die
+
+ dosed "s|^HELPFILE.*$|HELPFILE:file://localhost/usr/share/doc/${PF}/lynx_help/lynx_help/lynx_help_main.html|" \
+ /etc/lynx/lynx.cfg
+ dodoc CHANGES COPYHEADER INSTALLATION PROBLEMS README
+ docinto docs
+ dodoc docs/*
+ docinto lynx_help
+ dodoc lynx_help/*.txt
+ dohtml -r lynx_help
+
+ # small little manpage glitch
+ rm "${D}"/usr/share/man/lynx.1
+ newman lynx.man lynx.1
+}