summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-06-21 04:09:19 +0000
committerMike Gilbert <floppym@gentoo.org>2013-06-21 04:09:19 +0000
commitb250130ff449ab310c580a5911e515186b5b0fab (patch)
treea82297a9c56ea6f81b5bac6b7c840aed74d981aa /www-client
parentPatch for fixing the path to the singular rawstudio.png wrt #389397 (diff)
downloadgentoo-2-b250130ff449ab310c580a5911e515186b5b0fab.tar.gz
gentoo-2-b250130ff449ab310c580a5911e515186b5b0fab.tar.bz2
gentoo-2-b250130ff449ab310c580a5911e515186b5b0fab.zip
Beta channel bump. Backport nss-3.15 compatibility patch.
(Portage version: 2.2.0_alpha181/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog8
-rw-r--r--www-client/chromium/chromium-28.0.1500.52.ebuild (renamed from www-client/chromium/chromium-28.0.1500.36.ebuild)15
-rw-r--r--www-client/chromium/files/chromium-nss-3.15.patch26
3 files changed, 44 insertions, 5 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index c0f26b186840..eed5545cb7ec 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.899 2013/06/20 03:58:52 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.900 2013/06/21 04:09:19 floppym Exp $
+
+*chromium-28.0.1500.52 (21 Jun 2013)
+
+ 21 Jun 2013; Mike Gilbert <floppym@gentoo.org> +chromium-28.0.1500.52.ebuild,
+ +files/chromium-nss-3.15.patch, -chromium-28.0.1500.36.ebuild:
+ Beta channel bump. Backport nss-3.15 compatibility patch.
*chromium-29.0.1541.2 (20 Jun 2013)
diff --git a/www-client/chromium/chromium-28.0.1500.36.ebuild b/www-client/chromium/chromium-28.0.1500.52.ebuild
index f6d2c761f808..f4253b40cd58 100644
--- a/www-client/chromium/chromium-28.0.1500.36.ebuild
+++ b/www-client/chromium/chromium-28.0.1500.52.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-28.0.1500.36.ebuild,v 1.1 2013/06/07 01:06:51 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-28.0.1500.52.ebuild,v 1.1 2013/06/21 04:09:19 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -25,7 +25,7 @@ IUSE="bindist cups gnome gnome-keyring gps kerberos pulseaudio selinux +system-f
# Native Client binaries are compiled with different set of flags, bug #452066.
QA_FLAGS_IGNORED=".*\.nexe"
-RDEPEND=">=app-accessibility/speech-dispatcher-0.8:=
+RDEPEND="app-accessibility/speech-dispatcher:=
app-arch/bzip2:=
app-arch/snappy:=
system-sqlite? ( dev-db/sqlite:3 )
@@ -136,6 +136,8 @@ src_prepare() {
# Fix build with harfbuzz-0.9.18, bug #472416 .
epatch "${FILESDIR}/${PN}-system-harfbuzz-r0.patch"
+ epatch "${FILESDIR}/${PN}-nss-3.15.patch"
+
epatch_user
# Remove most bundled libraries. Some are still needed.
@@ -287,8 +289,13 @@ src_configure() {
myconf+="
-Dlinux_link_gsettings=1
-Dlinux_link_libpci=1
- -Dlinux_link_libspeechd=1
- -Dlibspeechd_h_prefix=speech-dispatcher/"
+ -Dlinux_link_libspeechd=1"
+
+ if has_version '>=app-accessibility/speech-dispatcher-0.8'; then
+ myconf+=" -Dlibspeechd_h_prefix=speech-dispatcher/"
+ else
+ myconf+=" -Dlibspeechd_h_prefix="
+ fi
# TODO: use the file at run time instead of effectively compiling it in.
myconf+="
diff --git a/www-client/chromium/files/chromium-nss-3.15.patch b/www-client/chromium/files/chromium-nss-3.15.patch
new file mode 100644
index 000000000000..312614ed7897
--- /dev/null
+++ b/www-client/chromium/files/chromium-nss-3.15.patch
@@ -0,0 +1,26 @@
+--- a/net/third_party/nss/ssl/bodge/secitem_array.c
++++ b/net/third_party/nss/ssl/bodge/secitem_array.c
+@@ -6,6 +6,7 @@
+ * Support routines for SECItemArray data structure.
+ */
+
++#include "nssutil.h"
+ #include "seccomon.h"
+ #include "secitem.h"
+ #include "secerr.h"
+@@ -13,10 +14,15 @@
+
+ typedef struct SECItemArrayStr SECItemArray;
+
++#define NSSUTIL_VERSION_NUM \
++ (NSSUTIL_VMAJOR * 10000 + NSSUTIL_VMINOR * 100 + NSSUTIL_VPATCH)
++#if NSSUTIL_VERSION_NUM < 31500
++// Added in NSS 3.15.
+ struct SECItemArrayStr {
+ SECItem *items;
+ unsigned int len;
+ };
++#endif
+
+ SECItemArray *
+ SECITEM_AllocArray(PLArenaPool *arena, SECItemArray *array, unsigned int len)