summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-10-21 20:10:21 +0000
committerJeroen Roovers <jer@gentoo.org>2014-10-21 20:10:21 +0000
commitb87cc3feca863b684dfc5607f154b8fc5a04783d (patch)
tree2478c3c897a68343b7cda3545cc244f344a56a39 /www-client
parentAdd zcat fix from upstream. (diff)
downloadgentoo-2-b87cc3feca863b684dfc5607f154b8fc5a04783d.tar.gz
gentoo-2-b87cc3feca863b684dfc5607f154b8fc5a04783d.tar.bz2
gentoo-2-b87cc3feca863b684dfc5607f154b8fc5a04783d.zip
Fix bash-completion (bug #526342).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/surfraw/ChangeLog8
-rw-r--r--www-client/surfraw/files/surfraw-2.2.9-completion.patch10
-rw-r--r--www-client/surfraw/surfraw-2.2.9-r1.ebuild90
3 files changed, 107 insertions, 1 deletions
diff --git a/www-client/surfraw/ChangeLog b/www-client/surfraw/ChangeLog
index 9b0b10c58d89..a4627b99e4b0 100644
--- a/www-client/surfraw/ChangeLog
+++ b/www-client/surfraw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/surfraw
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/surfraw/ChangeLog,v 1.78 2014/03/12 15:39:42 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/surfraw/ChangeLog,v 1.79 2014/10/21 20:10:21 jer Exp $
+
+*surfraw-2.2.9-r1 (21 Oct 2014)
+
+ 21 Oct 2014; Jeroen Roovers <jer@gentoo.org> +surfraw-2.2.9-r1.ebuild,
+ +files/surfraw-2.2.9-completion.patch:
+ Fix bash-completion (bug #526342).
12 Mar 2014; Jeroen Roovers <jer@gentoo.org> -surfraw-2.2.8.ebuild:
Old.
diff --git a/www-client/surfraw/files/surfraw-2.2.9-completion.patch b/www-client/surfraw/files/surfraw-2.2.9-completion.patch
new file mode 100644
index 000000000000..0fb759f864b5
--- /dev/null
+++ b/www-client/surfraw/files/surfraw-2.2.9-completion.patch
@@ -0,0 +1,10 @@
+--- a/surfraw-bash-completion.IN
++++ b/surfraw-bash-completion.IN
+@@ -45,5 +45,5 @@
+ fi
+ return 0
+ }
+-# test first in case removed-but-unpurged
+-type -p surfraw >/dev/null 2>&1 && complete -F _surfraw surfraw sr
++
++complete -F _surfraw surfraw sr
diff --git a/www-client/surfraw/surfraw-2.2.9-r1.ebuild b/www-client/surfraw/surfraw-2.2.9-r1.ebuild
new file mode 100644
index 000000000000..a914384307e8
--- /dev/null
+++ b/www-client/surfraw/surfraw-2.2.9-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/surfraw/surfraw-2.2.9-r1.ebuild,v 1.1 2014/10/21 20:10:21 jer Exp $
+
+EAPI=5
+
+inherit bash-completion-r1 eutils
+
+DESCRIPTION="A fast unix command line interface to WWW"
+HOMEPAGE="http://surfraw.alioth.debian.org/"
+SRC_URI="http://${PN}.alioth.debian.org/dist/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+RESTRICT="test"
+RDEPEND="dev-lang/perl"
+
+DOCS=(AUTHORS ChangeLog HACKING NEWS README TODO)
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-2.2.6-gentoo_pkg_tools.patch \
+ "${FILESDIR}"/${PN}-2.2.9-completion.patch
+}
+
+src_configure() {
+ econf --with-elvidir='$(datadir)'/surfraw
+}
+
+src_install() {
+ default
+
+ newbashcomp surfraw-bash-completion ${PN}
+ bashcomp_alias ${PN} sr
+
+ docinto examples
+ dodoc examples/README
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/uzbl_load_url_from_surfraw
+}
+
+pkg_preinst() {
+ has_version "=${CATEGORY}/${PN}-1.0.7"
+ upgrade_from_1_0_7=$?
+}
+
+pkg_postinst() {
+ local moves f
+
+ einfo
+ einfo "You can get a list of installed elvi by just typing 'surfraw' or"
+ einfo "the abbreviated 'sr'."
+ einfo
+ einfo "You can try some searches, for example:"
+ einfo "$ sr ask why is jeeves gay? "
+ einfo "$ sr google -results=100 RMS, GNU, which is sinner, which is sin?"
+ einfo "$ sr rhyme -method=perfect Julian"
+ einfo
+ einfo "The system configuration file is /etc/surfraw.conf"
+ einfo
+ einfo "Users can specify preferences in '~/.surfraw.conf' e.g."
+ einfo "SURFRAW_graphical_browser=mozilla"
+ einfo "SURFRAW_text_browser=w3m"
+ einfo "SURFRAW_graphical=no"
+ einfo
+ einfo "surfraw works with any graphical and/or text WWW browser"
+ einfo
+ if [[ $upgrade_from_1_0_7 = 0 ]] ; then
+ ewarn "surfraw usage has changed slightly since version 1.0.7, elvi are now called"
+ ewarn "using the 'sr' wrapper script as described above. If you wish to return to"
+ ewarn "the old behaviour you can add /usr/share/surfraw to your \$PATH"
+ fi
+ # This file was always autogenerated, and is no longer needed.
+ if [ -f "${EROOT}"/etc/surfraw_elvi.list ]; then
+ rm -f "${EROOT}"/etc/surfraw_elvi.list
+ fi
+
+ # Config file location changes in v2.2.6
+ for f in /etc/surfraw.{bookmarks,conf}; do
+ if [ -f "${EROOT}"${f} ]; then
+ ewarn "${f} has moved to /etc/xdg/config/surfraw/${f##*.} in v2.2.6."
+ moves=1
+ fi
+ done
+ if [ "${moves}" == 1 ]; then
+ ewarn "You must manually move, and update, the config files listed"
+ ewarn "above for surfraw v2.2.6 and above to use them."
+ fi
+}