summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-08-05 14:11:39 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-08-05 14:11:39 +0000
commitdf2aa44973330aefb8e2d57c223acc917fafda23 (patch)
treefdc0746ca688a701373156fe37f7106cb0b5dd4a /www-client
parentMultilib fix, this time for real. Thanks to Ken69267 for testing. (diff)
downloadgentoo-2-df2aa44973330aefb8e2d57c223acc917fafda23.tar.gz
gentoo-2-df2aa44973330aefb8e2d57c223acc917fafda23.tar.bz2
gentoo-2-df2aa44973330aefb8e2d57c223acc917fafda23.zip
Version bump wrt security #185737
(Portage version: 2.1.2.11)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/seamonkey-bin/ChangeLog8
-rw-r--r--www-client/seamonkey-bin/files/digest-seamonkey-bin-1.1.43
-rw-r--r--www-client/seamonkey-bin/seamonkey-bin-1.1.4.ebuild71
3 files changed, 81 insertions, 1 deletions
diff --git a/www-client/seamonkey-bin/ChangeLog b/www-client/seamonkey-bin/ChangeLog
index 0e2652acad32..d88ff0c380e8 100644
--- a/www-client/seamonkey-bin/ChangeLog
+++ b/www-client/seamonkey-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/seamonkey-bin
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/ChangeLog,v 1.20 2007/07/28 18:21:17 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/ChangeLog,v 1.21 2007/08/05 14:11:39 armin76 Exp $
+
+*seamonkey-bin-1.1.4 (05 Aug 2007)
+
+ 05 Aug 2007; Raúl Porcel <armin76@gentoo.org>
+ +seamonkey-bin-1.1.4.ebuild:
+ Version bump wrt security #185737
28 Jul 2007; Raúl Porcel <armin76@gentoo.org>
-seamonkey-bin-1.1.2.ebuild:
diff --git a/www-client/seamonkey-bin/files/digest-seamonkey-bin-1.1.4 b/www-client/seamonkey-bin/files/digest-seamonkey-bin-1.1.4
new file mode 100644
index 000000000000..cdb4168c4d9f
--- /dev/null
+++ b/www-client/seamonkey-bin/files/digest-seamonkey-bin-1.1.4
@@ -0,0 +1,3 @@
+MD5 b4b243e058c2128596aabb246044f886 seamonkey-1.1.4.en-US.linux-i686.tar.gz 14789982
+RMD160 b7ff7247dce92044a65be79b7437569e26494beb seamonkey-1.1.4.en-US.linux-i686.tar.gz 14789982
+SHA256 9032d5441d0674d6c7c7235eb6c5570a1713ec017443cb7fda840959c02243e5 seamonkey-1.1.4.en-US.linux-i686.tar.gz 14789982
diff --git a/www-client/seamonkey-bin/seamonkey-bin-1.1.4.ebuild b/www-client/seamonkey-bin/seamonkey-bin-1.1.4.ebuild
new file mode 100644
index 000000000000..699005d7f489
--- /dev/null
+++ b/www-client/seamonkey-bin/seamonkey-bin-1.1.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/seamonkey-bin-1.1.4.ebuild,v 1.1 2007/08/05 14:11:39 armin76 Exp $
+
+inherit eutils mozilla-launcher multilib
+
+DESCRIPTION="Mozilla Application Suite - web browser, email, HTML editor, IRC"
+SRC_URI="http://releases.mozilla.org/pub/mozilla.org/seamonkey/releases/${PV}/seamonkey-${PV}.en-US.linux-i686.tar.gz"
+HOMEPAGE="http://www.mozilla.org/projects/seamonkey/"
+RESTRICT="strip"
+
+KEYWORDS="-* ~amd64 ~x86"
+SLOT="0"
+LICENSE="MPL-1.1 GPL-2 LGPL-2.1"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+ x86? (
+ >=x11-libs/gtk+-2.2
+ =virtual/libstdc++-3.3
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-1.0
+ >=app-emulation/emul-linux-x86-gtklibs-1.0
+ app-emulation/emul-linux-x86-compat
+ )
+ >=www-client/mozilla-launcher-1.56"
+
+S="${WORKDIR}/seamonkey"
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/opt/seamonkey
+
+ # Install seamonkey in /opt
+ dodir ${MOZILLA_FIVE_HOME%/*}
+ mv ${S} ${D}${MOZILLA_FIVE_HOME}
+
+ # Install /usr/bin/seamonkey-bin
+ install_mozilla_launcher_stub seamonkey-bin ${MOZILLA_FIVE_HOME}
+
+ # Install icon and .desktop for menu entry
+ doicon ${FILESDIR}/icon/${PN}-icon.png
+ domenu ${FILESDIR}/icon/${PN}.desktop
+}
+
+pkg_preinst() {
+ declare MOZILLA_FIVE_HOME=/opt/seamonkey
+
+ # Remove entire installed instance to prevent all kinds of
+ # problems... see bug 44772 for example
+ rm -rf "${ROOT}${MOZILLA_FIVE_HOME}"
+}
+
+pkg_postinst() {
+ use amd64 && einfo "NB: You just installed a 32-bit seamonkey"
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}