summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-05-01 13:42:02 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-05-01 13:42:02 +0000
commit11ca2c8313f0d7df097f3c06873d6659573736ed (patch)
treeab54e216f32ca59893d6f205ced837818ef2882b /www-misc/htdig/htdig-3.2.0_beta6-r1.ebuild
parentversion bump (diff)
downloadgentoo-2-11ca2c8313f0d7df097f3c06873d6659573736ed.tar.gz
gentoo-2-11ca2c8313f0d7df097f3c06873d6659573736ed.tar.bz2
gentoo-2-11ca2c8313f0d7df097f3c06873d6659573736ed.zip
Bye bye webapp.eclass: should fix #28049 , #107062 , #110528 , #125136 ; also
see #120830. Added https patch ( bug #52613 ). Misc housekeeping. (Portage version: 2.1_pre9-r5)
Diffstat (limited to 'www-misc/htdig/htdig-3.2.0_beta6-r1.ebuild')
-rw-r--r--www-misc/htdig/htdig-3.2.0_beta6-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/www-misc/htdig/htdig-3.2.0_beta6-r1.ebuild b/www-misc/htdig/htdig-3.2.0_beta6-r1.ebuild
new file mode 100644
index 000000000000..a59afaef0477
--- /dev/null
+++ b/www-misc/htdig/htdig-3.2.0_beta6-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/htdig/htdig-3.2.0_beta6-r1.ebuild,v 1.1 2006/05/01 13:42:02 rl03 Exp $
+
+inherit eutils flag-o-matic
+
+MY_PV=${PV/_beta/b}
+S=${WORKDIR}/${PN}-${MY_PV}
+
+DESCRIPTION="HTTP/HTML indexing and searching system"
+SRC_URI="http://www.htdig.org/files/${PN}-${MY_PV}.tar.gz"
+HOMEPAGE="http://www.htdig.org"
+KEYWORDS="~x86 ~sparc ~ppc ~mips ~amd64"
+LICENSE="GPL-2"
+
+DEPEND=">=sys-libs/zlib-1.1.3
+ app-arch/unzip"
+
+SLOT="0"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc4.patch
+}
+
+src_compile() {
+ econf \
+ --with-config-dir=/etc/${PN} \
+ --with-default-config-file=/etc/${PN}/${PN}.conf \
+ --with-database-dir=/var/lib/${PN}/db \
+ --with-cgi-bin-dir=/var/www/localhost/cgi-bin \
+ --with-search-dir=/var/www/localhost/htdocs/${PN} \
+ --with-image-dir=/var/www/localhost/htdocs/${PN} \
+ --with-image-url-prefix=file:///var/www/localhost/htdocs/${PN} \
+ || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "make install failed"
+
+ dodoc ChangeLog COPYING README
+ dohtml -r htdoc
+
+ dosed /etc/${PN}/${PN}.conf
+ dosed /usr/bin/rundig
+
+ # symlink htsearch so it can be easily found. see bug #62087
+ dosym /var/www/localhost/cgi-bin/htsearch /usr/bin/htsearch
+}