summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-02-10 03:00:12 +0000
committerMike Gilbert <floppym@gentoo.org>2014-02-10 03:00:12 +0000
commitddf20d384567906ced50a2e141fb5a337db0ae80 (patch)
treec95b64a644f67ca260a91152bfa9d5b15c13ba0e /www-misc/litmus
parentVersion bump, add crypt use flag for XEP-0027 support using dev-python/python... (diff)
downloadgentoo-2-ddf20d384567906ced50a2e141fb5a337db0ae80.tar.gz
gentoo-2-ddf20d384567906ced50a2e141fb5a337db0ae80.tar.bz2
gentoo-2-ddf20d384567906ced50a2e141fb5a337db0ae80.zip
Allow >=net-libs/neon-30, bug 499732 by Arfrever. Also several other small changes from maintainer Bertrand Jacquin.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'www-misc/litmus')
-rw-r--r--www-misc/litmus/ChangeLog9
-rw-r--r--www-misc/litmus/files/0.13-autotools-neon-version.patch11
-rw-r--r--www-misc/litmus/litmus-0.13.ebuild44
-rw-r--r--www-misc/litmus/metadata.xml1
4 files changed, 44 insertions, 21 deletions
diff --git a/www-misc/litmus/ChangeLog b/www-misc/litmus/ChangeLog
index b53f1852a8ba..d5a4a0329e32 100644
--- a/www-misc/litmus/ChangeLog
+++ b/www-misc/litmus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-misc/litmus
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/litmus/ChangeLog,v 1.3 2013/09/02 00:43:49 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/litmus/ChangeLog,v 1.4 2014/02/10 03:00:12 floppym Exp $
+
+ 10 Feb 2014; Mike Gilbert <floppym@gentoo.org>
+ +files/0.13-autotools-neon-version.patch, litmus-0.13.ebuild, metadata.xml:
+ Allow >=net-libs/neon-30, bug 499732 by Arfrever. Also several other small
+ changes from maintainer Bertrand Jacquin.
02 Sep 2013; Patrick Lauer <patrick@gentoo.org> metadata.xml:
Remove unneeded useflag description from metadata.xml
diff --git a/www-misc/litmus/files/0.13-autotools-neon-version.patch b/www-misc/litmus/files/0.13-autotools-neon-version.patch
new file mode 100644
index 000000000000..c2e0211b6508
--- /dev/null
+++ b/www-misc/litmus/files/0.13-autotools-neon-version.patch
@@ -0,0 +1,11 @@
+--- configure.ac.ori 2014-01-31 01:00:58.796123088 +0100
++++ configure.ac 2014-01-31 01:00:43.767787763 +0100
+@@ -20,7 +20,7 @@
+ dnl List of tests
+ AC_SUBST([TESTS], ["basic copymove props locks http"])
+
+-NE_REQUIRE_VERSIONS([0], [25 26 27 28 29])
++NE_REQUIRE_VERSIONS([0], [25 26 27 28 29 30])
+ NEON_WITHOUT_ZLIB
+ NEON_WITHOUT_ACL
+ NEON_TEST
diff --git a/www-misc/litmus/litmus-0.13.ebuild b/www-misc/litmus/litmus-0.13.ebuild
index 2aba090b4275..bf903626d5b3 100644
--- a/www-misc/litmus/litmus-0.13.ebuild
+++ b/www-misc/litmus/litmus-0.13.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/litmus/litmus-0.13.ebuild,v 1.2 2013/09/01 18:26:28 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/litmus/litmus-0.13.ebuild,v 1.3 2014/02/10 03:00:12 floppym Exp $
EAPI="5"
+inherit autotools eutils
+
# TODO: FAIL (connection refused by '...' port 80: Connection refused)
# We can't run tests that connect with the internet.
RESTRICT="test"
@@ -15,30 +17,32 @@ SRC_URI="http://www.webdav.org/neon/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="debug expat gnutls kerberos libproxy +libxml2 pkcs11 +ssl threads"
+REQUIRED_USE="?? ( gnutls ssl )
+ ^^ ( expat libxml2 )
+ threads? ( ^^ ( gnutls ssl ) )"
-IUSE="debug gnutls kerberos libproxy ssl pkcs11 threads"
-
-REQUIRED_USE="^^ ( ssl gnutls )"
-
-neon_dep="<net-libs/neon-0.30:0/0"
-
-# First paragraph are required dependencies, second optional.
-DEPEND="
- gnutls? ( ${neon_dep}[ssl,zlib] )
- ssl? ( ${neon_dep}[ssl,zlib] )
- !gnutls? ( !ssl? ( ${neon_dep}[zlib] ) )
- || ( dev-libs/expat:0 dev-libs/libxml2:2 )
+NEON_DEP="net-libs/neon:0="
+DEPEND="${NEON_DEP}[expat?,gnutls?,kerberos?,libproxy?,pkcs11?,ssl?,zlib]
+ expat? ( dev-libs/expat:0 )
gnutls? ( net-libs/gnutls:0 )
- kerberos? ( dev-perl/GSSAPI:0 )
+ kerberos? ( app-crypt/mit-krb5:0 )
libproxy? ( net-libs/libproxy:0 )
+ libxml2? ( dev-libs/libxml2:2 )
pkcs11? ( dev-libs/pakchois:0 )
ssl? ( dev-libs/openssl:0 )"
-
RDEPEND="${DEPEND}"
DOCS=( ChangeLog FAQ NEWS README THANKS TODO )
+src_prepare() {
+ # Accept Neon 0.30.
+ epatch "${FILESDIR}/${PV}-autotools-neon-version.patch"
+
+ eautoreconf
+}
+
src_configure() {
# No EGD available in the Portage tree.
econf \
@@ -49,8 +53,10 @@ src_configure() {
$(use_enable debug) \
$(use_enable threads threadsafe-ssl posix) \
$(use_with gnutls ssl gnutls) \
+ $(use_with ssl ssl openssl) \
+ $(use_with expat) \
+ $(use_with libxml2) \
$(use_with kerberos gssapi) \
- $(use_with libproxy) \
- $(use_with ssl ssl openssl) \
- $(use_with pkcs11 pakchois)
+ $(use_with pkcs11 pakchois) \
+ $(use_with libproxy)
}
diff --git a/www-misc/litmus/metadata.xml b/www-misc/litmus/metadata.xml
index 3c773e49f319..f0b5e4cd5d70 100644
--- a/www-misc/litmus/metadata.xml
+++ b/www-misc/litmus/metadata.xml
@@ -9,6 +9,7 @@
<longdescription>WebDAV server protocol compliance test suite</longdescription>
<use>
<flag name="libproxy">Support for automatic proxy configuratino management through <pkg>net-libs/libproxy</pkg>.</flag>
+ <flag name="libxml2">Use dev-libs/libxml2 to parse XML</flag>
<flag name="pkcs11">Support for PKCS #11 through PaKChoiS (<pkg>dev-libs/pakchois</pkg>).</flag>
</use>
</pkgmetadata>