summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-10-29 18:53:30 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-10-29 18:53:30 +0000
commitbdc53e0750c66897d4fce990c0c2bce42bce858f (patch)
tree10974a3110edd3df3644988fb3f47046de4ef507 /www-misc/profile-sync-daemon
parentVersion bump (diff)
downloadgentoo-2-bdc53e0750c66897d4fce990c0c2bce42bce858f.tar.gz
gentoo-2-bdc53e0750c66897d4fce990c0c2bce42bce858f.tar.bz2
gentoo-2-bdc53e0750c66897d4fce990c0c2bce42bce858f.zip
version bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'www-misc/profile-sync-daemon')
-rw-r--r--www-misc/profile-sync-daemon/ChangeLog8
-rw-r--r--www-misc/profile-sync-daemon/profile-sync-daemon-4.02.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/www-misc/profile-sync-daemon/ChangeLog b/www-misc/profile-sync-daemon/ChangeLog
index 038902d07c9a..f13d07754045 100644
--- a/www-misc/profile-sync-daemon/ChangeLog
+++ b/www-misc/profile-sync-daemon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-misc/profile-sync-daemon
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/profile-sync-daemon/ChangeLog,v 1.4 2012/10/16 21:48:39 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/profile-sync-daemon/ChangeLog,v 1.5 2012/10/29 18:53:30 hasufell Exp $
+
+*profile-sync-daemon-4.02 (29 Oct 2012)
+
+ 29 Oct 2012; Julian Ospald <hasufell@gentoo.org>
+ +profile-sync-daemon-4.02.ebuild:
+ version bump
*profile-sync-daemon-3.16 (16 Oct 2012)
diff --git a/www-misc/profile-sync-daemon/profile-sync-daemon-4.02.ebuild b/www-misc/profile-sync-daemon/profile-sync-daemon-4.02.ebuild
new file mode 100644
index 000000000000..e570f92a7a7e
--- /dev/null
+++ b/www-misc/profile-sync-daemon/profile-sync-daemon-4.02.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/profile-sync-daemon/profile-sync-daemon-4.02.ebuild,v 1.1 2012/10/29 18:53:30 hasufell Exp $
+
+EAPI=4
+
+inherit eutils vcs-snapshot
+
+DESCRIPTION="Symlinks and syncs browser profile dirs to RAM"
+HOMEPAGE="https://wiki.archlinux.org/index.php/Profile-sync-daemon"
+SRC_URI="https://github.com/hasufell/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cron"
+
+RDEPEND="
+ app-shells/bash
+ net-misc/rsync
+ cron? ( virtual/cron )"
+
+src_install() {
+ emake DESTDIR="${D}" $(usex cron "install" "install-bin install-doc install-man")
+}
+
+pkg_postinst() {
+ eerror "IMPORTANT NOTICE!"
+ elog "Usage of the \"mozilla\" variable in the BROWSERS array is"
+ elog "deprecated starting with profile-sync-daemon v4.02."
+ elog "It has been replaced with the \"firefox\" variable."
+ elog
+ elog "In order to safely upgrade, you must run an unsync to"
+ elog "rotate your firefox profile back to disk using verion 3.x"
+ elog
+ elog "As usual, watch for any changes in the newly provided"
+ elog "/etc/conf.d/psd as well and be sure to incorporate them."
+}