summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2008-05-06 10:00:24 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2008-05-06 10:00:24 +0000
commit44084ad215596ffa3cd9691bd36c104acc743c3a (patch)
tree4708a24f91b763d1d8eba798b3235e60f0356b5e /www-misc/zoneminder
parent* 2.1.5_rc7 bump. The most notable bug fixed in this release is #172812. (diff)
downloadgentoo-2-44084ad215596ffa3cd9691bd36c104acc743c3a.tar.gz
gentoo-2-44084ad215596ffa3cd9691bd36c104acc743c3a.tar.bz2
gentoo-2-44084ad215596ffa3cd9691bd36c104acc743c3a.zip
Adding zoneminder-1.23.3 to the tree (sec issue #219694, bugs #212150 and
#216678) (Portage version: 2.1.4.4)
Diffstat (limited to 'www-misc/zoneminder')
-rw-r--r--www-misc/zoneminder/ChangeLog9
-rw-r--r--www-misc/zoneminder/files/10_zoneminder.conf18
-rw-r--r--www-misc/zoneminder/zoneminder-1.23.3.ebuild133
3 files changed, 159 insertions, 1 deletions
diff --git a/www-misc/zoneminder/ChangeLog b/www-misc/zoneminder/ChangeLog
index 12b53cd5788c..78f4fe008edc 100644
--- a/www-misc/zoneminder/ChangeLog
+++ b/www-misc/zoneminder/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-misc/zoneminder
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/zoneminder/ChangeLog,v 1.24 2008/02/23 14:39:39 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/zoneminder/ChangeLog,v 1.25 2008/05/06 10:00:23 wrobel Exp $
+
+*zoneminder-1.23.3 (06 May 2008)
+
+ 06 May 2008; wrobel@gentoo.org +files/10_zoneminder.conf,
+ +zoneminder-1.23.3.ebuild:
+ Adding zoneminder-1.23.3 to the tree (sec issue #219694, bugs #212150 and
+ #216678)
*zoneminder-1.23.1 (23 Feb 2008)
diff --git a/www-misc/zoneminder/files/10_zoneminder.conf b/www-misc/zoneminder/files/10_zoneminder.conf
new file mode 100644
index 000000000000..0ddb6755877f
--- /dev/null
+++ b/www-misc/zoneminder/files/10_zoneminder.conf
@@ -0,0 +1,18 @@
+ScriptAlias /cgi-bin/zms "/var/www/zoneminder/cgi-bin/zms"
+ScriptAlias /cgi-bin/nph-zms "/var/www/zoneminder/cgi-bin/nph-zms"
+
+<Directory "/var/www/zoneminder/cgi-bin">
+ AllowOverride All
+ Options ExecCGI
+ Order allow,deny
+ Allow from all
+</Directory>
+
+Alias /zoneminder "/var/www/zoneminder/htdocs"
+
+<Directory "/var/www/zoneminder/htdocs">
+ Options -Indexes MultiViews FollowSymLinks
+ AllowOverride All
+ Order allow,deny
+ Allow from all
+</Directory>
diff --git a/www-misc/zoneminder/zoneminder-1.23.3.ebuild b/www-misc/zoneminder/zoneminder-1.23.3.ebuild
new file mode 100644
index 000000000000..36af2ca21924
--- /dev/null
+++ b/www-misc/zoneminder/zoneminder-1.23.3.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/zoneminder/zoneminder-1.23.3.ebuild,v 1.1 2008/05/06 10:00:23 wrobel Exp $
+
+inherit eutils autotools depend.php depend.apache multilib
+
+MY_PV=${PV/_/-}
+MY_PN="ZoneMinder"
+
+PATCH_PV="1.23.1"
+
+DESCRIPTION="ZoneMinder allows you to capture, analyse, record and monitor any cameras attached to your system."
+HOMEPAGE="http://www.zoneminder.com/"
+SRC_URI="http://www.zoneminder.com/downloads/${MY_PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug ffmpeg X10"
+SLOT="0"
+
+DEPEND="app-admin/sudo
+ dev-libs/libpcre
+ >=media-libs/jpeg-6b
+ net-libs/gnutls
+ >=dev-lang/perl-5.6.0
+ dev-perl/Archive-Tar
+ dev-perl/Archive-Zip
+ dev-perl/DateManip
+ dev-perl/DBD-mysql
+ dev-perl/DBI
+ dev-perl/Device-SerialPort
+ dev-perl/libwww-perl
+ dev-perl/MIME-Lite
+ dev-perl/MIME-tools
+ dev-perl/PHP-Serialization
+ virtual/perl-Getopt-Long
+ virtual/perl-libnet
+ virtual/perl-Sys-Syslog
+ virtual/perl-Time-HiRes
+ X10? ( dev-perl/X10 )"
+
+RDEPEND="dev-perl/DBD-mysql
+ ffmpeg? ( media-video/ffmpeg )
+ media-libs/netpbm"
+
+# we cannot use need_httpd_cgi here, since we need to setup permissions for the
+# webserver in global scope (/etc/zm.conf etc), so we hardcode apache here.
+need_apache
+need_php_httpd
+
+S="${WORKDIR}"/${MY_PN}-${MY_PV}
+
+pkg_setup() {
+ require_php_with_use mysql
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PATCH_PV}/Makefile.am.patch
+ epatch "${FILESDIR}"/${PATCH_PV}/zm_create.sql.in.patch
+ epatch "${FILESDIR}"/${PATCH_PV}/zm_mpeg_ofc.patch
+ epatch "${FILESDIR}"/${PATCH_PV}/zm_remote_camera.patch
+
+ eautoreconf
+}
+
+src_compile() {
+ econf --with-libarch=$(get_libdir) \
+ --with-mysql=/usr \
+ $(use_with ffmpeg ffmpeg /usr) \
+ $(use_enable debug) \
+ $(use_enable debug crashtrace) \
+ --with-webdir="${ROOT}/var/www/zoneminder/htdocs" \
+ --with-cgidir="${ROOT}/var/www/zoneminder/cgi-bin" \
+ --with-webuser=apache \
+ --with-webgroup=apache \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+
+ keepdir /var/run/zm
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ fperms 0644 /etc/zm.conf
+
+ keepdir /var/log/${PN}
+ fowners apache:apache /var/log/${PN}
+ fowners apache:apache /var/run/zm
+
+ newinitd "${FILESDIR}"/init.d zoneminder
+ newconfd "${FILESDIR}"/conf.d zoneminder
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+
+ insinto /usr/share/${PN}/db
+ doins db/zm_u* db/zm_create.sql
+
+ insinto /etc/apache2/vhosts.d
+ doins "${FILESDIR}"/10_zoneminder.conf
+
+ for DIR in events images sound; do
+ dodir "${ROOT}"/var/www/zoneminder/htdocs/${DIR}
+ done
+
+}
+
+pkg_postinst() {
+ elog ""
+ elog "0. If this is a new installation, you will need to create a MySQL database"
+ elog " for ${PN} to use. (see http://www.gentoo.org/doc/en/mysql-howto.xml)."
+ elog " Once you completed that you should execute the following:"
+ elog ""
+ elog " cd /usr/share/${PN}"
+ elog " mysql -u <my_database_user> -p<my_database_pass> <my_zoneminder_db> < db/zm_create.sql"
+ elog ""
+ elog "1. Set your database settings in /etc/zm.conf"
+ elog ""
+ elog "2. Start the ${PN} daemon:"
+ elog ""
+ elog " /etc/init.d/${PN} start"
+ elog ""
+ elog "3. Finally point your browser to http://localhos/${PN}"
+ elog ""
+ elog ""
+ elog "If you are upgrading, you will need to run the zmupdate.pl script:"
+ elog ""
+ elog " /usr/bin/zmupdate.pl version=<from version> [--user=<my_database_user> --pass=<my_database_pass>]"
+ elog ""
+}