summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-05-27 08:33:52 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-05-27 08:33:52 +0000
commit19bad49167d59e612f4f64424515e2791a04d6ca (patch)
tree3e5a1ccb627354b71b72b938ec63d7cfd1d93f98 /www-misc
parentDeclare dependencies with SLOTs to avoid java-pkg_ensure-dep warning. (diff)
downloadgentoo-2-19bad49167d59e612f4f64424515e2791a04d6ca.tar.gz
gentoo-2-19bad49167d59e612f4f64424515e2791a04d6ca.tar.bz2
gentoo-2-19bad49167d59e612f4f64424515e2791a04d6ca.zip
Version bump.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 93491BB8)
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/urlwatch/ChangeLog7
-rw-r--r--www-misc/urlwatch/urlwatch-1.18.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/www-misc/urlwatch/ChangeLog b/www-misc/urlwatch/ChangeLog
index ea52883ce023..fdbca9bef55d 100644
--- a/www-misc/urlwatch/ChangeLog
+++ b/www-misc/urlwatch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-misc/urlwatch
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/urlwatch/ChangeLog,v 1.10 2015/05/20 08:01:29 monsieurp Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/urlwatch/ChangeLog,v 1.11 2015/05/27 08:33:52 monsieurp Exp $
+
+*urlwatch-1.18 (27 May 2015)
+
+ 27 May 2015; Patrice Clement <monsieurp@gentoo.org> +urlwatch-1.18.ebuild:
+ Version bump.
20 May 2015; Patrice Clement <monsieurp@gentoo.org> metadata.xml:
Add myself to the maintainers list.
diff --git a/www-misc/urlwatch/urlwatch-1.18.ebuild b/www-misc/urlwatch/urlwatch-1.18.ebuild
new file mode 100644
index 000000000000..44fb899ff8dc
--- /dev/null
+++ b/www-misc/urlwatch/urlwatch-1.18.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/urlwatch/urlwatch-1.18.ebuild,v 1.1 2015/05/27 08:33:52 monsieurp Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool for monitoring webpages for updates"
+HOMEPAGE="http://thp.io/2008/urlwatch/ http://pypi.python.org/pypi/urlwatch"
+SRC_URI="http://thp.io/2008/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/python-futures[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ || ( www-client/lynx app-text/html2text )"
+
+python_prepare() {
+ if [[ ${EPYTHON} == python3.* ]]; then
+ 2to3 -nw --no-diffs urlwatch lib/urlwatch/*.py \
+ share/urlwatch/examples/hooks.py.example setup.py || die
+ fi
+}