summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2011-02-11 13:44:45 +0000
committerJim Ramsay <lack@gentoo.org>2011-02-11 13:44:45 +0000
commit713934daa0fa25a28ab488f078d995e41b90b58c (patch)
tree21b0194e22b74a0ced3ce9fb09e5b74888230e79 /www-plugins/adobe-flash
parentdrop redudant middle version (diff)
downloadgentoo-2-713934daa0fa25a28ab488f078d995e41b90b58c.tar.gz
gentoo-2-713934daa0fa25a28ab488f078d995e41b90b58c.tar.bz2
gentoo-2-713934daa0fa25a28ab488f078d995e41b90b58c.zip
Fixed 32-bit install which I horribly broke
(Portage version: 2.1.9.34/cvs/Linux i686)
Diffstat (limited to 'www-plugins/adobe-flash')
-rw-r--r--www-plugins/adobe-flash/ChangeLog6
-rw-r--r--www-plugins/adobe-flash/adobe-flash-10.2.152.27_p201011173.ebuild28
2 files changed, 16 insertions, 18 deletions
diff --git a/www-plugins/adobe-flash/ChangeLog b/www-plugins/adobe-flash/ChangeLog
index 697286843cfd..d212d252172c 100644
--- a/www-plugins/adobe-flash/ChangeLog
+++ b/www-plugins/adobe-flash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-plugins/adobe-flash
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/ChangeLog,v 1.60 2011/02/10 21:07:04 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/ChangeLog,v 1.61 2011/02/11 13:44:45 lack Exp $
+
+ 11 Feb 2011; Jim Ramsay <lack@gentoo.org>
+ adobe-flash-10.2.152.27_p201011173.ebuild:
+ Fixed 32-bit install which I horribly broke
*adobe-flash-10.2.152.27_p201011173 (10 Feb 2011)
*adobe-flash-10.2.152.27 (10 Feb 2011)
diff --git a/www-plugins/adobe-flash/adobe-flash-10.2.152.27_p201011173.ebuild b/www-plugins/adobe-flash/adobe-flash-10.2.152.27_p201011173.ebuild
index 7f2c273b6a56..6f5c86c00a13 100644
--- a/www-plugins/adobe-flash/adobe-flash-10.2.152.27_p201011173.ebuild
+++ b/www-plugins/adobe-flash/adobe-flash-10.2.152.27_p201011173.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/adobe-flash-10.2.152.27_p201011173.ebuild,v 1.1 2011/02/10 21:07:04 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/adobe-flash/adobe-flash-10.2.152.27_p201011173.ebuild,v 1.2 2011/02/11 13:44:45 lack Exp $
EAPI=3
-inherit nsplugins multilib toolchain-funcs versionator
+inherit rpm nsplugins multilib toolchain-funcs versionator
# Note: There is no "square" for 32-bit! Just use the current 32-bit release:
PV_REL=$(get_version_component_range 1-4)
@@ -115,20 +115,6 @@ pkg_setup() {
fi
}
-src_unpack() {
- # In this pre-release version, both tarballs have just 'libflashplayer.so'
- # and no prefix directory, so put the 32-bit one somewhere else.
- if [[ $amd64_32bit ]]; then
- mkdir 32bit
- pushd "${S}/32bit"
- unpack $(basename $MY_32B_URI)
- popd
- unpack $(basename $MY_64B_URI)
- else
- default_src_unpack
- fi
-}
-
src_compile() {
if [[ $need_lahf_wrapper ]]; then
# This experimental wrapper, from Maks Verver via bug #268336 should
@@ -141,9 +127,17 @@ src_compile() {
src_install() {
if [[ $native_install ]]; then
+ # 32b RPM has things hidden in funny places
+ use x86 && pushd "${S}/usr/lib/flash-plugin"
+
exeinto /${INSTALL_BASE}
doexe libflashplayer.so
inst_plugin /${INSTALL_BASE}/libflashplayer.so
+
+ use x86 && popd
+
+ # 64b tarball has no readme file.
+ use x86 && dodoc "${S}/usr/share/doc/flash-plugin-${PV_REL}/readme.txt"
fi
if [[ $need_lahf_wrapper ]]; then
@@ -159,7 +153,7 @@ src_install() {
ABI="x86"
# 32b plugin
- pushd "${S}/32bit"
+ pushd "${S}/usr/lib/flash-plugin"
exeinto /${INSTALL_BASE}32
doexe libflashplayer.so
inst_plugin /${INSTALL_BASE}32/libflashplayer.so