summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-12-15 16:14:58 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-12-15 16:14:58 +0000
commit0872067d81312fcb045af320a1ce8bedd137e8cc (patch)
tree93798b54f1e24708b7910f3a57a4daa2f7321417 /www-plugins/lightspark
parentVersion bump, drop old (diff)
downloadgentoo-2-0872067d81312fcb045af320a1ce8bedd137e8cc.tar.gz
gentoo-2-0872067d81312fcb045af320a1ce8bedd137e8cc.tar.bz2
gentoo-2-0872067d81312fcb045af320a1ce8bedd137e8cc.zip
error out on unsupported gcc version wrt #441564
(Portage version: 2.2.0_alpha145/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'www-plugins/lightspark')
-rw-r--r--www-plugins/lightspark/ChangeLog5
-rw-r--r--www-plugins/lightspark/lightspark-0.7.0.ebuild14
2 files changed, 16 insertions, 3 deletions
diff --git a/www-plugins/lightspark/ChangeLog b/www-plugins/lightspark/ChangeLog
index 02cb8402e3ac..8a2273e81734 100644
--- a/www-plugins/lightspark/ChangeLog
+++ b/www-plugins/lightspark/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for www-plugins/lightspark
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.48 2012/12/04 21:57:10 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.49 2012/12/15 16:14:58 hasufell Exp $
+
+ 15 Dec 2012; Julian Ospald <hasufell@gentoo.org> lightspark-0.7.0.ebuild:
+ error out on unsupported gcc version wrt #441564
04 Dec 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+files/lightspark-0.6.0.1-gcc-4.5_0001.patch:
diff --git a/www-plugins/lightspark/lightspark-0.7.0.ebuild b/www-plugins/lightspark/lightspark-0.7.0.ebuild
index 0e0f00b76ad7..07260fa8c26e 100644
--- a/www-plugins/lightspark/lightspark-0.7.0.ebuild
+++ b/www-plugins/lightspark/lightspark-0.7.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.7.0.ebuild,v 1.2 2012/11/18 13:43:34 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.7.0.ebuild,v 1.3 2012/12/15 16:14:58 hasufell Exp $
EAPI=4
-inherit cmake-utils nsplugins multilib
+inherit cmake-utils nsplugins multilib toolchain-funcs
DESCRIPTION="High performance flash player"
HOMEPAGE="http://lightspark.sourceforge.net/"
@@ -20,6 +20,7 @@ RDEPEND=">=dev-cpp/libxmlpp-2.33.1:2.6
media-fonts/liberation-fonts
media-libs/libpng
media-libs/libsdl
+ >=sys-devel/gcc-4.6.0[cxx]
>=sys-devel/llvm-3
x11-libs/cairo
x11-libs/gtk+:2
@@ -56,6 +57,15 @@ PATCHES=(
"${FILESDIR}"/${P}-libxmlpp-gles.patch
)
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if [[ $(gcc-major-version) == 4 && $(gcc-minor-version) -lt 6 || $(gcc-major-version) -lt 4 ]] ; then
+ eerror "You need at least sys-devel/gcc-4.6.0"
+ die "You need at least sys-devel/gcc-4.6.0"
+ fi
+ fi
+}
+
src_configure() {
local audiobackends
use pulseaudio && audiobackends+="pulse"