summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-05-20 05:21:50 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-05-20 05:21:50 +0000
commit43634211c2a3424cfe95039cda8b4528f1927c07 (patch)
treec4265fa097b508c3be156fc2a897b9bbb46c53fe /www-plugins/lightspark
parentVersion bump, bug #320547 (diff)
downloadgentoo-2-43634211c2a3424cfe95039cda8b4528f1927c07.tar.gz
gentoo-2-43634211c2a3424cfe95039cda8b4528f1927c07.tar.bz2
gentoo-2-43634211c2a3424cfe95039cda8b4528f1927c07.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins/lightspark')
-rw-r--r--www-plugins/lightspark/ChangeLog8
-rw-r--r--www-plugins/lightspark/lightspark-0.3.5.ebuild (renamed from www-plugins/lightspark/lightspark-0.3.3-r1.ebuild)13
2 files changed, 12 insertions, 9 deletions
diff --git a/www-plugins/lightspark/ChangeLog b/www-plugins/lightspark/ChangeLog
index d6e7159b31ea..370d226dcc74 100644
--- a/www-plugins/lightspark/ChangeLog
+++ b/www-plugins/lightspark/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-plugins/lightspark
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.2 2010/05/19 21:42:18 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.3 2010/05/20 05:21:50 chithanh Exp $
+
+*lightspark-0.3.5 (20 May 2010)
+
+ 20 May 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ -lightspark-0.3.3-r1.ebuild, +lightspark-0.3.5.ebuild:
+ Version bump.
*lightspark-0.3.3-r1 (19 May 2010)
diff --git a/www-plugins/lightspark/lightspark-0.3.3-r1.ebuild b/www-plugins/lightspark/lightspark-0.3.5.ebuild
index 3c2d518a8033..d8ef218edc0c 100644
--- a/www-plugins/lightspark/lightspark-0.3.3-r1.ebuild
+++ b/www-plugins/lightspark/lightspark-0.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.3.3-r1.ebuild,v 1.1 2010/05/19 21:42:18 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.3.5.ebuild,v 1.1 2010/05/20 05:21:50 chithanh Exp $
EAPI=3
inherit cmake-utils nsplugins multilib
@@ -35,18 +35,15 @@ DEPEND="${RDEPEND}
src_prepare() {
# TODO: have to think of a less ugly solution
- epatch "${FILESDIR}"/${P}-llvm-datatypes.patch
+ epatch "${FILESDIR}"/${PN}-0.3.3-llvm-datatypes.patch
- # Adjust plugin directory
- sed -i "s|/usr/lib/mozilla/|/usr/$(get_libdir)/${PN}/|" plugin-dir/CMakeLists.txt || die
-
- # Adjust executable and plugin permissions
- sed -i 's|FILES ${CMAKE_CURRENT_BINARY_DIR}|PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}|' CMakeLists.txt || die
+ # Adjust plugin permissions
sed -i 's|FILES|PROGRAMS|' plugin-dir/CMakeLists.txt || die
}
src_configure() {
- local mycmakeargs="$(cmake-utils_use nsplugin COMPILE_PLUGIN)"
+ local mycmakeargs="$(cmake-utils_use nsplugin COMPILE_PLUGIN)
+ -DPLUGIN_DIRECTORY=/usr/$(get_libdir)/${PN}/plugins"
cmake-utils_src_configure
}