summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-06-07 13:17:29 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-06-07 13:17:29 +0000
commit4848677e53f1202922ce26482c67e275ee38ad7d (patch)
treea3ec15d50fe8b4dd478323f9d0c01804264514ab /www-plugins
parentRemove old. (diff)
downloadgentoo-2-4848677e53f1202922ce26482c67e275ee38ad7d.tar.gz
gentoo-2-4848677e53f1202922ce26482c67e275ee38ad7d.tar.bz2
gentoo-2-4848677e53f1202922ce26482c67e275ee38ad7d.zip
Version bump. Drop old buildfix, add different one.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/lightspark/ChangeLog9
-rw-r--r--www-plugins/lightspark/files/lightspark-0.3.3-llvm-datatypes.patch17
-rw-r--r--www-plugins/lightspark/files/lightspark-0.4.1-debug-defines.patch14
-rw-r--r--www-plugins/lightspark/lightspark-0.4.1.ebuild (renamed from www-plugins/lightspark/lightspark-0.3.9.ebuild)6
4 files changed, 25 insertions, 21 deletions
diff --git a/www-plugins/lightspark/ChangeLog b/www-plugins/lightspark/ChangeLog
index 24c980aa3fc9..13538217d03d 100644
--- a/www-plugins/lightspark/ChangeLog
+++ b/www-plugins/lightspark/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-plugins/lightspark
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.5 2010/05/25 09:04:14 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.6 2010/06/07 13:17:29 chithanh Exp $
+
+*lightspark-0.4.1 (07 Jun 2010)
+
+ 07 Jun 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ -files/lightspark-0.3.3-llvm-datatypes.patch, -lightspark-0.3.9.ebuild,
+ +lightspark-0.4.1.ebuild, +files/lightspark-0.4.1-debug-defines.patch:
+ Version bump. Drop old buildfix, add different one.
*lightspark-0.3.9 (25 May 2010)
diff --git a/www-plugins/lightspark/files/lightspark-0.3.3-llvm-datatypes.patch b/www-plugins/lightspark/files/lightspark-0.3.3-llvm-datatypes.patch
deleted file mode 100644
index 2bf56f29f64c..000000000000
--- a/www-plugins/lightspark/files/lightspark-0.3.3-llvm-datatypes.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff -ur a/abc.h b/abc.h
---- a/abc.h 2010-05-19 05:32:38.000000000 +0200
-+++ b/abc.h 2010-05-19 15:30:13.000000000 +0200
-@@ -20,6 +20,13 @@
- #ifndef _SWF_H
- #define _SWF_H
-
-+#ifndef INT64_C
-+# define INT64_C(C) ((int64_t) C ## LL)
-+#endif
-+#ifndef UINT64_C
-+# define UINT64_C(C) ((uint64_t) C ## ULL)
-+#endif
-+
- #include "compat.h"
- #include <llvm/Module.h>
- #include <llvm/ExecutionEngine/ExecutionEngine.h>
diff --git a/www-plugins/lightspark/files/lightspark-0.4.1-debug-defines.patch b/www-plugins/lightspark/files/lightspark-0.4.1-debug-defines.patch
new file mode 100644
index 000000000000..61e5692e72bf
--- /dev/null
+++ b/www-plugins/lightspark/files/lightspark-0.4.1-debug-defines.patch
@@ -0,0 +1,14 @@
+diff -ur a/swftypes.h b/swftypes.h
+--- a/swftypes.h 2010-06-05 03:14:06.000000000 +0200
++++ b/swftypes.h 2010-06-07 15:06:33.013468239 +0200
+@@ -471,9 +471,9 @@
+ public:
+ #ifndef NDEBUG
+ //Stuff onyl used in debugging
+- bool initialized;
+ int getRefCount(){ return ref_count; }
+ #endif
++ bool initialized;
+ bool implEnable;
+ void setPrototype(Class_base* c);
+ Class_base* getPrototype() const { return prototype; }
diff --git a/www-plugins/lightspark/lightspark-0.3.9.ebuild b/www-plugins/lightspark/lightspark-0.4.1.ebuild
index 6be2f6b9950b..9f7afa2f819d 100644
--- a/www-plugins/lightspark/lightspark-0.3.9.ebuild
+++ b/www-plugins/lightspark/lightspark-0.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.3.9.ebuild,v 1.1 2010/05/25 09:04:14 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.4.1.ebuild,v 1.1 2010/06/07 13:17:29 chithanh Exp $
EAPI=3
inherit cmake-utils nsplugins multilib
@@ -35,8 +35,8 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_prepare() {
- # TODO: have to think of a less ugly solution
- epatch "${FILESDIR}"/${PN}-0.3.3-llvm-datatypes.patch
+ # Fix gcc complaint about undefined debug variable
+ epatch "${FILESDIR}"/${PN}-0.4.1-debug-defines.patch
# Adjust plugin permissions
sed -i "s|FILES|PROGRAMS|" plugin-dir/CMakeLists.txt || die