summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-12-12 16:09:37 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-12-12 16:09:37 +0000
commit772e3430229cb4a8d8df9498747eae633e114fa2 (patch)
tree64b41bf4ec890f2df93e095e518831e61481e579 /www-plugins
parentProvide correct init.d script. (diff)
downloadgentoo-2-772e3430229cb4a8d8df9498747eae633e114fa2.tar.gz
gentoo-2-772e3430229cb4a8d8df9498747eae633e114fa2.tar.bz2
gentoo-2-772e3430229cb4a8d8df9498747eae633e114fa2.zip
Version bump, bug #346841. Now builds against llvm-2.8, bug #340437.
(Portage version: 2.2.0_alpha7/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/lightspark/ChangeLog9
-rw-r--r--www-plugins/lightspark/files/lightspark-0.4.5-allow-disabling-pulseaudio.patch22
-rw-r--r--www-plugins/lightspark/lightspark-0.4.5.ebuild (renamed from www-plugins/lightspark/lightspark-0.4.4.3.ebuild)7
3 files changed, 33 insertions, 5 deletions
diff --git a/www-plugins/lightspark/ChangeLog b/www-plugins/lightspark/ChangeLog
index e75c3f6beecf..0b42bd0febba 100644
--- a/www-plugins/lightspark/ChangeLog
+++ b/www-plugins/lightspark/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-plugins/lightspark
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.19 2010/10/18 16:20:16 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.20 2010/12/12 16:09:37 chithanh Exp $
+
+*lightspark-0.4.5 (12 Dec 2010)
+
+ 12 Dec 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ -lightspark-0.4.4.3.ebuild, +lightspark-0.4.5.ebuild,
+ +files/lightspark-0.4.5-allow-disabling-pulseaudio.patch:
+ Version bump, bug #346841. Now builds against llvm-2.8, bug #340437.
*lightspark-0.4.4.3 (18 Oct 2010)
diff --git a/www-plugins/lightspark/files/lightspark-0.4.5-allow-disabling-pulseaudio.patch b/www-plugins/lightspark/files/lightspark-0.4.5-allow-disabling-pulseaudio.patch
new file mode 100644
index 000000000000..f09e3552293e
--- /dev/null
+++ b/www-plugins/lightspark/files/lightspark-0.4.5-allow-disabling-pulseaudio.patch
@@ -0,0 +1,22 @@
+diff -ur a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2010-12-08 17:55:46.000000000 +0100
++++ b/CMakeLists.txt 2010-12-12 16:46:50.496000030 +0100
+@@ -108,6 +108,7 @@
+ SET(COMPILE_LIGHTSPARK TRUE CACHE BOOL "Compile Lightspark?")
+ SET(COMPILE_TIGHTSPARK TRUE CACHE BOOL "Compile Tightspark?")
+ SET(COMPILE_PLUGIN FALSE CACHE BOOL "Compile the browser plugin?")
++SET(AUDIO_BACKEND "pulse" CACHE STRING "Choose audio backend: none pulse alsa, default is pulse")
+ SET(ENABLE_CURL TRUE CACHE BOOL "Enable CURL? (Required for Downloader functionality)")
+ SET(ENABLE_LIBAVCODEC TRUE CACHE BOOL "Enable libavcodec and dependent functionality?")
+ SET(PLUGIN_DIRECTORY "${LIBDIR}/mozilla/plugins" CACHE STRING "Directory to install Firefox plugin to")
+@@ -371,7 +372,9 @@
+ GETTEXT_CREATE_TRANSLATIONS(i18n/lightspark.pot ALL i18n/pl.po i18n/fr.po
+ i18n/zh_CN.po)
+
+-ADD_SUBDIRECTORY(backends/interfaces/audio/pulse)
++IF(${AUDIO_BACKEND} MATCHES "pulse")
++ ADD_SUBDIRECTORY(backends/interfaces/audio/pulse)
++ENDIF(${AUDIO_BACKEND} MATCHES "pulse")
+ #ADD_SUBDIRECTORY(backends/interfaces/audio/alsa)
+ #ADD_SUBDIRECTORY(backends/interfaces/audio/openal)
+
diff --git a/www-plugins/lightspark/lightspark-0.4.4.3.ebuild b/www-plugins/lightspark/lightspark-0.4.5.ebuild
index 8ea241f7537c..3fd1c2e0b621 100644
--- a/www-plugins/lightspark/lightspark-0.4.4.3.ebuild
+++ b/www-plugins/lightspark/lightspark-0.4.5.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.4.4.3.ebuild,v 1.1 2010/10/18 16:20:16 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.4.5.ebuild,v 1.1 2010/12/12 16:09:36 chithanh Exp $
EAPI=3
inherit cmake-utils nsplugins multilib
DESCRIPTION="High performance flash player"
HOMEPAGE="https://launchpad.net/lightspark/"
-SRC_URI="http://launchpad.net/${PN}/trunk/${PN}-0.4.4/+download/${P}.tar.gz"
+SRC_URI="http://launchpad.net/${PN}/trunk/${P}/+download/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
@@ -36,9 +36,7 @@ RDEPEND="dev-cpp/libxmlpp:2.6
x11-libs/gtkglext
)
x11-libs/libX11"
-# Require sys-devel/llvm-2.7 during build, bug #340437
DEPEND="${RDEPEND}
- =sys-devel/llvm-2.7*
dev-lang/nasm
dev-util/pkgconfig"
@@ -46,6 +44,7 @@ S=${WORKDIR}/${P/_rc*/}
PATCHES=(
"${FILESDIR}"/${PN}-0.4.4.3-cmakelists.patch
+ "${FILESDIR}"/${PN}-0.4.5-allow-disabling-pulseaudio.patch
)
src_configure() {