summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-09-10 19:22:21 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-09-10 19:22:21 +0000
commitbaa6230ad28f96d534ef71bef7009b59d7c62ed4 (patch)
tree5d2b44d796467d153b0e2e15ef93e5818131dd8b /www-plugins
parentRemove 0.9.15-r51: the -r51 is for OpenRC, while -r2 is a stable target. If y... (diff)
downloadgentoo-2-baa6230ad28f96d534ef71bef7009b59d7c62ed4.tar.gz
gentoo-2-baa6230ad28f96d534ef71bef7009b59d7c62ed4.tar.bz2
gentoo-2-baa6230ad28f96d534ef71bef7009b59d7c62ed4.zip
Fix bug #284342, sdl was added into $gui local var from src_configure() even with USE=-sdl gtk -kde, which also introduiced a syntax error caused by the sed expression (which drops the first matched comma).
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/gnash/ChangeLog8
-rw-r--r--www-plugins/gnash/gnash-0.8.5.ebuild8
2 files changed, 13 insertions, 3 deletions
diff --git a/www-plugins/gnash/ChangeLog b/www-plugins/gnash/ChangeLog
index 8b416b8e08e4..3a30c824fb40 100644
--- a/www-plugins/gnash/ChangeLog
+++ b/www-plugins/gnash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-plugins/gnash
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.10 2009/09/10 17:12:23 mrpouet Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.11 2009/09/10 19:22:21 mrpouet Exp $
+
+ 10 Sep 2009; Romain Perier <mrpouet@gentoo.org>
+ gnash-0.8.5.ebuild:
+ Fix bug #284342, sdl was added into $gui local var from src_configure()
+ even with USE=-sdl gtk -kde, which also introduiced a syntax error caused
+ by the sed expression (which drops the first matched comma).
10 Sep 2009; Romain Perier <mrpouet@gentoo.org>
gnash-0.8.5.ebuild:
diff --git a/www-plugins/gnash/gnash-0.8.5.ebuild b/www-plugins/gnash/gnash-0.8.5.ebuild
index b76e03c7bd22..ea330b3bd02d 100644
--- a/www-plugins/gnash/gnash-0.8.5.ebuild
+++ b/www-plugins/gnash/gnash-0.8.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.5.ebuild,v 1.6 2009/09/10 17:12:23 mrpouet Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.5.ebuild,v 1.7 2009/09/10 19:22:21 mrpouet Exp $
EAPI="2"
KDE_REQUIRED="optional"
@@ -124,7 +124,7 @@ src_prepare() {
}
src_configure() {
local myconf
- local gui="sdl"
+ local gui
# Set nsplugin install directory.
use nsplugin && myconf="${myconf} --with-npapi-plugindir=/opt/netscape/plugins"
# Set kde and konqueror plugin directories.
@@ -157,6 +157,10 @@ src_configure() {
use gtk && gui=",gtk"
use kde && gui="${gui},kde4"
use sdl && gui="${gui},sdl"
+
+ if [ -z "$gui" ]; then
+ gui="sdl"
+ fi
# Strip extra comma from gui.
gui=$( echo $gui|sed -e 's/,//' )
econf \