summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-08-08 11:09:49 +0000
committerStuart Herbert <stuart@gentoo.org>2004-08-08 11:09:49 +0000
commitf6104ae625b8fa7a1772dc4fc82690713a0ee578 (patch)
tree0fac3ffd496ef5bc69f74d99ac574081cfc0ca49 /www-servers/boa/boa-0.94.13-r1.ebuild
parentAdded fix for CAN-2004-0415 (Manifest recommit) (diff)
downloadgentoo-2-f6104ae625b8fa7a1772dc4fc82690713a0ee578.tar.gz
gentoo-2-f6104ae625b8fa7a1772dc4fc82690713a0ee578.tar.bz2
gentoo-2-f6104ae625b8fa7a1772dc4fc82690713a0ee578.zip
Moved from net-www/boa to www-servers/boa.
Diffstat (limited to 'www-servers/boa/boa-0.94.13-r1.ebuild')
-rw-r--r--www-servers/boa/boa-0.94.13-r1.ebuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/www-servers/boa/boa-0.94.13-r1.ebuild b/www-servers/boa/boa-0.94.13-r1.ebuild
new file mode 100644
index 000000000000..aeb32fb40970
--- /dev/null
+++ b/www-servers/boa/boa-0.94.13-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/boa/boa-0.94.13-r1.ebuild,v 1.1 2004/08/08 11:09:49 stuart Exp $
+
+inherit eutils
+
+DESCRIPTION="Boa - A very small and very fast http daemon"
+SRC_URI="http://www.boa.org/${P}.tar.gz"
+HOMEPAGE="http://www.boa.org/"
+
+KEYWORDS="~x86 ~sparc ~mips ~ppc"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="tetex"
+
+DEPEND="virtual/libc
+ sys-devel/flex
+ sys-devel/bison
+ sys-apps/texinfo
+ tetex? ( virtual/tetex )"
+
+RDEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc3.patch || die
+}
+
+src_compile() {
+ cd src
+ econf || die "econf failed"
+ emake || die
+ cd ../docs
+ make boa.html boa.info || die
+
+ # SLH - 2004/04/23
+ # commented out - this doesn't appear to work, and I'm not tetex
+ # expert, so I don't know how to fix it
+ #
+ # use tetex && make boa.dvi
+}
+
+src_install() {
+ # make prefix=${D}/usr install
+ dosbin src/boa || die
+ doman docs/boa.8 || die
+ dodoc docs/boa.html || die
+ dodoc docs/boa_banner.png || die
+ doinfo docs/boa.info || die
+# if use tetex; then
+# dodoc docs/boa.dvi || die
+# fi
+
+ dodir /var/log/boa || die
+ dodir /var/www/localhost/htdocs || die
+ dodir /var/www/localhost/cgi-bin || die
+ dodir /var/www/localhost/icons || die
+
+ insinto /etc/conf.d
+ doins ${FILESDIR}/boa.conf.d
+
+ exeinto /usr/lib/boa
+ doexe src/boa_indexer || die
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/boa.rc6 boa || die
+
+ insinto /etc/boa
+ insopts -m700
+ insopts -m600
+ doins ${FILESDIR}/boa.conf || die
+ doins ${FILESDIR}/mime.types || die
+
+ # make DESTDIR=${D} install || die
+}
+
+pkg_prerm() {
+ if [ "$ROOT" = "/" ] && [ -e /dev/shm/.init.d/started/boa ] ; then
+ /etc/init.d/boa stop
+ fi
+ return # dont fail
+}
+
+pkg_preinst() {
+ if [ "$ROOT" = "/" ] && [ -e /dev/shm/.init.d/started/boa ] ; then
+ /etc/init.d/boa stop
+ fi
+ return # dont fail
+}