summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-08-29 17:21:40 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-08-29 17:21:40 +0000
commit46090a1638c14e5170fce955d2859660176eba6c (patch)
tree06a2adf99e7e8a9fda8ced69afdd479ce12af6b7 /www-servers/lighttpd
parentStable on sparc (diff)
downloadgentoo-2-46090a1638c14e5170fce955d2859660176eba6c.tar.gz
gentoo-2-46090a1638c14e5170fce955d2859660176eba6c.tar.bz2
gentoo-2-46090a1638c14e5170fce955d2859660176eba6c.zip
Add sedfu to fix an errant /tmp path I forgot to patch in tests/lighttpd.conf.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'www-servers/lighttpd')
-rw-r--r--www-servers/lighttpd/ChangeLog5
-rw-r--r--www-servers/lighttpd/Manifest14
-rw-r--r--www-servers/lighttpd/lighttpd-1.4.2.ebuild6
3 files changed, 11 insertions, 14 deletions
diff --git a/www-servers/lighttpd/ChangeLog b/www-servers/lighttpd/ChangeLog
index 6237d354161e..5b95d7f5c2ae 100644
--- a/www-servers/lighttpd/ChangeLog
+++ b/www-servers/lighttpd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for www-servers/lighttpd
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/lighttpd/ChangeLog,v 1.38 2005/08/29 15:51:18 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/lighttpd/ChangeLog,v 1.39 2005/08/29 17:21:40 ka0ttic Exp $
+
+ 29 Aug 2005; Aaron Walker <ka0ttic@gentoo.org> lighttpd-1.4.2.ebuild:
+ Add sedfu to fix an errant /tmp path I forgot to patch in tests/lighttpd.conf.
*lighttpd-1.4.2 (29 Aug 2005)
diff --git a/www-servers/lighttpd/Manifest b/www-servers/lighttpd/Manifest
index a54a3eb73ae2..c4fc67d5ef94 100644
--- a/www-servers/lighttpd/Manifest
+++ b/www-servers/lighttpd/Manifest
@@ -1,11 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 6c23268afc8a8db6cc2fba589ca10d8e lighttpd-1.4.1-r1.ebuild 4166
-MD5 30bd0994e4675f232aaa78d11062c029 lighttpd-1.4.2.ebuild 5103
+MD5 6f7270f12cfedfdba2aa8b56b453762e lighttpd-1.4.2.ebuild 5252
MD5 81af13d45943a9638f0d7de071256bf8 lighttpd-1.3.16.ebuild 2549
MD5 49ded22216ffc6092d1a1e04a6e420c1 lighttpd-1.3.13-r3.ebuild 2607
-MD5 7ecfeb0e1caaada05270c5e2035dde68 ChangeLog 12021
+MD5 82aed091ca1841c1ff7f126d00aaf6af ChangeLog 12175
MD5 6a9d4814404d8d51327e5b8306ee3d7e metadata.xml 726
MD5 1d925aed297ec4541fb230dd19e11bc1 files/spawn-fcgi.confd 1076
MD5 f984dc26b2bc491272d302ab453f6e6b files/lighttpd-1.3.13-ldap-binddn.diff 3863
@@ -37,10 +34,3 @@ MD5 ef2a8ad3ae2d26b163bfa379da101e61 files/1.4.1/07_all_fix-dst_addr_buf-leak.di
MD5 beb94165c83f50b8d2eddd9e8cc7dbe9 files/1.4.1/09_all_lfs-range-requests.diff 970
MD5 4dd7328c713617f5b637853edd7ebcfc files/1.4.1/05_all_fix_array_merging.diff 10158
MD5 8a15bebfc64b014d60f78768c94d7839 files/1.4.1/10_all_stat_cache_init_after_setuid.diff 1400
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDEy8REZCkKN40op4RAiqKAKCjQfG8aSaNxMBMPK06BiC3XthDpACeO0Q7
-i1CoMtCvRobjh0IQogk69L0=
-=Q0wf
------END PGP SIGNATURE-----
diff --git a/www-servers/lighttpd/lighttpd-1.4.2.ebuild b/www-servers/lighttpd/lighttpd-1.4.2.ebuild
index 4ed8c39270b9..a78852545da0 100644
--- a/www-servers/lighttpd/lighttpd-1.4.2.ebuild
+++ b/www-servers/lighttpd/lighttpd-1.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/lighttpd/lighttpd-1.4.2.ebuild,v 1.1 2005/08/29 15:51:18 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/lighttpd/lighttpd-1.4.2.ebuild,v 1.2 2005/08/29 17:21:40 ka0ttic Exp $
inherit eutils
@@ -105,6 +105,10 @@ src_unpack() {
# dev-python/docutils installs rst2html.py not rst2html
sed -i -e 's|\(rst2html\)|\1.py|g' doc/Makefile.in || \
die "sed doc/Makefile.in failed"
+
+ # fix a missed /tmp path so that all the tests pass
+ sed -i -e 's|"\(/tmp\)|"@SRCDIR@\1|' tests/lighttpd.conf || \
+ die "sed tests/lighttpd.conf"
}
src_compile() {