summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-12-29 14:50:43 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-12-29 14:50:43 +0000
commit7648a42395579f2b1dc9b4d54afc4eb025fea214 (patch)
tree38e5ebcf4837d3b2ed67e28441a97cd4d19e5621 /www-servers/thttpd
parentVersion bump (diff)
downloadgentoo-2-7648a42395579f2b1dc9b4d54afc4eb025fea214.tar.gz
gentoo-2-7648a42395579f2b1dc9b4d54afc4eb025fea214.tar.bz2
gentoo-2-7648a42395579f2b1dc9b4d54afc4eb025fea214.zip
Cleanup older versions
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'www-servers/thttpd')
-rw-r--r--www-servers/thttpd/ChangeLog11
-rw-r--r--www-servers/thttpd/files/thttpd-2.25/additional-input-validation-httpd.c.diff62
-rw-r--r--www-servers/thttpd/files/thttpd-2.25/fix-buffer-overflow.diff21
-rw-r--r--www-servers/thttpd/files/thttpd-2.25/fix-insecure-tmp-creation-CVE-2005-3124.diff19
-rw-r--r--www-servers/thttpd/files/thttpd-2.25/thttpd.conf.sample38
-rw-r--r--www-servers/thttpd/files/thttpd-2.25/thttpd.confd27
-rw-r--r--www-servers/thttpd/files/thttpd-2.25/thttpd.init30
-rw-r--r--www-servers/thttpd/files/thttpd-2.25b-glibc-2.10.patch21
-rw-r--r--www-servers/thttpd/thttpd-2.25b-r7.ebuild66
-rw-r--r--www-servers/thttpd/thttpd-2.26.2.ebuild61
10 files changed, 10 insertions, 346 deletions
diff --git a/www-servers/thttpd/ChangeLog b/www-servers/thttpd/ChangeLog
index db217f76d595..f49f25c46044 100644
--- a/www-servers/thttpd/ChangeLog
+++ b/www-servers/thttpd/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for www-servers/thttpd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/thttpd/ChangeLog,v 1.54 2012/12/29 14:33:27 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/thttpd/ChangeLog,v 1.55 2012/12/29 14:50:42 blueness Exp $
+
+ 29 Dec 2012; Anthony G. Basile <blueness@gentoo.org>
+ -files/thttpd-2.25/additional-input-validation-httpd.c.diff,
+ -files/thttpd-2.25/fix-buffer-overflow.diff,
+ -files/thttpd-2.25/fix-insecure-tmp-creation-CVE-2005-3124.diff,
+ -files/thttpd-2.25/thttpd.conf.sample, -files/thttpd-2.25/thttpd.confd,
+ -files/thttpd-2.25/thttpd.init, -files/thttpd-2.25b-glibc-2.10.patch,
+ -thttpd-2.25b-r7.ebuild, -thttpd-2.26.2.ebuild:
+ Cleanup older versions
29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> thttpd-2.26.4-r1.ebuild:
Stable for sparc, wrt bug #441548
diff --git a/www-servers/thttpd/files/thttpd-2.25/additional-input-validation-httpd.c.diff b/www-servers/thttpd/files/thttpd-2.25/additional-input-validation-httpd.c.diff
deleted file mode 100644
index 04f59eac8e39..000000000000
--- a/www-servers/thttpd/files/thttpd-2.25/additional-input-validation-httpd.c.diff
+++ /dev/null
@@ -1,62 +0,0 @@
---- thttpd-2.25b/extras/htpasswd.c.orig 2006-03-31 04:12:42.281317000 +0000
-+++ thttpd-2.25b/extras/htpasswd.c 2006-03-31 05:21:37.741632392 +0000
-@@ -151,6 +151,7 @@ void interrupted(int signo) {
- int main(int argc, char *argv[]) {
- FILE *tfp,*f;
- char user[MAX_STRING_LEN];
-+ char pwfilename[MAX_STRING_LEN];
- char line[MAX_STRING_LEN];
- char l[MAX_STRING_LEN];
- char w[MAX_STRING_LEN];
-@@ -168,6 +169,25 @@ int main(int argc, char *argv[]) {
- perror("fopen");
- exit(1);
- }
-+ if (strlen(argv[2]) > (sizeof(pwfilename) - 1)) {
-+ fprintf(stderr, "%s: filename is too long\n", argv[0]);
-+ exit(1);
-+ }
-+ if (((strchr(argv[2], ';')) != NULL) || ((strchr(argv[2], '>')) != NULL)) {
-+ fprintf(stderr, "%s: filename contains an illegal character\n",
-+ argv[0]);
-+ exit(1);
-+ }
-+ if (strlen(argv[3]) > (sizeof(user) - 1)) {
-+ fprintf(stderr, "%s: username is too long\n", argv[0],
-+ sizeof(user) - 1);
-+ exit(1);
-+ }
-+ if ((strchr(argv[3], ':')) != NULL) {
-+ fprintf(stderr, "%s: username contains an illegal character\n",
-+ argv[0]);
-+ exit(1);
-+ }
- printf("Adding password for %s.\n",argv[3]);
- add_password(argv[3],tfp);
- fclose(tfp);
-@@ -180,6 +200,25 @@ int main(int argc, char *argv[]) {
- exit(1);
- }
-
-+ if (strlen(argv[1]) > (sizeof(pwfilename) - 1)) {
-+ fprintf(stderr, "%s: filename is too long\n", argv[0]);
-+ exit(1);
-+ }
-+ if (((strchr(argv[1], ';')) != NULL) || ((strchr(argv[1], '>')) != NULL)) {
-+ fprintf(stderr, "%s: filename contains an illegal character\n",
-+ argv[0]);
-+ exit(1);
-+ }
-+ if (strlen(argv[2]) > (sizeof(user) - 1)) {
-+ fprintf(stderr, "%s: username is too long\n", argv[0],
-+ sizeof(user) - 1);
-+ exit(1);
-+ }
-+ if ((strchr(argv[2], ':')) != NULL) {
-+ fprintf(stderr, "%s: username contains an illegal character\n",
-+ argv[0]);
-+ exit(1);
-+ }
- if(!(f = fopen(argv[1],"r"))) {
- fprintf(stderr,
- "Could not open passwd file %s for reading.\n",argv[1]);
diff --git a/www-servers/thttpd/files/thttpd-2.25/fix-buffer-overflow.diff b/www-servers/thttpd/files/thttpd-2.25/fix-buffer-overflow.diff
deleted file mode 100644
index cacd7321486a..000000000000
--- a/www-servers/thttpd/files/thttpd-2.25/fix-buffer-overflow.diff
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Nrup thttpd-2.25b.orig/libhttpd.c thttpd-2.25b/libhttpd.c
---- thttpd-2.25b.orig/libhttpd.c 2003-12-25 19:06:05.000000000 +0000
-+++ thttpd-2.25b/libhttpd.c 2007-01-08 21:43:28.000000000 +0000
-@@ -1469,7 +1469,7 @@ expand_symlinks( char* path, char** rest
- httpd_realloc_str( &checked, &maxchecked, checkedlen );
- (void) strcpy( checked, path );
- /* Trim trailing slashes. */
-- while ( checked[checkedlen - 1] == '/' )
-+ while ( checkedlen && checked[checkedlen - 1] == '/' )
- {
- checked[checkedlen - 1] = '\0';
- --checkedlen;
-@@ -1488,7 +1488,7 @@ expand_symlinks( char* path, char** rest
- restlen = strlen( path );
- httpd_realloc_str( &rest, &maxrest, restlen );
- (void) strcpy( rest, path );
-- if ( rest[restlen - 1] == '/' )
-+ if ( restlen && rest[restlen - 1] == '/' )
- rest[--restlen] = '\0'; /* trim trailing slash */
- if ( ! tildemapped )
- /* Remove any leading slashes. */
diff --git a/www-servers/thttpd/files/thttpd-2.25/fix-insecure-tmp-creation-CVE-2005-3124.diff b/www-servers/thttpd/files/thttpd-2.25/fix-insecure-tmp-creation-CVE-2005-3124.diff
deleted file mode 100644
index c41ec46b9718..000000000000
--- a/www-servers/thttpd/files/thttpd-2.25/fix-insecure-tmp-creation-CVE-2005-3124.diff
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -ru thttpd-2.23beta1.orig/extras/syslogtocern thttpd-2.23beta1/extras/syslogtocern
---- thttpd-2.23beta1.orig/extras/syslogtocern 1999-09-15 18:00:54.000000000 +0200
-+++ thttpd-2.23beta1/extras/syslogtocern 2005-10-26 01:45:34.000000000 +0200
-@@ -31,8 +31,8 @@
- exit 1
- fi
-
--tmp1=/tmp/stc1.$$
--rm -f $tmp1
-+tmp1=``mktemp -t stc1.XXXXXX` || { echo "$0: Cannot create temporary file" >&2; exit 1; }
-+trap " [ -f \"$tmp1\" ] && /bin/rm -f -- \"$tmp1\"" 0 1 2 3 13 15
-
- # Gather up all the thttpd entries.
- egrep ' thttpd\[' $* > $tmp1
-@@ -65,4 +65,3 @@
- sed -e "s,\([A-Z][a-z][a-z] [0-9 ][0-9] [0-9][0-9]:[0-9][0-9]:[0-9][0-9]\) [^ ]* thttpd\[[0-9]*\]: \(.*\),[\1 ${year}] \2," > error_log
-
- # Done.
--rm -f $tmp1
diff --git a/www-servers/thttpd/files/thttpd-2.25/thttpd.conf.sample b/www-servers/thttpd/files/thttpd-2.25/thttpd.conf.sample
deleted file mode 100644
index e70173206f85..000000000000
--- a/www-servers/thttpd/files/thttpd-2.25/thttpd.conf.sample
+++ /dev/null
@@ -1,38 +0,0 @@
-## /etc/thttpd.conf
-##
-## do not leave empty lines in here!
-## format is: key=value
-##
-## run in debug-mode?
-#debug
-##
-## what interface to bind to?
-## (default is binding to any interface)
-#host=www.example.org
-port=8080
-user=nobody
-##
-## CGI:
-## ? match a single char
-## * matches any string excluding "/"
-## ** matches any string including "/"
-## separate multiple patterns with "|"
-#cgipat=**.sh|**.cgi
-##
-## chroot:
-chroot
-#nochroot
-##
-logfile=/var/log/thttpd.log
-pidfile=/var/run/thttpd.pid
-##
-charset=iso-8859-1
-##
-## control the caching: (in secs)
-#maxage 60
-##
-## virtual hosting:
-#vhost
-##
-## cache-control: send this "max-age" in all HTTP-responses:
-#max-age=0
diff --git a/www-servers/thttpd/files/thttpd-2.25/thttpd.confd b/www-servers/thttpd/files/thttpd-2.25/thttpd.confd
deleted file mode 100644
index 453636c4b518..000000000000
--- a/www-servers/thttpd/files/thttpd-2.25/thttpd.confd
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/www-servers/thttpd/files/thttpd-2.25/thttpd.confd,v 1.1 2004/08/08 18:34:03 stuart Exp $
-
-## Config file for /etc/init.d/thttpd
-
-## the startup-dir of thttpd is the docroot, so we specify it here
-## and the init-script does a "cd" prior to startup:
-THTTPD_DOCROOT="/var/www/localhost"
-
-## There are 2 ways to configure thttpd:
-## 1) specify all params on the cmd-line
-## 2) use a config-file (and start with "-C <conf-file>")
-## Note: 1) and 2) can be mixed.
-##
-## We choose 1) here -- if you have a more complicated setup read
-## thttpd(8) for details on 2).
-
-THTTPD_OPTS="-p 8080 -u nobody -r -i /var/run/thttpd.pid -l /var/log/thttpd.log"
-
-## For a more complex setup (e.g. cgi-support) use an external configfile:
-## comment the THTTPD_OPTS line above und use the one below.
-#THTTPD_OPTS="-C /etc/thttpd/thttpd.conf"
-
-## If you know what you are doing you can add cgi-support with the line below;
-## but you _should_ use the extern-configfile version!
-#THTTPD_OPTS="$THTTPD_OPTS -c **.cgi|**.sh"
diff --git a/www-servers/thttpd/files/thttpd-2.25/thttpd.init b/www-servers/thttpd/files/thttpd-2.25/thttpd.init
deleted file mode 100644
index 0821887c3b21..000000000000
--- a/www-servers/thttpd/files/thttpd-2.25/thttpd.init
+++ /dev/null
@@ -1,30 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/www-servers/thttpd/files/thttpd-2.25/thttpd.init,v 1.2 2006/09/06 14:31:17 dsd Exp $
-
-depend() {
- need net
-}
-
-start() {
- ebegin "Starting thttpd"
- if [ ! -d "$THTTPD_DOCROOT" ]; then
- eend 1 "THTTPD_DOCROOT not set correctly in /etc/conf.d/thttpd"
- exit 1
- fi
- start-stop-daemon --quiet --start --startas /usr/sbin/thttpd \
- --pidfile /var/run/thttpd.pid --chdir "$THTTPD_DOCROOT" -- \
- ${THTTPD_OPTS}
- eend $?
-}
-
-stop() {
- local rc
-
- ebegin "Stopping thttpd"
- start-stop-daemon --quiet --stop --pidfile /var/run/thttpd.pid
- rc=$?
- rm -f /var/run/thttpd.pid
- eend $rc
-}
diff --git a/www-servers/thttpd/files/thttpd-2.25b-glibc-2.10.patch b/www-servers/thttpd/files/thttpd-2.25b-glibc-2.10.patch
deleted file mode 100644
index c97227827e4b..000000000000
--- a/www-servers/thttpd/files/thttpd-2.25b-glibc-2.10.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -ur thttpd-2.25b.orig/extras/htpasswd.c thttpd-2.25b/extras/htpasswd.c
---- thttpd-2.25b.orig/extras/htpasswd.c 2001-12-19 02:08:08.000000000 +0200
-+++ thttpd-2.25b/extras/htpasswd.c 2009-08-09 16:40:06.000000000 +0300
-@@ -49,7 +49,7 @@
- while((line[y++] = line[x++]));
- }
-
--static int getline(char *s, int n, FILE *f) {
-+static int get_line(char *s, int n, FILE *f) {
- register int i=0;
-
- while(1) {
-@@ -189,7 +189,7 @@
- strcpy(user,argv[2]);
-
- found = 0;
-- while(!(getline(line,MAX_STRING_LEN,f))) {
-+ while(!(get_line(line,MAX_STRING_LEN,f))) {
- if(found || (line[0] == '#') || (!line[0])) {
- putline(tfp,line);
- continue;
diff --git a/www-servers/thttpd/thttpd-2.25b-r7.ebuild b/www-servers/thttpd/thttpd-2.25b-r7.ebuild
deleted file mode 100644
index 0375e1deea92..000000000000
--- a/www-servers/thttpd/thttpd-2.25b-r7.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/thttpd/thttpd-2.25b-r7.ebuild,v 1.8 2012/07/11 23:36:11 blueness Exp $
-
-inherit eutils flag-o-matic
-
-MY_P="${P%[a-z]*}"
-
-DESCRIPTION="Small and fast multiplexing webserver."
-HOMEPAGE="http://www.acme.com/software/thttpd/"
-SRC_URI="http://www.acme.com/software/thttpd/${P}.tar.gz"
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ~mips ppc sparc x86 ~x86-fbsd"
-IUSE="static"
-
-THTTPD_USER=thttpd
-THTTPD_GROUP=thttpd
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${MY_P}/*.diff
- epatch "${FILESDIR}"/${P}-glibc-2.10.patch
-}
-
-pkg_setup() {
- enewgroup ${THTTPD_GROUP}
- enewuser ${THTTPD_USER} -1 -1 -1 ${THTTPD_GROUP}
-}
-
-src_compile() {
- ## TODO: what to do with IPv6?
- use static && append-ldflags -static
-
- econf || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install () {
- dodir /usr/share/man/man1
- make prefix="${D}"/usr \
- MANDIR="${D}"/usr/share/man \
- WEBGROUP=${THTTPD_GROUP} \
- WEBDIR="${D}"/var/www/localhost \
- "$@" install || die "make install failed"
-
- mv "${D}"/usr/sbin/{,th_}htpasswd
- mv "${D}"/usr/share/man/man1/{,th_}htpasswd.1
-
- newinitd "${FILESDIR}"/${MY_P}/thttpd.init thttpd
- newconfd "${FILESDIR}"/${MY_P}/thttpd.confd thttpd
-
- dodoc README INSTALL TODO
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}/thttpd.logrotate" thttpd
-
- insinto /etc/thttpd
- doins "${FILESDIR}"/${MY_P}/thttpd.conf.sample
-}
-
-pkg_postinst() {
- elog "Adjust THTTPD_DOCROOT in /etc/conf.d/thttpd !"
-}
diff --git a/www-servers/thttpd/thttpd-2.26.2.ebuild b/www-servers/thttpd/thttpd-2.26.2.ebuild
deleted file mode 100644
index fedc096bc980..000000000000
--- a/www-servers/thttpd/thttpd-2.26.2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/thttpd/thttpd-2.26.2.ebuild,v 1.9 2012/08/19 16:25:30 armin76 Exp $
-
-EAPI="4"
-
-inherit eutils flag-o-matic toolchain-funcs
-
-MY_P="s${P}"
-
-DESCRIPTION="Fork of thttpd, a small, fast, multiplexing webserver."
-HOMEPAGE="http://opensource.dyc.edu/sthttpd"
-SRC_URI="http://opensource.dyc.edu/pub/sthttpd/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND=""
-DEPEND=""
-
-THTTPD_USER=thttpd
-THTTPD_GROUP=thttpd
-THTTPD_DOCROOT="${EPREFIX}/var/www/localhost/htdocs"
-
-DOCS=( README TODO )
-
-pkg_setup() {
- ebegin "Creating thttpd user and group"
- enewgroup ${THTTPD_GROUP}
- enewuser ${THTTPD_USER} -1 -1 -1 ${THTTPD_GROUP}
-}
-
-src_configure() {
- econf WEBDIR=${THTTPD_DOCROOT}
-}
-
-src_install () {
- default
-
- newinitd "${FILESDIR}"/thttpd.init thttpd
- newconfd "${FILESDIR}"/thttpd.confd thttpd
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}/thttpd.logrotate" thttpd
-
- insinto /etc/thttpd
- doins "${FILESDIR}"/thttpd.conf.sample
-}
-
-pkg_postinst() {
- chown root:${THTTPD_GROUP} "${EROOT}/usr/sbin/makeweb" \
- || die "Failed chown makeweb"
- chmod 2751 "${EROOT}/usr/sbin/makeweb" \
- || die "Failed chmod makeweb"
- chmod 755 "${THTTPD_DOCROOT}/cgi-bin/printenv" \
- || die "Failed chmod printenv"
- elog "Adjust THTTPD_DOCROOT in /etc/conf.d/thttpd !"
-}