summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2005-03-27 17:26:44 +0000
committerStuart Herbert <stuart@gentoo.org>2005-03-27 17:26:44 +0000
commit7d93da17ea23e6910b5704ae1095460c283577e1 (patch)
treed82e096b4ae817fc80b437e33d196929b0f857a0 /www-servers/thttpd
parentAdded second revision of php5-sapi eclass (diff)
downloadgentoo-2-7d93da17ea23e6910b5704ae1095460c283577e1.tar.gz
gentoo-2-7d93da17ea23e6910b5704ae1095460c283577e1.tar.bz2
gentoo-2-7d93da17ea23e6910b5704ae1095460c283577e1.zip
Added php support
(Portage version: 2.0.51.19)
Diffstat (limited to 'www-servers/thttpd')
-rw-r--r--www-servers/thttpd/Manifest22
-rw-r--r--www-servers/thttpd/thttpd-2.25b-r2.ebuild97
2 files changed, 106 insertions, 13 deletions
diff --git a/www-servers/thttpd/Manifest b/www-servers/thttpd/Manifest
index 67c499f602d3..552d96906233 100644
--- a/www-servers/thttpd/Manifest
+++ b/www-servers/thttpd/Manifest
@@ -1,19 +1,15 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 9638e3f16ce376f6259c3963fe78da43 thttpd-2.25b-r1.ebuild 1234
MD5 81ad0c3d58b6031c8e4774fb9e38116b ChangeLog 1607
MD5 4a186842848d9c384e2d12785ba426bc metadata.xml 165
MD5 01cfdda0a52d777aa2c814dcf4ba9d95 thttpd-2.25b.ebuild 1188
-MD5 1e6cbba778f6846533ae1d69310e0c4e files/digest-thttpd-2.25b-r1 64
+MD5 9638e3f16ce376f6259c3963fe78da43 thttpd-2.25b-r1.ebuild 1234
+MD5 49909dbc71b581aed05a308fbd456896 thttpd-2.25b-r2.ebuild 2001
MD5 1e6cbba778f6846533ae1d69310e0c4e files/digest-thttpd-2.25b 64
+MD5 1e6cbba778f6846533ae1d69310e0c4e files/digest-thttpd-2.25b-r1 64
+MD5 6f77a5ae06c1e805c8ba4f18ef210040 files/digest-thttpd-2.25b-r2 126
+MD5 ad986b02a371b2fea3b4ae5060c9dc81 files/php5.0-stdint.diff 358
+MD5 f7a7898637874593f519c336db79fa45 files/php-5.0.3-missing-arches.patch 524
+MD5 273799e60d5a41a1e6f5ac53781a152f files/php5_soap_persistence_session.diff 1976
+MD5 1d3e759791468812bd3c6dd786428cac files/thttpd-2.25/thttpd.conf.sample 672
MD5 84af2600ce2cfa9331871027accd00f5 files/thttpd-2.25/thttpd.confd 1152
MD5 98bfd7ed90b6a438a940413d5e541c29 files/thttpd-2.25/thttpd.init 828
-MD5 1d3e759791468812bd3c6dd786428cac files/thttpd-2.25/thttpd.conf.sample 672
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFCLbn/EZCkKN40op4RAm4UAKC9q3z+vlsFOz8N8ZB63TtUK8Y7vwCfXop7
-N5rBkfmyLxjtED0V0jU84Mg=
-=3U44
------END PGP SIGNATURE-----
+MD5 8c8c8edd7b2bc08ca093377c6ed10dae files/thttpd-2.25/php-5.0.3-thttpd-2.25b.patch 11525
diff --git a/www-servers/thttpd/thttpd-2.25b-r2.ebuild b/www-servers/thttpd/thttpd-2.25b-r2.ebuild
new file mode 100644
index 000000000000..305208cdd0d6
--- /dev/null
+++ b/www-servers/thttpd/thttpd-2.25b-r2.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/thttpd/thttpd-2.25b-r2.ebuild,v 1.1 2005/03/27 17:26:44 stuart Exp $
+
+PHPSAPI="thttpd"
+
+MY_PHP_P="php-5.0.3"
+MY_THTTPD_P="${P%[a-z]*}"
+
+inherit php5-sapi-r1 flag-o-matic
+
+DESCRIPTION="Small and fast multiplexing webserver."
+HOMEPAGE="http://www.acme.com/software/thttpd/"
+SRC_URI="http://www.acme.com/software/thttpd/${P}.tar.gz
+ php? ( http://www.php.net/distributions/${MY_PHP_P}.tar.gz )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="static php"
+
+DEPEND="virtual/libc"
+
+PHP_S="${WORKDIR}/${MY_PHP_P}"
+
+pkg_setup() {
+ if useq php ; then
+ php5-sapi-r2_pkg_setup
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ if useq php ; then
+ cd ${WORKDIR}
+ epatch ${FILESDIR}/${MY_THTTPD_P}/php-5.0.3-thttpd-2.25b.patch
+ epatch ${FILESDIR}/php-5.0.3-IOV.patch
+ php5-sapi-r2_src_unpack
+ fi
+}
+
+src_compile() {
+ # compile PHP5 first
+ if useq php ; then
+ my_conf="--with-thttpd=${S}"
+ php5-sapi-r2_src_compile
+ php5-sapi-r2_src_install
+ fi
+
+ cd ${S}
+
+ ## TODO: what to do with IPv6?
+
+ append-ldflags -Wl,-z,now
+ use static && append-ldflags -static
+
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ if useq php ; then
+ # we have to do the install again, because Portage wipes anything
+ # put into $D during src_compile
+ #
+ # ideally, we need to improve the eclass
+ php5-sapi-r2_src_install
+ fi
+
+ cd ${S}
+ dodir /usr/share/man/man1
+ make prefix=${D}/usr \
+ MANDIR=${D}/usr/share/man \
+ WEBGROUP=nogroup \
+ WEBDIR=${D}/var/www/localhost \
+ "$@" install || die "make install failed"
+
+ mv ${D}/usr/sbin/{,th_}htpasswd
+ mv ${D}/usr/share/man/man1/{,th_}htpasswd.1
+
+ newinitd ${FILESDIR}/${MY_THTTPD_P}/thttpd.init thttpd
+ newconfd ${FILESDIR}/${MY_THTTPD_P}/thttpd.confd thttpd
+
+ dodoc README INSTALL TODO
+
+ insinto /etc/thttpd
+ doins ${FILESDIR}/${MY_THTTPD_P}/thttpd.conf.sample
+}
+
+pkg_postinst() {
+ if useq php ; then
+ php5-sapi-r2_pkg_postinst
+ fi
+
+ einfo "Adjust THTTPD_DOCROOT in /etc/conf.d/thttpd !"
+}