summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-04-12 22:45:47 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-04-12 22:45:47 +0000
commit0083b9cb7bc965ca2c16d9fcc34e45bbb2b19af0 (patch)
tree6cacf7cfd40bbd478f8278b03c2a42e101a8008a /www-servers/varnish
parentVersion bump to 1.8.0. (diff)
downloadgentoo-2-0083b9cb7bc965ca2c16d9fcc34e45bbb2b19af0.tar.gz
gentoo-2-0083b9cb7bc965ca2c16d9fcc34e45bbb2b19af0.tar.bz2
gentoo-2-0083b9cb7bc965ca2c16d9fcc34e45bbb2b19af0.zip
Bump to new 4.0 branch
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'www-servers/varnish')
-rw-r--r--www-servers/varnish/ChangeLog9
-rw-r--r--www-servers/varnish/files/varnish-4.0.0-fix-man-Makefile_am.patch14
-rw-r--r--www-servers/varnish/files/varnishd.service5
-rw-r--r--www-servers/varnish/varnish-4.0.0.ebuild90
4 files changed, 116 insertions, 2 deletions
diff --git a/www-servers/varnish/ChangeLog b/www-servers/varnish/ChangeLog
index 74686f293ec4..b10c4ecce7d2 100644
--- a/www-servers/varnish/ChangeLog
+++ b/www-servers/varnish/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-servers/varnish
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/ChangeLog,v 1.75 2014/03/31 21:25:22 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/ChangeLog,v 1.76 2014/04/12 22:45:47 blueness Exp $
+
+*varnish-4.0.0 (12 Apr 2014)
+
+ 12 Apr 2014; Anthony G. Basile <blueness@gentoo.org>
+ +files/varnish-4.0.0-fix-man-Makefile_am.patch, +varnish-4.0.0.ebuild,
+ files/varnishd.service:
+ Bump to new 4.0 branch
31 Mar 2014; Michał Górny <mgorny@gentoo.org> varnish-3.0.5-r3.ebuild,
varnish-3.0.5-r4.ebuild:
diff --git a/www-servers/varnish/files/varnish-4.0.0-fix-man-Makefile_am.patch b/www-servers/varnish/files/varnish-4.0.0-fix-man-Makefile_am.patch
new file mode 100644
index 000000000000..311f0fd7c956
--- /dev/null
+++ b/www-servers/varnish/files/varnish-4.0.0-fix-man-Makefile_am.patch
@@ -0,0 +1,14 @@
+diff -Naur varnish-4.0.0.orig/man/Makefile.am varnish-4.0.0/man/Makefile.am
+--- varnish-4.0.0.orig/man/Makefile.am 2014-04-12 18:25:35.435043191 -0400
++++ varnish-4.0.0/man/Makefile.am 2014-04-12 18:25:58.579043997 -0400
+@@ -84,8 +84,8 @@
+ $(top_srcdir)/doc/sphinx/include/varnishhist_synopsis.rst
+ ${RST2MAN} $(top_srcdir)/doc/sphinx/reference/varnishhist.rst $@
+
+-vmod_std.3: $(top_srcdir)/lib/libvmod_std/vmod_std.man.rst
++vmod_std.3: $(top_builddir)/lib/libvmod_std/vmod_std.man.rst
+ ${RST2MAN} $? $@
+
+-vmod_directors.3: $(top_srcdir)/lib/libvmod_directors/vmod_directors.man.rst
++vmod_directors.3: $(top_builddir)/lib/libvmod_directors/vmod_directors.man.rst
+ ${RST2MAN} $? $@
diff --git a/www-servers/varnish/files/varnishd.service b/www-servers/varnish/files/varnishd.service
index 169206e0714b..a45f1e247839 100644
--- a/www-servers/varnish/files/varnishd.service
+++ b/www-servers/varnish/files/varnishd.service
@@ -7,7 +7,10 @@ Type=forking
LimitNOFILE=32786
LimitMEMLOCK=82000
PIDFile=/var/run/varnishd.pid
-ExecStart=/usr/sbin/varnishd -a 0.0.0.0:80 -f /etc/varnish/default.vcl -P /var/run/varnishd.pid
+ExecStart=/usr/sbin/varnishd -a 0.0.0.0:80 -P /var/run/varnishd.pid
+
+#If you wish to use a config file, then use the following ExecStart line
+#ExecStart=/usr/sbin/varnishd -a 0.0.0.0:80 -f /etc/varnish/default.vcl -P /var/run/varnishd.pid
[Install]
WantedBy=multi-user.target
diff --git a/www-servers/varnish/varnish-4.0.0.ebuild b/www-servers/varnish/varnish-4.0.0.ebuild
new file mode 100644
index 000000000000..d21d9c823dc0
--- /dev/null
+++ b/www-servers/varnish/varnish-4.0.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/varnish-4.0.0.ebuild,v 1.1 2014/04/12 22:45:47 blueness Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
+
+inherit autotools-utils eutils systemd python-single-r1
+
+DESCRIPTION="Varnish is a state-of-the-art, high-performance HTTP accelerator"
+HOMEPAGE="http://www.varnish-cache.org/"
+SRC_URI="http://repo.varnish-cache.org/source/${P}.tar.gz"
+
+LICENSE="BSD-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="jemalloc jit static-libs"
+
+CDEPEND="
+ || ( dev-libs/libedit sys-libs/readline )
+ dev-libs/libpcre[jit?]
+ jemalloc? ( dev-libs/jemalloc )"
+
+#varnish compiles stuff at run time
+RDEPEND="
+ ${PYTHON_DEPS}
+ ${CDEPEND}
+ sys-devel/gcc"
+
+DEPEND="
+ ${CDEPEND}
+ dev-python/docutils
+ virtual/pkgconfig"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="test" #315725
+
+DOCS=( README doc/changes.rst )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.0.0-fix-man-Makefile_am.patch
+)
+
+AUTOTOOLS_AUTORECONF="yes"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Remove bundled libjemalloc. We also fix
+ # automagic dep in our patches, bug #461638
+ rm -rf lib/libjemalloc
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_enable jit pcre-jit )
+ $(use_with jemalloc)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ newinitd "${FILESDIR}"/varnishd.initd-r2 varnishd
+ newconfd "${FILESDIR}"/varnishd.confd-r2 varnishd
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/varnishd.logrotate" varnishd
+
+ dodir /var/log/varnish
+
+ systemd_dounit "${FILESDIR}/${PN}d.service"
+
+ insinto /etc/varnish
+ doins lib/libvmod_std/vmod.vcc
+}
+
+pkg_postinst () {
+ elog "No demo-/sample-configfile is included in the distribution. Please"
+ elog "read the man-page for more info. A sample configuration proxying"
+ elog "localhost:8080 for localhost:80 is given in /etc/conf.d/varnishd."
+}