summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-06-25 08:23:11 +0000
committerMichał Górny <mgorny@gentoo.org>2012-06-25 08:23:11 +0000
commit19f4e6721cdce7dc04a6515bfa6b18e60f26b663 (patch)
tree3068aa289975bbc149946f13c9bcfd58c1f3737d /www-servers
parentVersion bump with bugfixes and systemd support. Drop old. (diff)
downloadgentoo-2-19f4e6721cdce7dc04a6515bfa6b18e60f26b663.tar.gz
gentoo-2-19f4e6721cdce7dc04a6515bfa6b18e60f26b663.tar.bz2
gentoo-2-19f4e6721cdce7dc04a6515bfa6b18e60f26b663.zip
Version bump. The new version fixes build with new iproute2 (bug #423373).
(Portage version: 2.2.0_alpha112_p2/cvs/Linux x86_64)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/pshs/ChangeLog11
-rw-r--r--www-servers/pshs/metadata.xml2
-rw-r--r--www-servers/pshs/pshs-0.2.1.ebuild34
3 files changed, 43 insertions, 4 deletions
diff --git a/www-servers/pshs/ChangeLog b/www-servers/pshs/ChangeLog
index 499a64435bf5..0cf865d1a598 100644
--- a/www-servers/pshs/ChangeLog
+++ b/www-servers/pshs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/pshs
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pshs/ChangeLog,v 1.2 2011/11/16 21:55:56 mgorny Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pshs/ChangeLog,v 1.3 2012/06/25 08:23:11 mgorny Exp $
+
+*pshs-0.2.1 (25 Jun 2012)
+
+ 25 Jun 2012; Michał Górny <mgorny@gentoo.org> +pshs-0.2.1.ebuild,
+ metadata.xml:
+ Version bump. The new version fixes build with new iproute2 (bug #423373).
*pshs-0.2 (16 Nov 2011)
@@ -16,4 +22,3 @@
+metadata.xml:
Add initial version of pretty simple HTTP server, a little CLI tool for file
sharing.
-
diff --git a/www-servers/pshs/metadata.xml b/www-servers/pshs/metadata.xml
index 92ed3ec94dc2..98eabec92224 100644
--- a/www-servers/pshs/metadata.xml
+++ b/www-servers/pshs/metadata.xml
@@ -18,6 +18,6 @@
<email>mgorny@gentoo.org</email>
<name>Michał Górny</name>
</maintainer>
- <bugs-to>http://bugs.gentoo.org/enter_bug.cgi?product=Gentoo%20Linux&amp;component=Applications&amp;short_desc=www-servers/pshs:%20</bugs-to>
+ <bugs-to>https://bitbucket.org/mgorny/pshs/issues/</bugs-to>
</upstream>
</pkgmetadata>
diff --git a/www-servers/pshs/pshs-0.2.1.ebuild b/www-servers/pshs/pshs-0.2.1.ebuild
new file mode 100644
index 000000000000..27cee2bc4527
--- /dev/null
+++ b/www-servers/pshs/pshs-0.2.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pshs/pshs-0.2.1.ebuild,v 1.1 2012/06/25 08:23:11 mgorny Exp $
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="Pretty small HTTP server - a command-line tool to share files"
+HOMEPAGE="https://bitbucket.org/mgorny/pshs/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+magic +netlink upnp"
+
+RDEPEND=">=dev-libs/libevent-2
+ magic? ( sys-apps/file )
+ upnp? ( net-libs/miniupnpc )"
+DEPEND="${RDEPEND}
+ netlink? ( sys-apps/iproute2
+ >=sys-kernel/linux-headers-2.6.27 )"
+# libnetlink is static only ATM
+
+src_configure() {
+ myeconfargs=(
+ $(use_enable magic libmagic)
+ $(use_enable netlink)
+ $(use_enable upnp)
+ )
+
+ autotools-utils_src_configure
+}