summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-04-01 04:50:02 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-04-01 04:50:02 +0000
commit1dbd02a09bcab30aa6ba438d10b399a2d4c168ea (patch)
tree3c742c65a496dde5b4859ce46b05d9ce4bb1bc2b /www-servers
parentpython-dateutil no longer needs a slot dep. (diff)
downloadgentoo-2-1dbd02a09bcab30aa6ba438d10b399a2d4c168ea.tar.gz
gentoo-2-1dbd02a09bcab30aa6ba438d10b399a2d4c168ea.tar.bz2
gentoo-2-1dbd02a09bcab30aa6ba438d10b399a2d4c168ea.zip
Bump for #405767
(Portage version: 2.2.0_alpha97/cvs/Linux x86_64)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/apache/ChangeLog7
-rw-r--r--www-servers/apache/apache-2.4.1.ebuild124
2 files changed, 130 insertions, 1 deletions
diff --git a/www-servers/apache/ChangeLog b/www-servers/apache/ChangeLog
index 8b885ef4af85..57f841fa45c1 100644
--- a/www-servers/apache/ChangeLog
+++ b/www-servers/apache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/apache
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/ChangeLog,v 1.180 2012/03/29 10:40:41 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/ChangeLog,v 1.181 2012/04/01 04:50:02 patrick Exp $
+
+*apache-2.4.1 (01 Apr 2012)
+
+ 01 Apr 2012; Patrick Lauer <patrick@gentoo.org> +apache-2.4.1.ebuild:
+ Bump for #405767
29 Mar 2012; Agostino Sarubbo <ago@gentoo.org> apache-2.2.22.ebuild:
Stable for amd64, wrt bug #401761
diff --git a/www-servers/apache/apache-2.4.1.ebuild b/www-servers/apache/apache-2.4.1.ebuild
new file mode 100644
index 000000000000..8c452e5d5949
--- /dev/null
+++ b/www-servers/apache/apache-2.4.1.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.4.1.ebuild,v 1.1 2012/04/01 04:50:02 patrick Exp $
+
+EAPI="2"
+
+# latest gentoo apache files
+GENTOO_PATCHSTAMP="20120401"
+GENTOO_DEVELOPER="patrick"
+
+# IUSE/USE_EXPAND magic
+IUSE_MPMS_FORK="itk peruser prefork"
+IUSE_MPMS_THREAD="event worker"
+
+IUSE_MODULES="actions alias asis auth_basic auth_digest authn_alias authn_anon
+authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default
+authz_groupfile authz_host authz_owner authz_user autoindex cache cern_meta
+charset_lite cgi cgid dav dav_fs dav_lock dbd deflate dir disk_cache dumpio
+env expires ext_filter file_cache filter headers ident imagemap include info
+log_config log_forensic logio mem_cache mime mime_magic negotiation proxy
+proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_http proxy_scgi rewrite
+reqtimeout setenvif speling status substitute unique_id userdir usertrack
+version vhost_alias"
+# The following are also in the source as of this version, but are not available
+# for user selection:
+# bucketeer case_filter case_filter_in echo http isapi optional_fn_export
+# optional_fn_import optional_hook_export optional_hook_import
+
+# inter-module dependencies
+# TODO: this may still be incomplete
+MODULE_DEPENDS="
+ dav_fs:dav
+ dav_lock:dav
+ deflate:filter
+ disk_cache:cache
+ ext_filter:filter
+ file_cache:cache
+ log_forensic:log_config
+ logio:log_config
+ mem_cache:cache
+ mime_magic:mime
+ proxy_ajp:proxy
+ proxy_balancer:proxy
+ proxy_connect:proxy
+ proxy_ftp:proxy
+ proxy_http:proxy
+ proxy_scgi:proxy
+ substitute:filter
+"
+
+# module<->define mappings
+MODULE_DEFINES="
+ auth_digest:AUTH_DIGEST
+ authnz_ldap:AUTHNZ_LDAP
+ cache:CACHE
+ dav:DAV
+ dav_fs:DAV
+ dav_lock:DAV
+ disk_cache:CACHE
+ file_cache:CACHE
+ info:INFO
+ ldap:LDAP
+ mem_cache:CACHE
+ proxy:PROXY
+ proxy_ajp:PROXY
+ proxy_balancer:PROXY
+ proxy_connect:PROXY
+ proxy_ftp:PROXY
+ proxy_http:PROXY
+ ssl:SSL
+ status:STATUS
+ suexec:SUEXEC
+ userdir:USERDIR
+"
+
+# critical modules for the default config
+MODULE_CRITICAL="
+ authz_host
+ dir
+ mime
+"
+
+inherit apache-2
+
+DESCRIPTION="The Apache Web Server."
+HOMEPAGE="http://httpd.apache.org/"
+
+# some helper scripts are Apache-1.1, thus both are here
+LICENSE="Apache-2.0 Apache-1.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND="${DEPEND}
+ >=dev-libs/openssl-0.9.8m
+ apache2_modules_deflate? ( sys-libs/zlib )"
+
+# dependency on >=dev-libs/apr-1.4.5 for bug #368651
+RDEPEND="${RDEPEND}
+ >=dev-libs/apr-1.4.5
+ >=dev-libs/openssl-0.9.8m
+ apache2_modules_mime? ( app-misc/mime-types )"
+
+# init script fixup - should be rolled into next tarball #389965
+src_prepare() {
+ apache-2_src_prepare
+ sed -i -e 's/! test -f/test -f/' "${GENTOO_PATCHDIR}"/init/apache2.initd || die "Failed to fix init script"
+}
+
+src_install() {
+ apache-2_src_install
+ for i in /usr/bin/{htdigest,logresolve,htpasswd,htdbm,ab,httxt2dbm}; do
+ rm "${D}"/$i || die "Failed to prune apache-tools bits"
+ done
+ for i in /usr/share/man/man8/{rotatelogs.8,htcacheclean.8}; do
+ rm "${D}"/$i || die "Failed to prune apache-tools bits"
+ done
+ for i in /usr/share/man/man1/{logresolve.1,htdbm.1,htdigest.1,htpasswd.1,dbmmanage.1,ab.1}; do
+ rm "${D}"/$i || die "Failed to prune apache-tools bits"
+ done
+ for i in /usr/sbin/{checkgid,fcgistarter,htcacheclean,rotatelogs}; do
+ rm "${D}/"$i || die "Failed to prune apache-tools bits"
+ done
+}