summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Noël Rivasseau <elvanor@gentoo.org>2011-04-05 17:36:16 +0000
committerJean-Noël Rivasseau <elvanor@gentoo.org>2011-04-05 17:36:16 +0000
commit4b81175e43d9bc0372fd5ce09be3e9206b288067 (patch)
tree616770235ec9c95326543bd7ce88a3ce305a0994 /www-servers
parentFix deprecation warnings. (diff)
downloadgentoo-2-4b81175e43d9bc0372fd5ce09be3e9206b288067.tar.gz
gentoo-2-4b81175e43d9bc0372fd5ce09be3e9206b288067.tar.bz2
gentoo-2-4b81175e43d9bc0372fd5ce09be3e9206b288067.zip
Improvement in init script, bug #191611
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/tomcat/ChangeLog6
-rw-r--r--www-servers/tomcat/files/6/tomcat.init.29
-rw-r--r--www-servers/tomcat/files/6/tomcat.init.37
3 files changed, 12 insertions, 10 deletions
diff --git a/www-servers/tomcat/ChangeLog b/www-servers/tomcat/ChangeLog
index 7af8a3be9aa9..2a68204f77ff 100644
--- a/www-servers/tomcat/ChangeLog
+++ b/www-servers/tomcat/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-servers/tomcat
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.249 2011/03/13 00:08:31 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.250 2011/04/05 17:36:16 elvanor Exp $
+
+ 05 Apr 2011; <elvanor@gentoo.org> files/6/tomcat.init.2:
+ Modified init script for bug #361235 / #191611. Removed the --startas
+ /bin/bash which was apparently causing the problems.
13 Mar 2011; Miroslav Šulc <fordfrog@gentoo.org> -tomcat-7.0.8.ebuild,
-tomcat-7.0.10.ebuild:
diff --git a/www-servers/tomcat/files/6/tomcat.init.2 b/www-servers/tomcat/files/6/tomcat.init.2
index 4411548872b8..10738925e96f 100644
--- a/www-servers/tomcat/files/6/tomcat.init.2
+++ b/www-servers/tomcat/files/6/tomcat.init.2
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/6/tomcat.init.2,v 1.1 2010/06/06 12:32:34 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/6/tomcat.init.2,v 1.2 2011/04/05 17:36:16 elvanor Exp $
opts="${opts} forcestop"
@@ -59,9 +59,8 @@ ssd() {
--stderr ${CATALINA_BASE}/logs/catalina.out"
start-stop-daemon ${args} --exec ${exec} -- ${OPTS_CP} "$@" ${CATALINA_ARGS} ${TOMCAT_START}
else
- start-stop-daemon ${args} --startas /bin/bash -- -c \
- "exec ${exec} ${OPTS_CP} $@ ${CATALINA_ARGS} ${TOMCAT_START} >> \
- \"$CATALINA_BASE/logs/catalina.out\" 2>&1"
+ start-stop-daemon ${args} --exec ${exec} -- ${OPTS_CP} "$@" ${CATALINA_ARGS} ${TOMCAT_START} >> \
+ "${CATALINA_BASE}/logs/catalina.out" 2>&1
fi
return $?
}
diff --git a/www-servers/tomcat/files/6/tomcat.init.3 b/www-servers/tomcat/files/6/tomcat.init.3
index 9cde76382c7c..17c92aa51c3e 100644
--- a/www-servers/tomcat/files/6/tomcat.init.3
+++ b/www-servers/tomcat/files/6/tomcat.init.3
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/6/tomcat.init.3,v 1.1 2011/02/14 23:09:40 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/6/tomcat.init.3,v 1.2 2011/04/05 17:36:16 elvanor Exp $
opts="${opts} forcestop"
@@ -59,9 +59,8 @@ ssd() {
--stderr ${CATALINA_BASE}/logs/catalina.out"
start-stop-daemon ${args} --exec ${exec} -- ${OPTS_CP} "$@" ${CATALINA_ARGS} ${TOMCAT_START}
else
- start-stop-daemon ${args} --name ${exec} --startas /bin/bash -- -c \
- "exec ${exec} ${OPTS_CP} $@ ${CATALINA_ARGS} ${TOMCAT_START} >> \
- \"$CATALINA_BASE/logs/catalina.out\" 2>&1"
+ start-stop-daemon ${args} --name ${exec} --exec ${exec} -- ${OPTS_CP} "$@" ${CATALINA_ARGS} ${TOMCAT_START} >> \
+ "${CATALINA_BASE}/logs/catalina.out" 2>&1
fi
return $?
}