summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-07-08 12:11:34 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-07-08 12:11:34 +0000
commit745ed5c5d5c975e6ee0a23ee71d52247edfe4d09 (patch)
tree811441452f6123dfd454853b21077bae21819661 /www-servers
parentMasking some CD/DVD-Recording tools. (diff)
downloadgentoo-2-745ed5c5d5c975e6ee0a23ee71d52247edfe4d09.tar.gz
gentoo-2-745ed5c5d5c975e6ee0a23ee71d52247edfe4d09.tar.bz2
gentoo-2-745ed5c5d5c975e6ee0a23ee71d52247edfe4d09.zip
* amd64-fixes added
(Portage version: 2.1.1_pre2-r4)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog8
-rw-r--r--www-servers/nginx/files/digest-nginx-0.3.53-r13
-rw-r--r--www-servers/nginx/files/nginx-0.3.53-amd64_fixes.patch29
-rw-r--r--www-servers/nginx/nginx-0.3.53-r1.ebuild84
4 files changed, 123 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 1b5bf023f9f8..bd0b571fd7ff 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.99 2006/07/07 20:51:17 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.100 2006/07/08 12:11:34 voxus Exp $
+
+*nginx-0.3.53-r1 (08 Jul 2006)
+
+ 08 Jul 2006; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.3.53-r1.ebuild,
+ -nginx-0.3.53.ebuild:
+ Added patch for amd64 from author.
*nginx-0.3.53 (07 Jul 2006)
diff --git a/www-servers/nginx/files/digest-nginx-0.3.53-r1 b/www-servers/nginx/files/digest-nginx-0.3.53-r1
new file mode 100644
index 000000000000..abead4c9ea1a
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.3.53-r1
@@ -0,0 +1,3 @@
+MD5 c05426aeaa8a5b142ce3aa24082812f4 nginx-0.3.53.tar.gz 407129
+RMD160 3d8fef05d00560504b39746faa8d777bc9c122cc nginx-0.3.53.tar.gz 407129
+SHA256 944a11986124ddbb43ad303abe951b54ea18479eb1cc396b42beddeeaffc7c41 nginx-0.3.53.tar.gz 407129
diff --git a/www-servers/nginx/files/nginx-0.3.53-amd64_fixes.patch b/www-servers/nginx/files/nginx-0.3.53-amd64_fixes.patch
new file mode 100644
index 000000000000..73209b281840
--- /dev/null
+++ b/www-servers/nginx/files/nginx-0.3.53-amd64_fixes.patch
@@ -0,0 +1,29 @@
+--- src/http/ngx_http_request_body.c Fri Jul 7 17:34:30 2006
++++ src/http/ngx_http_request_body.c Sat Jul 8 09:37:55 2006
+@@ -92,7 +92,7 @@
+ rb->bufs->buf = b;
+ rb->bufs->next = NULL;
+
+- if (preread >= r->headers_in.content_length_n) {
++ if ((off_t) preread >= r->headers_in.content_length_n) {
+
+ /* the whole request body was pre-read */
+
+@@ -120,7 +120,7 @@
+
+ rb->rest = r->headers_in.content_length_n - preread;
+
+- if (rb->rest <= (size_t) (b->end - b->last)) {
++ if (rb->rest <= (off_t) (b->end - b->last)) {
+
+ /* the whole request body may be placed in r->header_in */
+
+@@ -242,7 +242,7 @@
+
+ size = rb->buf->end - rb->buf->last;
+
+- if (size > rb->rest) {
++ if ((off_t) size > rb->rest) {
+ size = (size_t) rb->rest;
+ }
+
diff --git a/www-servers/nginx/nginx-0.3.53-r1.ebuild b/www-servers/nginx/nginx-0.3.53-r1.ebuild
new file mode 100644
index 000000000000..1832ad98a7c7
--- /dev/null
+++ b/www-servers/nginx/nginx-0.3.53-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.3.53-r1.ebuild,v 1.1 2006/07/08 12:11:34 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-amd64_fixes.patch
+}
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ cp ${FILESDIR}/nginx-r1 ${T}/nginx
+ doinitd ${T}/nginx
+
+ rm conf/nginx.conf
+ cp ${FILESDIR}/nginx.conf-r2 ${T}/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/* ${T}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+
+ use perl && {
+ cd ${S}/objs/src/http/modules/perl/
+ make DESTDIR=${D} install || die "failed to install perl stuff"
+ }
+}